Shop Discount Sea-Doo Parts

96 gsx no start

Messages
6
Likes
0
Water Crafts
96 sea doo gsx
#1
Took ski out on river ran ok wouldn’t go over 6000 rpm decided to check my jets and clean power valves after doing so I put some gas in carb fired it up with hose running idled at 3000 rpms for a little bit then died out ski would not restart I had no spark tested my coil and replaced it I now have spark plugs were oil failed replaced those still now start tried a little more gas and it just kept cranking no start tested stator and that checked out only thing I noticed is ski doesn’t beep anymore when attaching lanyard don’t think that would cause it though because I’m getting power and spark p.s now I hear a thud and starter barely turns motor
 


mikidymac

Moderator
Staff member
Moderator
Messages
10,802
Likes
945
Location
California
Water Crafts
2003 GTI
2001 XP
1996 XP
1996 HX
1991 Superjet
2001 Superjet
#2
Did you have the hose on with the engine off?

Did you install new genuine mikuni carb parts and check pop-off and leak down after the carbs went back together?
 
Messages
6
Likes
0
Water Crafts
96 sea doo gsx
#3
I thought running hose before starting it would cause the issue which I think I did start hose first.. I took valve cover off to make sure I wasn’t hydro locked up top... and at first no then I read the threads and put my old gaskets back in that we’re in ok shape I did not check pop off because I didn’t switch springs but I would think it would start by adding the fuel to my cylinders to eliminate a carb issue
 
Messages
6
Likes
0
Water Crafts
96 sea doo gsx
#6
After trying to crank for three second sometimes it would stop crank and then I would hear this whining noise like something was spinning compression is 150 btw
 

mikidymac

Moderator
Staff member
Moderator
Messages
10,802
Likes
945
Location
California
Water Crafts
2003 GTI
2001 XP
1996 XP
1996 HX
1991 Superjet
2001 Superjet
#7
Sounds like your starer bendix isn't engaging all the time.

You have compression and you have added fuel so you are missing spark to fire. Have you checked for spark and tried new spark plugs?
 

Users who viewed this discussion (Total:11)

SPONSORED LINKS

Latest posts

Usergroup

Administrator Moderator Premium Member
Top