Need advise

hal5778

Member
Well I have replaced the starter with an OEM,tested both the dess post and s/s button and both okay,fully charged the battery,cleaned all ground connections and hand turned over the motor with the plugs out and it turns freely and smooth and cleaned all ground connections I could locate and there has been no change. I did jump the 2 solenoid posts and the motor did turn over without the clunking noise? In my previous posts I explained the initial issue which was when I push the s/s button the motor will make a clunking noise and then start to turn over normal but when I release the s/s button it will continue to turn over until I press it a few time s and then eventually stop. While the motor is turning over I have no spark at the plugs? When I connect the battery with dess key off it will spark and after a few times it will not spark and if I wait a moment and try it again it will spark? Today I jumped the 2 posts on solenoid and the motor turned over as should without the clunking but still no spark. Although the MPEM in the ski is the one that was in it when purchased I believe it is an aftermarket and the description online says it is suppose to work with any dess key without programming? This issue has been a nightmare for me and any input I can get will be very appreciated. Thanks
 

Attachments

  • 3D60FDE9-B490-4D9F-95B1-4E3D573DDD88.jpeg
    3D60FDE9-B490-4D9F-95B1-4E3D573DDD88.jpeg
    252.2 KB · Views: 3
Fully charging a battery isn't load testing a battery, you want to do that to make sure it has the ability to crank her over. Also sounds like the start switch is bad or the MPEM is bad with the starting continuing after the button is pressed. Unfortunately my suggestion is to get a OEM MPEM, the aftermarket stuff isn't reliable.

Did the ski ever work for you?
 
It was a non running ski when I purchased it in hopes of a minor repair lol. I ordered a new OEM MPEM today and will post the results either way. Thanks for all the input!!
 
Check the voltage drop on the wires going to the starter. Did you replace the solenoid? They can be erratic. Problem may be the contactor inside the solenoid is bad and it is not passing the full voltage to the starter then it gets hot and sticks.
 
Thank you for your reply I actually have replaced the solenoid,starter,s/s button,tested dess post and cleaned all the ground connections I could find. There’s not much left except the MPEM which I have no way of testing and it appears to be an aftermarket probably from China assembled by a 7 year old.😡
 
These skis will surprise you. If you throw money at them they will suck it all up and still not work. I've had some strange issues. fortunately for me I have lots of spare parts and can swap and generally... swapping parts doesn't solve many problems. It's hit or miss. Good Luck !!
 
Okay this is just getting more challenging today I installed a OEM MPEM with matching dess key and I got nothing the gauges did not operate,no beeping and the s/s button did nothing as well? When I would connect the main wire harness I got a slight churp? I reinstalled the aftermarket MPEM and put a dess key on the dess post and the gauges worked and when I pushed the s/s button the motor turned over (without any spark to the plugs)? Also when I would plugin the main harness to the aftermarket MPEM I could hear either the starter solenoid or the starter click?
 
The first question is where did you get the OEM MPEM and key from an how do you know it is working unit?
 
I purchased the OEM MPEM online from a reputable seller that said it came off a non running ski but would fire if fuel was put in carb. I spoke to him and he agreed to refund if I paid returned shipping and then I got a message saying he would refund and I could keep it which makes me think maybe it is no good? If anyone has a good working MPEM with matching dess key I am interested in purchasing. Mine is a 278-001-496
 
I agree with your assessment that if the seller is refunding and letting you keep the MPEM and key then it probably might not be a working unit. I've seen Westside Powersports recommended a lot on this forum. They sell used parts and I believe they stand behind them. Call them and explain your problem and see what they recommend. Also wait and see if someone on the forum responds to your request to purchase an OEM unit.
 
Well it's been a long mind teasing process but I finally hit the problem. After checking potential items like MPEM, dess key and dess post,starter,starter solenoid,clean all ground connectons,s/s button and all harness plugs for corrosion I checked the continuity on the ground attached to front of motor and at the mpem plug and it showed negative. I spliced into the ground wire at the mpem plug and ran a new separate wire back to the front motor ground location while leaving the factory harness ground attached as well and problem solved :), There must be some ground disconnect in the harness. Wanted to post this and thank everyone for their help and advice I wouldnt want anyone to go thru this puzzle hopefully it will help someone in the future. Thanks Again!!!!
 
Back
Top