2004 Seadoo Speedster RPM surging

Not open for further replies.
Hi All,

My family purchased a 2004 Seadoo Speedster with Mercury M2 240 engine (2nd gen) last year. We used it all last year without any major issues. First trip out this year everything started fine, but about 20 minutes into our trip (while cruising at about 4K) the rpms started to dip and oscillate down towards idle. Originally I thought something was just stuck in the intake, but I inspected that and it’s clear. I’ve tried a few things since then to resolve the issue but it continues to occur about 15-30 minutes into the trip. I believe the issue may be heat related because it seems to happen faster if I’m pushing the boat harder and if I shut the boat off for 10-15 minutes it goes away for a while.

I've done some browsing on the Mercury forums and I’ll list some of the things I’ve done/may be relevant.

  • Added recommended quantity of Quickleen to the fuel tank
  • Replaced spark plugs
  • Tested head temp when issue is occurring (about 100 F)
  • Disconnected both head temperature sensors (same issue occurred)
  • Disconnected throttle position sensor (same issue occurred)
  • Replaced water separating filter
  • There is no throttle guardian
  • The stop switch is working correctly
I’ve recorded videos of “normal” operation (getting up to plane and running) and when the issue is occurring.

I think the manual I’ve been working with is for the first gen engine, so I’ll try to get the new one and see if that has any additional info.

Any suggestions are appreciated!


  • 9502E16E-4954-41ED-9423-0143F4A49A22.jpeg
    460.7 KB · Views: 10
Last edited:
From the second vid... sounds like it's running out of fuel. I would verify the fuel pressure on the vapor tank.
Thanks for the suggestion. It’s refreshing to be able to find items that are in the right place now that I have the right manual. I will check the fuel pressure on the vapor tank. Just to confirm, that would be connecting to #5 in the attached image correct?
Would an Innova Fuel Injection pressure tester from AutoZone work for this? (* I tried to include a link but it didn’t work)

Final question (for now) should this just be a key on test or should I be monitoring the fuel pressure out on the water?

Thanks again!
I got the gen. 1 engine but I think to check the pressure for vapor tank is the same, it has a pressure valve on near the VST, it should be 36 PSI as far as I remember. Check in the manual on how to check it properly... It measures the electronic fuel pump inside the VST.. per manual specs it is 36 PSI. Although I sold my challenger M2 240 EFI 3 weeks ago, but I'm the one repairing myself from new electronic fuel pump from VST. Dr. Honda is very helpful, I'm glad his back helping out in the forum now. Tim75 also help a lot in the forum.
Sorry for the long delay. I was able to test the pressure on the vapor tank and it was in spec. I replaced the inline fuel filter right before the water separator (#3 on my previously posted diagram) and that seems to have resolved my issues. The old filter was much more restrictive than the new one and there were some semi-solid (almost jello like) pieces that came out of the in side when I removed the old filter.

Not open for further replies.