Mercury m2 240 efi speedster 2002

talha.lodhi98

New Member
I have 2002 speedster with mercury m2 240 efi I am have issues that engine start with rough idle and keep die
First engine was running fine with rich smoke but It was running completely fine then after 2 day u took to lake and boat die after 5 minutes and didn't start
Then I manually open air intake then it start but keep die afterwards and now it not even running for minutes
I removed all fuel and put new one and add little marvel mystery oil
 
I have 2002 speedster with mercury m2 240 efi I am have issues that engine start with rough idle and keep die
First engine was running fine with rich smoke but It was running completely fine then after 2 day u took to lake and boat die after 5 minutes and didn't start
Then I manually open air intake then it start but keep die afterwards and now it not even running for minutes
I removed all fuel and put new one and add little marvel mystery oil

Check the TPS. It can cause flooding at low speed. Many threads here about it.

Check the fuel pressure at the shrader valve on top of the vapor separator.
 
I checked fuel pressure too
I checked compression on all piston
One get stuck really low compression
Now I need advice how to unstuck one piston so It can run again
 
I checked fuel pressure too
I checked compression on all piston
One get stuck really low compression
Now I need advice how to unstuck one piston so It can run again

Can you share your numbers?
When you checked compression, did you set full throttle?

Stuck piston???
How did you do the compression test?
 
Back
Top