2002 GTX RFI won't run over 30 mph.

Messages
70
Likes
6
Water Crafts
96 seadoo gtx
#26
Is the engine getting hot? No beeping on the display or msgs?
There is another set of codes you can check but hitting the start stop button 5 times without the key and it should give some beeps if there is trouble. Look at the manual in section 5 or 6 I can’t remember
 


etemplet

Premium Member
Premium Member
Messages
1,972
Likes
143
Location
Louisiana
Water Crafts
1996 SPI, 1996 GTX, 1997 GTX
#27
I think Miki is asking about the craft's performance "in the water" and whether the engine is "not" revving up, or it is revving up and not going anywhere. Your description sounds to me like the engine is "not revving up". I have a 1999 GTX RFI I just purchased and am following this thread but our skis are not identical. RFI's are new to me but I am very cunning and devious when searching for a problem with those same qualities. :) I just can't let go. :D :D

On a side note, I sent my fuel injectors out for cleaning. Cost me $48. That could possibly be an issue for you if you have not checked that already. Good Luck !!
 

mknice1

New Member
Messages
19
Likes
0
Water Crafts
2002 GTX RFI
#28
I think Miki is asking about the craft's performance "in the water" and whether the engine is "not" revving up, or it is revving up and not going anywhere. Your description sounds to me like the engine is "not revving up". I have a 1999 GTX RFI I just purchased and am following this thread but our skis are not identical. RFI's are new to me but I am very cunning and devious when searching for a problem with those same qualities. :) I just can't let go. :D:D

On a side note, I sent my fuel injectors out for cleaning. Cost me $48. That could possibly be an issue for you if you have not checked that already. Good Luck !!
I bought new injector since mine sat with old gas for a few years. Most of the fuel system components have been replaced along with the spark plugs and rectifier. We are still having the issue.
 

etemplet

Premium Member
Premium Member
Messages
1,972
Likes
143
Location
Louisiana
Water Crafts
1996 SPI, 1996 GTX, 1997 GTX
#29
I posted some pictures on my 99 GTX RFI thread. I replaced the fuel filters on my RFI today.... Unbelievable. I can't believe the ski even started and one cylinder had zero compression. I'm sure my ski would not have run very long. I read you replaced your already so that is a good thing to do. :) 20181010_123229.jpg GTX RFI Fuel Filter2.jpg
 
Messages
27
Likes
4
Location
Chicago
Water Crafts
00 FTC rfi
99 gp800
#31
Oh wow just reread your last post haha did you geget it up and running or was that you on another post getting it up to 5600rpm now?
 
Messages
76
Likes
0
Location
Burlington Ontario
Water Crafts
2005 Sea-Doo Sportster LE DI
#33
Rfi’s can foul plugs quickly. Put in a new set and see if it runs good. Cleaning them wont help. Check your charging 13.5 v by revving to 3000 rpm on land. You can also charge your battery manually and see if you get 20 minutes out of it. If your charging 13.5 v I would even try a new battery. These rfi s need a constant voltage and 12.3 is low.
 

Users who viewed this discussion (Total:8)

SPONSORED LINKS

Usergroup

Administrator Moderator Premium Member
Top