Shop Discount Sea-Doo Parts

2000 Millennium RX

GGuillot

Well-Known Member
Messages
906
Location
Alabama
Water Crafts
1997 GTX
1996 GSX
It's not registered? You've got balls where you live, either that or you own the river. If you get caught without registration or a boating license the fines are heavy here in AL and GA. Heck without any letters displayed on the hull like you're doing they'd probably impound it.
 

etemplet

Premium Member
Premium Member
Messages
2,587
Location
Louisiana
Water Crafts
1996 SPI, 1996 GTX, 1997 GTX
Matt suggested I check the accelerator pump nozzles. He was right... one was plugged up solid. :) I was afraid to blow air threw them as I didn't know how the nozzle was made. I gave them the "full monty" treatment. I also found a jet inside the accelerator pump hose. So I made sure I put that back in there when installed the new line. I dropped the Pop-Off from 23 PSI to 19 PSI. Ski is happier and I put another 40 minutes run time on it. I'm anal about warming up and break-in but I can't wait to get it wide open and check the speed on the GPS. I've never been a boater or fisherman but sure is peaceful out there.RX Canal 9-3-19 (1).JPGRX Canal 9-3-19 (5).JPEG
 

etemplet

Premium Member
Premium Member
Messages
2,587
Location
Louisiana
Water Crafts
1996 SPI, 1996 GTX, 1997 GTX
Ugly and Slow. 55mph on the GPS but... I'm breaking it in. Still tight now doubt. 6680 on the RPM. I enjoy the tweakin.....we'll see what I can come up with to get another 3 or 4 mph. :D :D
 

Mekanix

Well-Known Member
Messages
2,023
Location
Halifax, Nova Scotia, Canada
Water Crafts
96 GSX 800 :D
2000 GS 717
02 gtx 4 tech :s
98 XPL :/
99 XPL :p
2001 XPL :)
2000 RX
2002 RX :)
Ugly and Slow. 55mph on the GPS but... I'm breaking it in. Still tight now doubt. 6680 on the RPM. I enjoy the tweakin.....we'll see what I can come up with to get another 3 or 4 mph. :D:D
Give it time. Mine took about 4 hrs of break I to get past 6600. Seems like every ride it gets faster and snappier. Also make sure your rave lines arent full of water and that the water regulator isn't screwed all the I or out. Mine had unscrewed until the spring almost had no pressure. And the check valve for the raves can go bad meaning the pressure that is normally dumped overboard can pull water in as well if the valve malfunctions.
 

etemplet

Premium Member
Premium Member
Messages
2,587
Location
Louisiana
Water Crafts
1996 SPI, 1996 GTX, 1997 GTX
I made an individual post on the ski running lean. This thread is kinda dead as people generally don't read long resto threads. :)

I'm gonna pull the carbs and go over everything with a fine tooth comb. It is taking it's time about settling down to a consistent idle. I'm working on this today. :) As I mention in my other thread I'm lowing the pop-off and disassembling the accelerator pump. Input is appreciated.
 

etemplet

Premium Member
Premium Member
Messages
2,587
Location
Louisiana
Water Crafts
1996 SPI, 1996 GTX, 1997 GTX
This BOMB is getting painted. I am not looking forward to it but that freakin Gray is horrible, flat dull, and unpolishable. :) I can do nothing with the shiny spots where the numbers were. Thought about spaying with the clear but that won't last long. Holding the same color or close would be best as that is what I have always done. I am not opposed to the color The mats are nice though and I'll have to remove them.


RX Water Test First Ride Day  (3).JPEG
 
Last edited:

GGuillot

Well-Known Member
Messages
906
Location
Alabama
Water Crafts
1997 GTX
1996 GSX
This BOMB is getting painted. I am not looking forward to it but that freakin Gray is horrible, flat dull, and unpolishable. :) I can do nothing with the shiny spots where the numbers were. Thought about spaying with the clear but that won't last long. Holding the same color or close would be best as that is what I have always done. I am not opposed to the color The mats are nice though and I'll have to remove them.


View attachment 45503
Have you tried wet sanding? start at 400 grit to get the heavy oxidation out and work your way up to 1500-2000 grit, then polish.
 

mikidymac

Moderator
Staff member
Moderator
Messages
12,206
Location
California
Water Crafts
2003 GTI
2001 XP
1996 XP
1996 HX
1991 Superjet
2001 Superjet
The seadoo silver doesn't come back with sanding and buffing like the other colors. Must be something with the metal flake in it.
 

etemplet

Premium Member
Premium Member
Messages
2,587
Location
Louisiana
Water Crafts
1996 SPI, 1996 GTX, 1997 GTX
You got that right. The spots where the numbers were are smooth and shiny. Pitiful.
 

etemplet

Premium Member
Premium Member
Messages
2,587
Location
Louisiana
Water Crafts
1996 SPI, 1996 GTX, 1997 GTX
OK, I pulled the carbs for some checks... they were all good. I disassembled 2 throttle cables, this is the split type with the sensor. I'm getting no reading at all from one sensor and on the other I'm getting a reading that won't change no matter where how far open or closed the throttle cable is. I took two of them apart to figure out why they are a bit stuff and I did find out why. :) I tried looking in the manual to test the sensor but that stuff is so difficult to find. Any way to test this thing. I'm using the Ohms setting on a multi-meter. It's just a magnet so it should be an on/off switch. Open or closed but I didn't design it so I'm not sure. Help is appreciated. I guess looking at this now working properly could cost a few RPM on top and maybe some acceleration points.

They can be taken apart and modified to slide easier if necessary. :) I got plenty of time and a spare cable so I can play with this stuff. I think I'd recommend buying a new one.

RX Throttle Cable repair sensor (1).JPEGRX Throttle Cable repair sensor (2).JPEG
 
Last edited:

GGuillot

Well-Known Member
Messages
906
Location
Alabama
Water Crafts
1997 GTX
1996 GSX
Help is appreciated. I guess looking at this now working properly could cost a few RPM on top and maybe some acceleration points.
I'm trying to understand the problem you're experiencing, I went back and read this thread and you saw 55 mph on GPS at 6680 RPM back in Sep? So what problem again are you chasing? It was suggested from Mekanix to give it time to break it in and it'll improve. How much riding time have you gotten on it since then?
 
Last edited:

etemplet

Premium Member
Premium Member
Messages
2,587
Location
Louisiana
Water Crafts
1996 SPI, 1996 GTX, 1997 GTX
After much diligence I just ordered a new cable. This girl should be ready for the water again by next week's end.
 

etemplet

Premium Member
Premium Member
Messages
2,587
Location
Louisiana
Water Crafts
1996 SPI, 1996 GTX, 1997 GTX
Liked to killed me to spend $114 when I was SOOOOOO close to having this thing working. Cable might be good but I don't know how to test the sensor. I'll figure it out when I get my new cable. This double cable rig is the reason the throttle is stiff on these skis. The plastic piece internally drags causing added friction.

This ski still has the fuglies and needs work but.... when it's on the water you can't tell. Ha ha. My goal is to hit at least 57mph on the GPS with this one.

Good luck all have a great day.... I got 10 skis outside that need work. LOL Touchdowns everyone !!
 

etemplet

Premium Member
Premium Member
Messages
2,587
Location
Louisiana
Water Crafts
1996 SPI, 1996 GTX, 1997 GTX
I spent a lot of setting up the carbs. I did all the re-checks last week. So.... throttle cable is in and adjusted. All I need to do is button up the exhaust.

I installed the Candoo GPS speedometer pick up. I'll be working on the UGLIES as time permits. I have a plan.
 

SPONSORED LINKS

Latest posts

Usergroup

Administrator Moderator Premium Member
Top