Seadoo SPX Problem

BShones

New Member
1997 Seadoo SPX. Last week I was riding my ski and it was running perfect until I fell off. It didn’t tip or anything but it wouldn’t start back up. All the electronics were working but nothing would happen when I pushed the start button. I was able to jump the solenoid to get home and the next morning the ski started fine and ran good out of the water. Today I was riding and the same thing happened. I jumped the solenoid and by the time I got back to the dock, it started with the button. The ski is not getting hot and I put in a new oem solenoid after the first time it happened. What’s causing this? Could the little bit of water in the hull be shorting the starter out? Any help is appreciated.
 
if your able to start it by jumping the solenoid than the mpem is recognizing that it has the correct key installed. When this happens do you still get the 2 beeps when you put the key on?
im half wondering if the starter button is going out
 
if your able to start it by jumping the solenoid than the mpem is recognizing that it has the correct key installed. When this happens do you still get the 2 beeps when you put the key on?
im half wondering if the starter button is going out
I get the two beeps when I put the key on. I was thinking the button aswell but it’s weird that it only happens after riding for a bit. Maybe the casing around the button has a hole and water is getting in. I will have to take a better look at it when I get home.
 
if you feel like searching around there's a way to test the start stop button with a multimeter, but with your problem being intermittent it might be best to just replace it or if you have a known good one to use that.
 
Back
Top