1996 seadoo GTX changed MPEM now no power

Not open for further replies.


New Member
Hi I am new to the forum. Recently acquired a 1996 seadoo GTX that was apparently having issues bogging at WOT. Saw note from dealer that said cleaned carb and it needed an MPEM replacement. I tried to fire it up and was turning over with no spark. Opened the water tight case for the mpem and it fires right up. Next day wanted to go on the water to test and same thing wouldn’t fire up in the shop, moved some wires and it fires right up.
bought a used MpEM off eBay figuring it was a good place to start, sent mpem with key to nick in Minnesota to program. Got it back and installed now there is no power to anything. Installed the old mpem that was working intermittently and still no power to anything.
Battery is 12.5V
Any help would be appreciated. I checked all the wire colors and not sure how I could mess up install but maybe I did.


  • 54EEA33B-DEAD-4D0D-90EA-7EB4502BC295.jpeg
    2.7 MB · Views: 23
Bogging at wot is a bad wear ring/impeller. Check the fuses on the MPEM, mine looked fine and tested fine until I physically pulled it and ended up in 3 pieces. I can't help much more as all I know about yours is it's a lot easier to do basically everything than the 97 when they updated things.
yea all 3 fuses in near Mpem look good that’s why I’m thinking I wired it wrong somehow. Even though all the colors match there is a few oddities. Like the gray wire comes into the box then goes right back out and there are two red and purple wires ( I think that was the color)
UPDATE: Once i found the wiring diagram for the correct model. It turns out hooking up the MPEM isnt idiot proof and you have to hook the red/Purple wire to the red/Blue wire. Way to go seadoo. Once i did this all the lights came on and it fired up minus a fuel flow issue
Not open for further replies.