MPEM? Starter Solenoid?

Rbaud22

New Member
Hello! I am new to the sea doo community and was looking for help on a weird problem I have been having with my pwc. I have a 2006 seadoo Rxp with less than 90 hours on the engine. last year when I went to install the dess key onto the post my sea doo started to beep faintly before I even completely insert the key onto the post. When I inserted the dess key fully I got the normal 2 beeps and I was able to start the pwc. However, the long faint beeping was continuous and stayed ringing with the pwc on. The faint beep even continued to ring for about 30 seconds after I pull the key out.

I tested fuses and battery and checked all grounds. I also checked the dess post and my key because I originally thought this was the problem.

I was unable to figure out the problem before I returned to school and when I put the key on this year i heard a rattling noise from the starter solenoid area. now when I put the key into the pwc I get nothing (no beeps no sign of life when I push start/stop button). I again tested the battery which tested perfect.

Also to add to this mess I have been riding without a working display so I was unable to see if any error codes were displaying.

Please let me know if you have any clue what could be happening here thank you so much!
 
Last edited:
Test your rectifier, the diodes can go bad and allow current to flow the wrong way in the charging circuit, causing all kinds of weird issues. Although it now sounds like you blew a main fuse.
 
Test your rectifier, the diodes can go bad and allow current to flow the wrong way in the charging circuit, causing all kinds of weird issues. Although it now sounds like you blew a main fuse.
I couldn’t find a way to test the rectifier without starting the pwc. However I did locate my rectifier and it definitely needs to be replaced. I appreciate your input!
 

Attachments

  • IMG_2174.jpeg
    IMG_2174.jpeg
    319.8 KB · Views: 7
Back
Top