HELP nothing happens pressing button

Note: This site contains eBay affiliate links for which may be compensated


New Member
My 2015 spark got flipped and we drove it back to the beach and it didn’t do anything when pressing the button nothing on the screen so I took it apart and looked over things couldn’t find anything so I tried it again and everything worked as normal so I brushed it off as the electronics in the screen and key reader got wet but just took it out today took it off the trailer like normal parked it and it’s doing the same thing someone help really don’t wanna pay to have someone look at it when I could probably do it myself
Not for nothing but a few punctuation marks (periods, commas, etc) would help.

This may sound weird, but has happened to me with my 2016 Spark....I'd press the RED Start/Stop button and nothing would display messages, nada....I tore into the electrics, checked everything, etc.....nothing seemed amiss...Huh? Putting the key on gave me the proper 2 chirps, but pressing the red button gave me nothing...Huh?

So, I started looking at everything with a fine tooth comb, starting at the SS button.....I discovered that the Red soft rubber button had slipped out of it's normal position and was NOT actually pressing the plunger on the switch underneath it. I carefully removed the RED rubber button from the handle (using a blunt pointed wooden stick, like a bamboo skewer blunt end). The rubber button has a recess that sits over the plunger on the switch and needs to be in alignment for the switch plunger to do it's thing......I carefully manipulated the red rubber switch cover back into the handle (WD40 helps) and made sure the switch plunger was seated into the red rubber cover.....worked like a charm....pressing the red rubber button made the ski act properly after that.
Hmmm I don’t ever remember mine beeping when I put the key on but it would beep when I hit the button I will definitely look at that when I get a minute is there anyway to tell without taking the red thing off?
Pressing the RED SS button, no key, is supposed to "wake up" the should see a Welcome message on the display (if everything is working properly).

Putting the security key onto the ski should give you two audible chirps....that indicates that the ski recognizes the key and the ski can start....otherwise, no chirps, etc....means either the key is not recognized OR the beeper (chirper) is defective.
I don’t think it’s that because I’m getting no beeps and when I hit the button I can hear something happening sounds like in the fuse box almost like little clicking
Are these the starter wires next to the fuse box if so when i connect them together with a screwdriver should it turn over and next would a bad starter cause the button to not turn on the screen or make any beeps
The two posts next to the fuse box are the solenoid posts. Shorting them together should send battery power directly to the starter and the starter should try to turn over the motor.

You say you can hear clicking...that means the solenoid is trying to make a connection (internally) to those two posts. If nothing is happening after that:
1) starter could be bad
2) solenoid posts could be burnt inside - not allowing power to get to the starter.

????? - If memory serves...there is supposed to be a starter relay plugged into the fuse box...upper left corner...your picture doesn't show a relay plugged into the fusebox....where did it go?

To answer your question....NO, a bad starter would NOT affect the SS button from "waking up" the ski.....