Connect DESS, no beeps

Note: This site contains eBay affiliate links for which may be compensated
Not open for further replies.


I went to start my 99 GTX Ltd this year for the same time and when I connected the DESS, it wouldn't even beep. I know the battery is good. It's pretty new, and according to the charger, it's charged. Even when I had bad batteries in the past, it would always beep when I connected the DESS. This is the first time this has happened. It was stored all winter and this is the first time I am trying to start it.

I looked at the fuses and they all seem OK. I can try replacing them anyway, but for now at least, they look fine. I even tried using both of the DESS', but the same result.

Does anyone have any ideas for what I can try? If you need more info, let me know. I appreciate any help anyone can offer. Thanks.
Thanks for the quick reply...yes, I did try and press the start button...nothing can't just be the buzzer anyway since none of the gauges turned on either...if the LCD displays had lit up when I connected the DESS, then it probably would have just been the it's something more than that...
Not open for further replies.