96 GTX Reverse Lever Stuck in Foward

Status
Not open for further replies.

If anyone has a photo of a operational lever it would be greatly appreciated. I'm not sure what went missing or what part I need to order.

Thanks
 
Last edited:
Link isn't working.
Does it work properly in forwards?
Lots of us make do without reverse. How often do you really need it?
 
I have this exact same problem with my 96 GTX. It looks like the black plastic (attached to the metal cable from the reverse handle) is supposed to raise up and disengage the metal lever that he's pointing to, but that's not happening.

I wonder if it's somehow edged a line into the lever, causing it to stick. You can see a line at 5-7 seconds into the video.
 
So I tried today putting some WD40 on the big dark lever and metal latch, just to see if it was sticking or something. I also tried tightening and loosening the bolt that holds the dark lever on the reverse shield. No difference.

It appears that enough pressure is being put trying to rotate the big plate (that redirects the water jet) so that it puts pressure on the metal latch BEFORE the lever releases the metal latch. This binds the mechanism up, preventing the metal latch from releasing.

Anyone know how to fix this? There's a groove in the metal latch, but it looks like the part was forged that way. I could try sanding it down, but I don't know that's the best idea.

Also, this is the replacement part, but it looks nothing like my current hook. Should I try replacing the latch?

Sea-Doo New OEM Hook Lever, Sportster LRV GTX GTI Challenger, 271000430 | eBay
 
This site contains eBay affiliate links for which Sea-Doo Forum may be compensated.
I've ordered the replacement part (because it wasn't expensive) and I'm going to see if that fixes it. Anyone else have any ideas or advice?
 
Strangely, mine does it out of water and not in. For whatever reason the jet propulsion fixes my issue when out riding. I'm sure it's a matter of time before it needs fixed.
 
Wow! Awesome find.

That's exactly what I was looking for. Now I'm a bit concerned because I'll need to figure out how to get the pin out so I can replace the lever. :)
 
Status
Not open for further replies.
Back
Top