95 GTX oil pump cable

Note: This site contains eBay affiliate links for which SeaDooForum.com may be compensated
Status
Not open for further replies.

jcschere

New Member
I have a 1995 Seadoo GTX. I had the carbs off yesterday and after I put them back on I noticed that the cable that runs from the carbs to the oil pump was not "tight". By "tight" I mean that when the throttle is pulled, the oil pump cable is also pulled, but when the throttle is released the oil pump cable does not snap back all of the way.

In my Clymer manual it shows the lever that the cable connects to on the oil pump positioned straight down. I am assuming that is the closed position. When the throttle is released, this lever stays at about a 15 degrees counterclockwise of the closed position.

Is it not supposed to snap back all of the way? Is the spring on the oil pump lever worn out or maybe it came loose? I don't know if it is just in my head or not, but the throttle seems easier to pull. It is kind of hard to see down there so I can't exactly see if there is an obvious problem. If anyone can help I would greatly appreciate it.
 
I would check the spring, i just looked at my ski and it snaps right back with the release of the throttle.
 
Alright, I will check it out. Just to make sure my initial message wasn't confusing: the throttle snaps back just fine along with the gas cable, it's just the cable to the oil pump that still has some slack when the throttle is released.
 
Status
Not open for further replies.
Back
Top