2007 GTX No Beep Gauges On No Start

Not open for further replies.


Active Member
Having a problem from start of this season with no start condition.

Put the lanyard key in, no beep but gauges turn on.

No click with depressing start key.

Can’t activate diagnostic mode with five presses of start/stop button but I’m not sure that ever worked.
Battery fully charged and in good shape.

Bought this seadoo a year ago, worked well last year except for sometimes key would give 2 beeps but pushing start button did not give click or start.

If solenoid or starter is bad, you would get DESS Key beeps in both cases right? Assuming beeper works well?

Trying to rule out bad DESS post, MPEM, or anything else after reading other posts.
There is a small Black, 5 Pin Relay under the front hood in the fuse box. Pull that out, and give it a clean. If cleaning the pins doesn't help replace it. It's a common relay, and can be found at any auto parts store. Had three of my 07's give me troubles over that relay.
I wanted to follow up on my post. Turns out it was just a failed battery even though the battery was new one year ago.

on my charger, the battery read 13 volts but after placing on the seadoo, after 5 min it read 9.8 volts with the multimeter.

I purchased a new battery and the seadoo is working just fine. So maybe low voltage will make the DESS beeps not work properly but was enough to turn on the gauges.

As an aside, the failed battery after 1 year was an Autozone Duralast Gold which only has a 3 month warranty. The new one is a Duracell which is $20-$30 more but comes with a two year warranty.
Not open for further replies.