2005 GTXSC no beeps

Note: This site contains eBay affiliate links for which SeaDooForum.com may be compensated
Not open for further replies.


New Member
Newbie to the forum here...

I have a 2005 GTXSC that didn't start last weekend. When I plugged the key in, I didn't get the two beeps. I also didn't get the long beep telling me it's the wrong key. When I removed the key, i did get a momentary 'SEADOO' on the display I didn't have time to check the battery or try the learner key. I got the same 'SEADOO' message on my other identical machine when I intentionally plugged the wrong key in and removed it. Could it just be a bad battery? Is the 'SEADOO' message a default that has always been displayed; I've just never noticed it?
Ok, I'm continuing this thread because it's my other 2005 giving me issue this year. I charged the batteries last month before bringing all four seadoos to the lake. The people that launched them and brought them to my dock put about 1/2 of run time on all four of them. Now when I put a key on one of the 2005's, I get nothing. No good beeps, no bad beeps, no gauges and no "Seadoo" on the display. I've charged the battery again and the charger says it's full. I've removed and cleaned the connectors on the battery. I removed and tested 12 fuses. There are two banks of 5 fuses and two that are in their own waterproof connector. All are good and none are corroded. I did notice that one of the banks of 5 fuses did not have it's cover on. Is it possible that something in their is wet? There wasn't any water in the engine compartment. Could it be a bad key or something bad in the key circuit? I tried the key in the wrong seadoo and get the bad key beep. If I try a different key in this seadoo, I still get nothing.
try swapping out a post. a bad post will do exactly what you are describing where it won't recognize anything.
Not open for further replies.