2000 gti random electrical problems while under load

Note: This site contains eBay affiliate links for which SeaDooForum.com may be compensated
Status
Not open for further replies.

Tayloreks

Active Member
Hey everyone I need help with this gti. I have very weird electrical problems at random the ski will just die while riding It will do it while idling sometimes. I seem to remember casually replacing a 15 amp fuse in the mempem or I might be dreaming it at this point. I got this ski off someone I know that said it was just having minor problems... but anyways I had putting out over 15 volts to the battery and I replaced the rectifier and when I first put it on the volts would rise and fall pretty quick with the trottle now it seems slugish and stays kinds high at 14.20 ish after I let off under water load. But it seems to be doing ok it stays solid while this electrical short happens now. When this short happens my speedo starts freaking out going up and down dancing till it cuts off the engine. Also most of the it will let me restart the ski and only idle back to the shore if i try snf give it gas it freaks out and starts going crazy and you can see the speedo freaking out with it. I replaced the coil as well thinking over charging could have hurt it but no luck with that. So I poped off the stator cover to give her a quick look because of course the starter grinds like crazy and found oil and metal shavings I need to go find some bolts to pop off this fly wheel so i can see how bad the stator might look like. I think thats about all I got for now any other ideas?
 
Stator sounds suspect. You can rent a puller from Autozone. Just don't thread the bolts into the flywheel too far or you will damage the stator windings.
 
Status
Not open for further replies.
Back
Top