03 GTX bad Sensor Key

Note: This site contains eBay affiliate links for which SeaDooForum.com may be compensated
Not open for further replies.


New Member
Hey Guys

Have an 03 GTX 4-TEC that went died on me.
After alot of trouble shooting, from what I found on this forum, I was able to find the problem..

Went to launch the ski the other day and out of the blue, it was completely dead.
I put the landyard key in and nothing, no beeps or gauges...

I thought it was the battery (even tho it is less them a year old)
Tried to jump it and notta..
Checked all the fuse in the main box - and they all looked okay.
Didn't know what else to try at the ramp so brought it home.
Next day I called Seadoo mechanic on here, Dennis, and he was kind enough
to tell me a few things to try.. (thanks Dennis!)

I had the battery checked, it was okay..
Checked my on/off switch that the previous owner had installed, and that was okay.

I searched the forums and read about jumping from the solenoid, I did that and it cranked over..

I try to get it in diagnostic mode by holding down the start button without landyard attached, but nothing happend

So I narrowed it down to the landyard or the post ?
I tried cleaning both and still nothing... (I tried soap, pencil eraser)

I kept searching and read this post Weird DESS Fix where a member starting beating his post against his work bench and got it working.
Well I had my post out and exposed (still wired in) just hanging their so out of frustration, I just went out and starting beating the post and then my key and gave it a shot!
It started beeping!! I couldn't believe it! LOL
After I fired it up I turned it off and tried again and now I get beep (1 long 3 short I think it was) and a message "Sensor Key"

Does that mean I need just the key or is it the DESS post ?

Not open for further replies.