Shop Discount Sea-Doo Parts

Hey Everyone! Anyone in Nor Cali?

Messages
6
Likes
2
Location
Modesto
Water Crafts
Sea doo Challenger 180 CS
#1
I have a 2006 sea doo challenger 180. I have barely taken it out since I have had it the past 10 years...first time taking it out in the past 3 years...Shop put new battery on..took for a test drive out with son. Everything was good...had a new key made as well that seems a little different than original. None of my gauges are working but all the buttons on the right side work... While out in it the first 1/2 hour, I heard like 6/7 beeps then the engine shut off...(no gauges to warn me of anything). Im thinking since my son had just put the lanyard around his wrist that maybe it started to come off and thats why the beeps went off? Would it do that? We checked fuses as good as we could without any tools..changed the one by the engine that said gauges and then when I went to start it at least the one side of the gauge with the engine/temp went red at start then went off but the other half side (oil, ) didnt. Does only one side of that gauge light up at start? The other gauges, rpm, gas, speedometer still not working.
[ My brother has surgery this week but hopefully after he will be able to look at it and fix it] Just curious what everyone thinks it can be?
 


gato760

Active Member
Messages
39
Likes
6
Location
San Diego, CA
Water Crafts
Challenger 180
#2
I have a 2006 sea doo challenger 180. I have barely taken it out since I have had it the past 10 years...first time taking it out in the past 3 years...Shop put new battery on..took for a test drive out with son. Everything was good...had a new key made as well that seems a little different than original. None of my gauges are working but all the buttons on the right side work... While out in it the first 1/2 hour, I heard like 6/7 beeps then the engine shut off...(no gauges to warn me of anything). Im thinking since my son had just put the lanyard around his wrist that maybe it started to come off and thats why the beeps went off? Would it do that? We checked fuses as good as we could without any tools..changed the one by the engine that said gauges and then when I went to start it at least the one side of the gauge with the engine/temp went red at start then went off but the other half side (oil, ) didnt. Does only one side of that gauge light up at start? The other gauges, rpm, gas, speedometer still not working.
[ My brother has surgery this week but hopefully after he will be able to look at it and fix it] Just curious what everyone thinks it can be?
Hello Seadoogirl72,

I would move this thread to the "4-Tec Sea-Doo Boats" section of the forum and you might get more assistance.

I have a 2006 C180 wake tower edition with the 215 hp engine. I usually hear two quick beeps when I put the lanyard on. A couple times I have gotten the one long beep when the lanyard was not securely on and I would adjust it and it would beep twice (as it is supposed to). All my gauges I believe turn on when I put the lanyard on, and then go off. I would check all your fuses first. It is easy to see if they are burnt out. I keep a ton of extra fuses in the box just in case since my stereo and amp will occasionally blow a fuse. I copied this from the manual that might provide some info for you:
DESS Sea-Doo 2006 C180.PNG

Regards
 
Messages
6
Likes
2
Location
Modesto
Water Crafts
Sea doo Challenger 180 CS
#3
Hi gato160! We must have the same boat then? I will try that! I couldn't remember if all the lights in gauges light up or not so thank you! I just bought all new fuses so I will put all new ones in and hope it is just that... Let's pray... :)
 

Users who viewed this discussion (Total:9)

SPONSORED LINKS

Latest posts

Usergroup

Administrator Moderator Premium Member
Top