Note: This site contains eBay affiliate links for which may be compensated
Not open for further replies.


Active Member
Hello everyone,

New to the forum and I've been diagnosing some issues on my 2001 GTX RFI so I thought I would share.

Bought the jet ski and it was running a little rough and fouling plugs so I cleaned the RAVE valves and it was running like a dream. Before taking it down to my house on the ocean I took it out for a friends birthday to tag along the pontoon and to let people ride it. What a mistake that was. Some girl didn't attach the lanyard correctly, rolled it, and left it running upside down. It went about 18' underwater and I had to swim down to it to tie a rope to it to drag it back to shallower water.

Part 1: Getting the jet ski running again
First I pulled it by hand up onto someone nearby's jet dock after asking. This allowed me to get the water out of the hull. The engine was hydrolocked, but luckily I keep a wrench for the plugs on the ski. Highly recommend this. I pulled the plugs, blasted the water out of the engine, and then replaced them. I tried to fire it up. Did this over and over until it stopped fouling plugs and would start and run. I drove it straight back to ramp and loaded it up. Got it home and drained the water out of the counterbalance shaft oil reservoir and replaced the oil with SAE 30 oil, 30ml. This is necessary because water down there won't burn up during running and will eventually rust bearing leading to a crank case blowout.

Part 2: Electrical problems
After changing the oil I got the ski out on the water again thinking everything was okay. The ski went for a bit and then shut out. Also in mid-range I was chopping a lot while running and in general the ski didn't feel great. It would be running with chop adn then shut out. No beeps, no DESS key acknoledgement, no advanced diagnostics beeps. Got it home and starting tearing into it. I had blown the 5a MPEM fuse which worried me that the MPEM got water in through the seal and was dead. Replaced the 5A fuse and opened MPEM. No water inside, but I let it dry open in the sun regardless. Put it back in and took the ski back out. Put brand new plugs in hoping to address the chopping despite the plugs looking brand new. Still chopping, starter sometimes spins but doesn't engage the flywheel now. Beeper will work one minute and not work the next. Ski cut out and I had to paddle back again while running wide open. This time no 5A fuse blown. Beeper still coming and going. In order to rest my mind about some weird electronic behavior from MPEM I borrowed one from my buddies 1999 GTX RFI and his DESS key. All the problems were exactly the same so I assumed the MPEM was fine. I sanded and cleaned contacts on the battery and battery wires. I tested battery for health at AutoZone. Still no dice. Worried that all these weird electrical issues were somehow related to some larger issue I was starting to freak out. I found water in the back electrical box housing the starter relay. A few of the fuses in there were corroded so I replaced all fuses with new and dried the starter box out. This didn't fix it. I pulled the ground cable from the bottom side of the motor and sanded/cleaned this and re tightened. This was a big problem and fixed the ski cutting out to zero when running wide open and stranding me. I then replaced the beeper with one online, ordered a new starter, and borrowed ignition coils from my buddies ski. Coils fixed the skip. New starter engages every time. I think water got into it and rusted out the mechanism that pushes it forwards. I could see rust on the bearing and gear. New beeper beeps perfectly and 100% of the time. Ski is running at 100% again and is ready to go offshore again!

So after spending some significant time underwater...

-Ignition skip
-Starter doesn't engage but will spin
-Beeper is intermittent
-5A MPEM fuse blowing
-Ski cuts out to zero and won't start while running wide open

-Clean and re-tighten ground strap to motor
-Replace starter motor (water got inside and rusted mechanism).
-Replaced Beeper (intermittent beeper function likely beeper going out)
-Replaced Ignition coils (they were submerged and worked but would miss some fires)

It's hard to say what caused the 5A fuse to blow, but there was water in the starter relay box, and the ground strap was not getting a great connection. Haven't blown one since the above solutions. The forum posts on that 5A fuse blowing had me a bit freaked out as the part cost is almost $500. If you're getting my above issues address the things I listed above before buying an MPEM. I probably would have ordered one as part of my troubleshooting if my buddy didn't have one I could borrow to rule that out as a factor.

It was a lot of different small problems making it seem like there was one really big problem causing it all. Hope this can help someone as I tore the forums apart looking for information and while there were bits and pieces I could use from various posts, there wasn't one where someone had the same problems at the same time as me, especially not one due to a sunken ski.
Last edited:
Not open for further replies.