First jetski giving me nothing but problems. Please help. 2010 GTX IS 260 Limited

Note: This site contains eBay affiliate links for which may be compensated
Not open for further replies.


New Member
Hello everyone, I just made this account because I am running out of options and if anyone could point me in the right direction, I would really appreciate it.

I bought my first jetski, a 2010 GTX IS 260 Limited, about 2 months ago with 160 hours on it. Looked in good shape, clean, previous owner seemed to have taken care of it, said he recently replaced carbon seal, and he ran it almost exclusively in freshwater. During the test drive, it ran like a dream so I bought it. Take it out basically the second day I owned it and drove it around for 5 minutes before it started giving me nothing but problems. I am mechanically savvy, and I like to try to repair everything myself to save a couple bucks, but currently I am not sure what my next step is. I am not familiar with jetskis, but I have owned a 21 foot boat which I maintain myself for 4 years.

So here's a list of problems I had with the Seadoo:

1. First time I ran it hard, gave me a high exhaust temp light. Code P0127. I checked inside the intercooler, clean inside, no oil or water. Ended up being a bad MAF sensor. Changed the sensor, and it was back to running good.

2. I put 2 more hours on it before the next thing happened. Was cruising at 56mph when all the sudden lost propulsion and RPMs went through the roof. Got code C2222 and P0127. I was dead in the water, but eventually got the thing back home. Opened up the jet pump, found the driveshaft teeth and impeller teeth completely grounded off, engine side was pristine. Figured I guess it was age and I got unlucky. There was no junk in the jet when I took it apart. Bought new impeller, driveshaft, wear ring, changed carbon seal while I was there. The driveshaft I bought was OEM but with a revised part number. Seadoos website said it was compatible with my jetski. When I compared the two driveshafts visually, the new one was about an eighth of an inch shorter than what I had. Teeth on engine and impeller side were exactly the same and I figured if seadoos website says it's good, then I guess it's good. (It wasn't good). Put the thing in the water, now we had propulsion but I still had the codes. Took it back out, read somewhere that sometimes computer needs time to adjust and codes will go away after some riding. Also, I unplugged the battery completely for a few hours. Put it back on the water, drove around a bit and codes were gone, jetski was riding good again.

3. Put 2 more hours on it. Was cruising again, suddenly lost propulsion temporarily and gained it again seemingly out of nowhere. White smoke out of exhaust, figured metal on metal contact. Brought the ski in, took it apart to find that the driveshaft teeth and impeller teeth again stripped. This time, only partially, about an eighth of an inch was stripped off. Turns out Seadoo was wrong. Fantastic. Bought a new propeller and driveshaft with the old part number that was the same length as the original. (3rd one now, keeping track?) Wear ring was fine, no damage done to it. Replaced driveshaft and impeller. Took it out on the water. As soon as I turned it on, I noticed the whole jetski now noticeably vibrates when idling (driveshaft alignment issue?) I got on the throttle and acceleration was noticeably very slow and as soon as it got to about 30ish mph, it threw a bunch of codes at me and a check engine light went on. C2221, C2222, P0127, C2231, C2260. I noticed some of the options disappeared off the dash too, couldn't find the settings menu, and the IS system that's usually shown on top did not even light up, nor was I able to access by pressing mode. When I restarted the jetski a few times, eventually the IS mode menu did show up, but I was not able to adjust the suspension with the arrows at all. I also noticed the key would consistently now take almost a full minute to read when before it would be maybe 10 seconds. Lastly, it seems like in neutral the idle is kind of sputtering? It oscillates around 1800-2000rpm, but not consistently 1900 like it usually did. However, maybe I just haven't noticed that previously and that could be normal. I checked the battery voltage, it was 12.87V, so I dont think it's a battery issue. If it is a wiring issue, I dont know where to start. I don't even think it's an engine issue since it ran perfectly fine right beforehand, previous owner said he did an oil change and changed ignition coils right before selling.

I spent more time laying under the damn thing than riding it. Any advice would be greatly appreciated. Sorry the post is long, I figured any detail can help. Thank you. -Arthur
Last edited:
I see you posted this in the 4 tec as well. You should delete this post, if possible, as this is for the older 2 cycle sea doos
I see you posted this in the 4 tec as well. You should delete this post, if possible, as this is for the older 2 cycle sea doos
Yeah I didn't realize I posted in the wrong forum at first, tried to delete but couldn't find a way to do it. Apologies.
Not open for further replies.