2005 Seadoo GTI/ RFI No start

Note: This site contains eBay affiliate links for which SeaDooForum.com may be compensated


So I’m racking my brain on this issue….long post alert!!!

I have 2005 Seadoo GTI/RFI. It ran decent last summer, but the compression was starting to fail…and then starting in the water became near impossible. I’ve rebuilt a few of these machines. So I just pulled the engine, and performed a top end rebuild. Even went ahead and changed the jet pump fluid, wear ring, etc.

After connecting everything and aligning the motor, the ski fired right up first try. The machine was smoking like crazy (which I was expecting because of the oil and trying to break the rings in). Initially, compression was showing 140 Magneto side - and 135 PTO side. I figure this would increase as the rings set. I cranked the ski and then connected a hose and ran it for about 5 minutes to get it nice and warm and recheck the compression. No change. Then took it to the river and tried to start it…nothing. The battery was showing 12.6 volts and upon starting, dropping to 11.3 volts. I initially thought it was the battery, so I put that one on my charger and put it a brand new battery, same result.

Brought the ski back, removed the fuel injectors and cleaned them with my electronic injector cleaner and they’re spraying great. Also made a fuel pressure gauge and I’m getting 60 PSI. I can hear the fuel pump prime every time I install the key. Took the fuel pump assembly out today and went ahead replaced both filters (even though I replaced them last season too.) I trimmed the ignition cables and checked for spark with my tester and I’m getting good bright spark. Now the ski will not crank period….the starter motor just engages and turns the engine, but doesn’t crank. Thinking my engine was either hydro-locked or fuel-locked, I removed the spark plugs and cranks the engine to expel any water or fuel inside the engine. Installed new spark plugs and finally the engine started for a second and shut off. Now it’s the doing the same thing. Starter motor engaging the motor and rotating everything, but not starting.

I will also add that when I first started it after the rebuild, and then connected it to water, I did see water dripping minor drips from the PTO side closest to the starboard side of the motor. So I’m not 100% that the new head gasket is holding. Current compression is still 140/135.

Is there anything else I’m forgetting?
I just did the top end of my 01 gtx RFI. Ran great on first try. Then nothing. I think I may have a fuel delivery issue. As I have spark and compression.

I did have trouble seating the fuel rail. Thinking I may have damaged it.

Did you resolve your issue >