sounds rough, vibration and low power - solved! (with pics)

geoffwea

New Member
Messages
4
Likes
0
Water Crafts
GXT 155
#1
just took my 155 GTX 2013 out for a spin and 30 mins into use the following things happened;

- lots of engine Vibration
- Low power output
- Sounded like it was running roughly.

I put into reverse and it came right. After another 10 mins problems occurred again and I couldn't remedy by turning on / off, putting in reverse and playing with throttle.

I just purchased second hand. I've only done 7 hours (total 107) which has been awesome and I'm still learning about the mechanical aspects of my Jetski.

Its on a trailer on my drive way ... should I remove from trailer and inspect intake or is it likely to be my wear ring? (replaced at 100 hours).

Do these symptoms occur when intakes are blocked, or could it be something worse :(.

Suggestions very much appreciated.

Geoff
 


geoffwea

New Member
Messages
4
Likes
0
Water Crafts
GXT 155
#3
thanks, I think this small stick may have had something to do with problems :)

I'm amazed that such a small stick can withstand the rotational power of my 1500cc engine ......

Good advice and lesson about how seemingly small sticks can cause big problems.
 

Attachments

mkov608

Active Member
Messages
531
Likes
29
Location
Pensacola, FL
Water Crafts
1995 XP (sold)
1999 GTX Limited (sold)
2X 2002 GTX 4-tec
#4
Yep ... junk in the pump is never a good thing. Last season I caught something in my pump that raised a slight edge on the wear ring, and then the impeller started unraveling the wear ring. Yikes! From the looks of it, you may need to invest in a new impeller and wear ring soon. Damage to the impeller can cause dynamic balance issues.
 

Adsense

Usergroup

Administrator Moderator Premium Member
Top