Shop Discount Sea-Doo Parts

Sea-Doo GTX wont crank

Akalewey

New Member
Messages
5
Water Crafts
1995 Sea-Doo GTX
1991 Yamaha Wave Runner
Hello all! I recently became the new owner of a 1995 Sea Doo GTX. I’ve spent the majority of the day today working on it as I was led to believe after some fresh gas, oil, and a new battery that she would start. Upon trying to start it, it did absolutely nothing. The button made a click sound that’s it. No lights no sounds no attempts to crank. Just dead. I did pull the plugs (they are very bad) and crank the motor to make sure it wasn’t locked and it was good. To be honest I’m new in the jet ski world and not sure what to do now. Any help would be appreciated!
 

GGuillot

Well-Known Member
Messages
1,158
Location
Alabama
Water Crafts
1997 GTX
1996 GSX
Hello all! I recently became the new owner of a 1995 Sea Doo GTX. I’ve spent the majority of the day today working on it as I was led to believe after some fresh gas, oil, and a new battery that she would start. Upon trying to start it, it did absolutely nothing. The button made a click sound that’s it. No lights no sounds no attempts to crank. Just dead. I did pull the plugs (they are very bad) and crank the motor to make sure it wasn’t locked and it was good. To be honest I’m new in the jet ski world and not sure what to do now. Any help would be appreciated!
It's possible the starter solenoid is frozen. I'd start there by testing it. There's good videos online that can guide you if you're unsure how to. Once that's good and it still doesn't start, chase down the switches like the start/stop button and test they close the circuit. Then move on to all the grounds, if it's been sitting awhile, especially outside, corrosion may have developed, so check those out.
 

Akalewey

New Member
Messages
5
Water Crafts
1995 Sea-Doo GTX
1991 Yamaha Wave Runner
Alright. Now that one out of the two are running I’m finally ready to start on this one. Now, with a new battery in it it I’m not seeming to get any power to the ski at all. I’m not getting any sort of lights on the gauges as well as any crank. It’s really just a dead fish right now. I did notice upon closer inspection that the wires running under the front trunk into the hood and what I assume goes to the gauges were chewed by a mouse. Some of the rubber was chewed, so I’d assume I have an electrical issue somewhere causing this. What’s the best way to go about it? All help is appreciated as I’m brand new to the world of PWC’s, thanks!:)
 

GGuillot

Well-Known Member
Messages
1,158
Location
Alabama
Water Crafts
1997 GTX
1996 GSX
Alright. Now that one out of the two are running I’m finally ready to start on this one. Now, with a new battery in it it I’m not seeming to get any power to the ski at all. I’m not getting any sort of lights on the gauges as well as any crank. It’s really just a dead fish right now. I did notice upon closer inspection that the wires running under the front trunk into the hood and what I assume goes to the gauges were chewed by a mouse. Some of the rubber was chewed, so I’d assume I have an electrical issue somewhere causing this. What’s the best way to go about it? All help is appreciated as I’m brand new to the world of PWC’s, thanks!:)
Unplug and pull the harness out the ski then lay it out. Probe the multi meter going from plug to plug verifying continuity. Splice in new wire where needed using a soldering iron and heat shrink. Or find a harness out of another ski...
 

etemplet

Well-Known Member
Messages
3,203
Location
Louisiana
Water Crafts
1996 SPI, 1996 GTX, 1997 GTX
Check the plug that goes into the mag. Unplug it and give it a cleaning.. Unplug the plug going to the gauges and check the black and purple wires. See if they are shorted. I found these issues on a GTX I just worked on. :)
 

Akalewey

New Member
Messages
5
Water Crafts
1995 Sea-Doo GTX
1991 Yamaha Wave Runner
What is the mag? It wouldn’t start at all if those shorted? Those are definitely the ones that were chewed. I did bridge the gap between the solenoid bolts and it turned over. How can i tell if those wires shorted? I’m in a bit over my head with electrical issues! haha
 

etemplet

Well-Known Member
Messages
3,203
Location
Louisiana
Water Crafts
1996 SPI, 1996 GTX, 1997 GTX
I think it was a GTX 717 engine. Melted the plug going into the mag. The 4 pin plug at the front of the engine. I had him check the plug for the fuel gauge and speedo. positive and ground were shorted. Probably burned out the rectifier, sure smelled bad. I replaced it. :) He still has a mag issue. If the MAG plug is disconnected the ski usually doesn't do anything. Don't know what to tell you... electrical is my growth area as well. LOL Good Luck !
 

GGuillot

Well-Known Member
Messages
1,158
Location
Alabama
Water Crafts
1997 GTX
1996 GSX
What is the mag? It wouldn’t start at all if those shorted? Those are definitely the ones that were chewed.
(Mag) or Magneto, where the charging system of the ski is, front of the engine. There's a plug there you'll see with a bunch yellow black wires, if the ground wire on that plug is cut, bad, chewed, the ski won't do anything. It can't complete the ground loop back through the engine, which with the starter bolted on traces back to the battery negative. Download a service manual to see the wiring schematics and it'll show all the ground points.

I still think your best bet is going to be pulling the harness out the ski and testing plug to plug and repairing, or get a harness out another comparable ski.
 

Akalewey

New Member
Messages
5
Water Crafts
1995 Sea-Doo GTX
1991 Yamaha Wave Runner
I’ve tested everything in the electrical box and everything comes back as normal, except for the yellow an red wire That comes from the stop start button and goes into the solenoid. I’ve tested it’s current from one side of where it goes into the control module to the other and it has no current there. I can get it to start and fire in a variety of different ways. The start stop switch is good, the kill switch is good. Does anyone know what goes on exactly inside that control module that could be causing this?
 

SPONSORED LINKS

Usergroup

Administrator Moderator Premium Member
Top