Shop Discount Sea-Doo Parts

New jet pump and lost power....... HOW???

Status
Not open for further replies.

knied1

New Member
Messages
24
Location
buffalo
Water Crafts
2000 GTX RFI
2002 GTI
91 jetmate with 750 conversion
I have a 2000 GTX RFI, on the speedometer its been running 61 to 63 MPH (I know the speedo isn't exact)
The machine ended up sucking up a stick, and took large chunks out of the 3 veins in the jet drive. since then the machine has been running 56 to 58 range on the speedo, and caveating. when the stick was sucked up I took the machine to the dealer we bought it from, and they repaired the impeller said the jet pump wasn't repairable.....replace it if I want the power back.

So I now bought a NOS jet drive, WITH new wear ring installed, and ran the machine last night.
I`m only getting 42 to 46 MPH out of the machine and I do not understand why.

I am running the same impeller, yes I did put oil in the jet drive when I installed it, and yes I did follow all torque specs. I

The machine doe not seem to cavitate, but also doesn't seem to have the ass it did before installing the new pump.

Your input will be greatly appreciated.
 

LouDoo

Premium Member
Premium Member
Messages
12,673
Location
Lexington, KY
Water Crafts
SeaDoo's: 96 GTI 720, 95 XP 800 Limited, 96 GSX 787. 2000, 18' Bayliner 3.0L.
I would check two things. First since it's a new pump you will need to align the pump to the motor, you will need an alignment tool. [MENTION=43374]Coastiejoe[/MENTION] has one that he rents at cost. I would also check the carbon seal.

Lou
 

knied1

New Member
Messages
24
Location
buffalo
Water Crafts
2000 GTX RFI
2002 GTI
91 jetmate with 750 conversion
Lou,

I did align the pump to the motor, probably should have stated that in my first message.
since im getting 10 to 12 more MPH on the jet pump with broken vanes im not sure how the carbon ring can be the issue?

can you explain that one to me a little please.

Coastie,

Thanks for the link, I was able to borrow the tool from the dealer I purchased the machines from.
 

mikidymac

Moderator
Staff member
Moderator
Messages
12,715
Location
California
Water Crafts
2003 GTI
2001 XP
1996 XP
1996 HX
1991 Superjet
2001 Superjet
Hold on. The pump doesn't get aligned to the motor. There is no need to realign anything by just replacing the pump. The engine is aligned to the shoe and the pump bolts to the shoe. So since the pump has to be out to align anything swapping a pump will not cause any alignment issues.

What used pump did they sell you? Did it look just like your old one. Some are big hub and some are small hub as well as plastic or brass.
 

knied1

New Member
Messages
24
Location
buffalo
Water Crafts
2000 GTX RFI
2002 GTI
91 jetmate with 750 conversion
It was plastic not brass.....the numbers on the body of the pump were the exact same as the old one.

I was New Old Stock that I bought....so everything in it is brand new....wear ring, bearings seals shaft ETC
 

knied1

New Member
Messages
24
Location
buffalo
Water Crafts
2000 GTX RFI
2002 GTI
91 jetmate with 750 conversion
AND BTW....my biggest reason for checking alignment is when the stick got sucked in it stalled the motor like it was seized.....once I got the stick out everything ran fine
 

LouDoo

Premium Member
Premium Member
Messages
12,673
Location
Lexington, KY
Water Crafts
SeaDoo's: 96 GTI 720, 95 XP 800 Limited, 96 GSX 787. 2000, 18' Bayliner 3.0L.
I could be wrong but on a 95GTX the pump is mounted directly to the hull, there is no shoe. The pump is aligned with shims (washers). Mute point since the alignment has been checked.

Lou
 

knied1

New Member
Messages
24
Location
buffalo
Water Crafts
2000 GTX RFI
2002 GTI
91 jetmate with 750 conversion
Ok so last night I took the jet drive back out, and checked EVERYTHING again.
the following is ALL brand new
seals, bearing, impeller shaft. housing, wear ring.

when I put the impeller on it spun inside the assembly nice and smooth, and freely
I put the nose cone on, and I wasn't ably to spin the impeller
after filling the nose cone with oil it spins, but does seem to spin tough.

is it possible that the impeller shaft is too long? and does anyone know what length it is supposed to be?


Thank you,
 

SabrToothSqrl

Well-Known Member
Messages
5,666
Location
PA
Water Crafts
2002 GTX & XP
Sounds like something is binding somewhere in the pump. I'd check the washers/bearings at the end of it.

Correct, there is nothing to align by changing the pump.
 

knied1

New Member
Messages
24
Location
buffalo
Water Crafts
2000 GTX RFI
2002 GTI
91 jetmate with 750 conversion
I agree, but the bearings are brands new, and before I put the nose cone on everything spins super smooth and free....only after putting the nose cone on it binds.
I am guessing it is the " button" that pushes on the end of that impeller shaft, but that is just an assumption
 

mikidymac

Moderator
Staff member
Moderator
Messages
12,715
Location
California
Water Crafts
2003 GTI
2001 XP
1996 XP
1996 HX
1991 Superjet
2001 Superjet
On some of the newer pumps you have to actually use something to push the "button" release when you put the cone on. I use the allan wrench for the plug to do it. IF you don't keep the release lever pushed down it can cause the spring loaded plunger "button" to bind up.

The manual shows the procedure.
 

mikidymac

Moderator
Staff member
Moderator
Messages
12,715
Location
California
Water Crafts
2003 GTI
2001 XP
1996 XP
1996 HX
1991 Superjet
2001 Superjet
A good pump will have some resistance when assembled but you should still be able to turn the impeller with one finger. IF it is harder than that or hurts your finger it needs to be looked at closer, They can also be tight on a new wear ring so check that too. If it turns easy with the cap off I think the "pusher" is the issue.
 

knied1

New Member
Messages
24
Location
buffalo
Water Crafts
2000 GTX RFI
2002 GTI
91 jetmate with 750 conversion
trying to find the " Pusher in my manual, and I don't see one.
does anyone have instructions on it.....just making sure im not skipping something.


thanks again
 

mikidymac

Moderator
Staff member
Moderator
Messages
12,715
Location
California
Water Crafts
2003 GTI
2001 XP
1996 XP
1996 HX
1991 Superjet
2001 Superjet
Page 09-02-17 and 09-02-18 of the 2000 GTX RFI manual.
 

knied1

New Member
Messages
24
Location
buffalo
Water Crafts
2000 GTX RFI
2002 GTI
91 jetmate with 750 conversion
OK so I pull the plug on the nose cone, and using the allen wrench push in on the button, I hear a slight pop, and there it is.....a free spinning impeller.
THANKS ALL for the help.

so no I need to choose my impeller,
Solas makes a 15/23, and a 16/24 for my machine
stock is a 16/24 BUT it was recommended to me to go with the 15/23

is there a real noticeable difference between the 2.
I understand that I should get more hook up but less top end on the 15/23, and the opposite with the 16/24, BUT is there really a noticeable difference.
if I were to go with the 15/23 how much top end should I expect to loose from the 16/24

ONCE AGAIN THANKS TO ALL
 
Status
Not open for further replies.

Users who viewed this discussion (Total:0)

SPONSORED LINKS

Usergroup

Administrator Moderator Premium Member
Top