Less than 2 hours. iBR Error.

kevinsaw

New Member
Messages
1
Points
0
Location
hawaii
#1
Aloha (Edited your post to remove the OTHER site you mentioned) ..LOL

I'm kinda in a predicament. I purchased a brand new 2016 SeaDoo Spark from California and had it shipped out to Hawaii. I own (2) SeaDoos in Florida and have grown to love them so I thought a Spark would be a perfect smaller addition to have in Hawaii.

First time out was nice and easy. Started right up. I'm a very safe and conscious owner so no shallow water, no beaching, no bs.

2nd time out. 1 Hour and 45 Minutes into ownership.
I got to the dock, easy launch, pushed off and hit the start button in about 10 feet of water... loud beep, flashing iBR light.

And here's a video: https://www.youtube.com/watch?v=y_2KVH55zzY

Motor started fine but it was stuck in neutral and I was slowly drifting away. Fortunately, someone threw me a line and I was pulled back to the dock. Tried a few more times. Waiting about 20-30 minutes. Tried again. Still no luck. Put her on the trailer and came home.

I did a little bit of reading and checked the basics: Battery & loose bolts. Everything seems fine.

The biggest issue is, there isn't a SeaDoo dealer in Hawaii. I've contacted the dealer in CA but they're closed for the weekend.

Anyone have an idea if this is an easy fix? Any help would be greatly appreciated.

Thanks,
Kevin
 
Last edited by a moderator:

racerxxx

Moderator
Moderator
Messages
10,075
Points
63
Location
Chalfont, Pennsylvania
#2
Welcome to the forum, Seadooforum

Have you disconnected the battery and left it unhooked for any time? Possibly it might reset (a guess at that), have you inspected for any thigh in the way of allowing it to move, externally? I know a while back guys with the couch skis had anodes that fell and jammed the iBR and would fault out and stick the ski in neutral.
 
Messages
57
Points
8
Location
CT
#3
If you read the owners manual it gives you a way to manually override the IBR to check it. I don't remember the procedure but if you inspect it and find nothing wrong you may be able to reset it using the manual over ride procedure.
 

Similar threads


Users who viewed this discussion (Total:0)

Adsense