Check engine codes? No dealerships here!!

Lutra

New Member
Messages
5
Likes
0
Water Crafts
2
#1
We have a pair of 2016 Sparks on a little island in the bahamas, far from dealerships.
One has ibr and trim, the other does not.
the one with ibr first started not going over 25mph. It felt like it would speed up for 5 seconds then slow down 5 seconds then repeat. Did spark plugs and the idiot that did them forgot to install one so it blew the coil pack out of the motor. Got new plugs and put it all back together but now "Check Engine" comes across the screen, it beeps very loud, and wont go over 25.
At some point, I tried the really dumb idea of swapping head units. Now the other one won't even start.

I got a brp > OBD2 adapter. Can I plug this into a standard OBD2 scan tool or do I need a Candoo or Tactrix? They have been out of commission forever now... PLEASE help!

Yes I have disconnected the batteries for extended periods of time. I tried riding the one at 25mph for 15 minutes and still nothing. It rides like a charm, despite the check engine light.
 


Lutra

New Member
Messages
5
Likes
0
Water Crafts
2
#3
Now that I think about it, I also had to do the wear ring on the one that won't go over 25....perhaps it's jet is still messed up?
 

Lutra

New Member
Messages
5
Likes
0
Water Crafts
2
#4
no one taking orders at pwcmuscle on saturdays? won't ship til monday i assume? Can take up to a week to ship things here just from ft lauderdale
 

hfgreg

Administrator
Staff member
ADMINISTRATOR
Messages
2,999
Likes
22
Location
Tampa, Fl
#5
no one taking orders at pwcmuscle on saturdays? won't ship til monday i assume? Can take up to a week to ship things here just from ft lauderdale
Did you order? Missed this message. We take calls on the weekend usually but this weekend we were out.

You can PM me anytime on here and I will get it right away!
 

Digdog

Active Member
Messages
134
Likes
10
Location
Saskatoon
Water Crafts
Seadoo RXT-X 260
#6
We have a pair of 2016 Sparks on a little island in the bahamas, far from dealerships.
One has ibr and trim, the other does not.
the one with ibr first started not going over 25mph. It felt like it would speed up for 5 seconds then slow down 5 seconds then repeat. Did spark plugs and the idiot that did them forgot to install one so it blew the coil pack out of the motor. Got new plugs and put it all back together but now "Check Engine" comes across the screen, it beeps very loud, and wont go over 25.
At some point, I tried the really dumb idea of swapping head units. Now the other one won't even start.

I got a brp > OBD2 adapter. Can I plug this into a standard OBD2 scan tool or do I need a Candoo or Tactrix? They have been out of commission forever now... PLEASE help!

Yes I have disconnected the batteries for extended periods of time. I tried riding the one at 25mph for 15 minutes and still nothing. It rides like a charm, despite the check engine light.
Sounds like it is in Limp Mode, you should be able to read a code on your screen and diagnose from there.
 

Users who viewed this discussion (Total:12)

Adsense

Usergroup

Administrator Moderator Premium Member