Buzzing sound won't quit. Ready to ride!

susanmac

New Member
Messages
16
Points
1
Location
Lake City SC
#1
I have 2 skis. '05 Bombardier makes a buzzing noise when going about 20 mph or better. Then it continues. Wondering if it could be a sensor and how to replace if so? Any ideas welcome. Just got the skis last summer. Love them!
 

ryffish

Premium Member
Premium Member
Messages
307
Points
51
Location
US
#3
did you check your impeller and wear ring ? That could be it you might have sucked something in it
 

ryffish

Premium Member
Premium Member
Messages
307
Points
51
Location
US
#4
Or your carbon seal and bellows it has that rubber wrapped around it might be tore
 

susanmac

New Member
Messages
16
Points
1
Location
Lake City SC
#5
Thanks ryffish. I will check into that. When I bought them they said the wear ring had been replaced recently. I guess that might be the reason why. I will try to get that checked.
 

ryffish

Premium Member
Premium Member
Messages
307
Points
51
Location
US
#7
you didnt say your check engine light was on . If you are throwing off a code you have to hook up to either buds or candoo pro it will give you a number and tell you what's wrong. Problem is you might have to take it to a pwc mechanic. you can do it yourself but you would have to buy a candoo home edition that would give you the diagnostic power you need
 

ski-d00

Well-Known Member
Messages
2,163
Points
63
Location
St. Marys, Ohio
#8
That's the first time you mentioned check engine light which is kind of important information. You need to explain the problem better in more detail and exactly what is happening. When you say buzzing, do you mean the beeper is going off? Is it constant, or a long beep every minute or so? Do you get any message on the dash like OIL with the check engine, red light flashing? What makes it go away? Does it start, idle, and run fine? Have you pressed set 5 times while it is beeping to get a code?

With your current description, I can limit it down to about 200 possible issues.
 

susanmac

New Member
Messages
16
Points
1
Location
Lake City SC
#9
The jet ski starts and idles fine. Usually when it gets above 20 mph the check engine light comes on and a beep that lasts for 5 seconds comes on and continues every few minutes unless you restart the jet ski
 

susanmac

New Member
Messages
16
Points
1
Location
Lake City SC
#11
That's the first time you mentioned check engine light which is kind of important information. You need to explain the problem better in more detail and exactly what is happening. When you say buzzing, do you mean the beeper is going off? Is it constant, or a long beep every minute or so? Do you get any message on the dash like OIL with the check engine, red light flashing? What makes it go away? Does it start, idle, and run fine? Have you pressed set 5 times while it is beeping to get a code?

With your current description, I can limit it down to about 200 possible issues.
Sorry. I should have gotten my son to describe it better from the start. Thanks. I didn't know about pressing set 5 times for a code.
 

ski-d00

Well-Known Member
Messages
2,163
Points
63
Location
St. Marys, Ohio
#17
Very rarely do the exhaust temp sensors fail and since you say in your description that it goes off at 20mph it is even more likely that it is working fine and telling you that your exhaust is getting too hot. There are 3 small holes in the exit of the J-pipe that clog and will cause exactly what you are describing. Once these are cleaned, it won't trigger the code because it is getting better water flow to the waterbox keeping it cool and it works fine.

This is a situation that normally gets progressively worse. Did this start out doing it only at full throttle? And then continue to do it more often? And now does it all the time?
 

Similar threads


Users who viewed this discussion (Total:0)

Latest posts

Adsense