3D with smoking running problems.

Status
Not open for further replies.
Messages
13
Likes
0
Location
Scotland
Water Crafts
Seadoo RX
Seadoo 3D
Seadoo Challenger 240EFi
#1
Hi everybody, I'm loving for some help with my Seadoo 3D, I had it out for the first time on Sunday at Loch Lomond, put it in the water and it started great with new plugs in, fresh fuel and oil, it's been laid up awhile. It was running great for around 6-7mins then the amber light came on, it started to lose power and stutter, I headed for the pontoon and had a look. When I lifted the cover the engine bay was covered in smoke, almost like it was on fire! I checked and everything was OK, no fire. I let it cool down and after 10mins she started again, I had a little blast and again it lost power and I went back to the pontoon. Opened up the cover, loads of smoke again! I took it out the water and she starts and runs great out the water, no miss firing or nothing, but I the water it only runs for 5mins and it starts to lose power almost to the point of cutting out.
I did read on the forum about the water elbows on them clogging up for the exhaust? Does this sound like the fault??
I little blast I did have it was ace, so I'm really wanting to fix her ASAP!
Thanks team.
 


Coastiejoe

Moderator
Staff member
Moderator
Messages
14,648
Likes
97
Location
FLorida, Southern Area
Water Crafts
2009 RTX X (255 hp supercharged / inter-cooled).
2010 GTX 155
#2
Take it to the ramp, back down, pull the seat, start it up. See where the smoke is coming from..
 
Status
Not open for further replies.

Users who viewed this discussion (Total:0)

Adsense

Usergroup

Administrator Moderator Premium Member
Top