Bilge Pump - Seadoo Forums

Visit PWCMuscle.com
for 15% off all Hydro Turf - CODE: HYDRO15
Need OEM parts for your boat or PWC? Visit SeadooWarehouse.com
Results 1 to 6 of 6

Thread: Bilge Pump

  1. ☑ ORIGINAL POSTER #1

    Join Date
    Sep 2017
    Location
    ON
    Posts
    5
    Thumbs Up
    Received: 0 Given: 0


    Default Bilge Pump

    hi I'm new to this forum. Just bought an older 1997 Challenger 1800 as a winter project for my kids and I to get it back up and running by spring. There are a lot of posts on bilge pumps but i cannot find anything to directly answer my question and it may be basic but here it is.

    I can't seem to get it to turn on at all, but shouldn't it turn even when out of water, engines are not running but i press the button? or do the engines need to be running?

    thanks.

    0 Not allowed!

  2. # ADS
     

  3. #2
    Member whitewheels's Avatar
    Join Date
    Oct 2014
    Location
    Sweden
    Posts
    92
    Watercrafts
    Sportster LE
    Thumbs Up
    Received: 0 Given: 11


    Default

    No. It should turn on without engine running. It has a autobilge function but you can manualy turn it on on the knob
    /Glenn - Tavelsjo

    2000 Sporster LE

    0 Not allowed!

  4. ☑ ORIGINAL POSTER #3

    Join Date
    Sep 2017
    Location
    ON
    Posts
    5
    Thumbs Up
    Received: 0 Given: 0


    Default

    Thanks whitewheels, that's exactly what I expected

    0 Not allowed!

  5. #4
    Experienced Rider Lumps's Avatar
    Join Date
    Sep 2016
    Location
    CANADA
    Posts
    330
    Watercrafts
    2000 seadoo challenger 2000
    Thumbs Up
    Received: 4 Given: 3


    Default

    do you have a battery switch in the trunk? I have a 2000 challenger 2000 and it comes with the battery switch. the bilge pump is on the wrong side of that switch in my opinion. my auto bailer only works with the main power switch turned on. I have been considering rewiring it so it will run without having everything else powered.

    anyway, I assume you would have tried it with the power turned on either way. sometimes the impellers get clogged with junk. they just pop off the little plastic mount you should be able to check it out. if you determine the pump is actually shot, they are just generic "Rule" pumps and are easily replaced. I think the little mounting basket is even still the same

    0 Not allowed!

  6. #5
    Member whitewheels's Avatar
    Join Date
    Oct 2014
    Location
    Sweden
    Posts
    92
    Watercrafts
    Sportster LE
    Thumbs Up
    Received: 0 Given: 11


    Default

    Quote Originally Posted by Lumps View Post
    do you have a battery switch in the trunk? I have a 2000 challenger 2000 and it comes with the battery switch. the bilge pump is on the wrong side of that switch in my opinion. my auto bailer only works with the main power switch turned on. I have been considering rewiring it so it will run without having everything else powered.

    anyway, I assume you would have tried it with the power turned on either way. sometimes the impellers get clogged with junk. they just pop off the little plastic mount you should be able to check it out. if you determine the pump is actually shot, they are just generic "Rule" pumps and are easily replaced. I think the little mounting basket is even still the same
    I totally agree with you there. I have a small leak in the hull so leaving the boat uatended for a week i need to have the battery switch turn on....not ideal

    0 Not allowed!

  7. ☑ ORIGINAL POSTER #6

    Join Date
    Sep 2017
    Location
    ON
    Posts
    5
    Thumbs Up
    Received: 0 Given: 0


    Default

    Thanks for the responses. i do not have a battery switch in the back so this won't be a factor. i think it must either be clogged or shot completely. i'll pull it out this weekend and find out.

    0 Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bilge Pump, Nav Light and Bilge Fan, all not working!!!
    By YellowSeadoo2003 in forum 2-Stroke Sea-Doo PWC forum
    Replies: 2
    Last Post: 05-31-17, 01:07 PM
  2. Bilge pump
    By vicnem3rd in forum Mercury Powered SeaDoo Sport Boats
    Replies: 2
    Last Post: 08-04-16, 09:12 PM
  3. Bilge pump mod to my LRV
    By adv bum in forum 2-Stroke Sea-Doo PWC forum
    Replies: 7
    Last Post: 10-04-13, 12:41 PM
  4. Bilge pump, what have you done????
    By Coastiejoe in forum 4-Tec Sea-Doo PWC Forum
    Replies: 4
    Last Post: 09-01-12, 08:03 PM
  5. Bilge pump, nav lights, and bilge fan not working
    By Chuck3too3 in forum 2-Stroke SeaDoo Sport Boat Forum
    Replies: 7
    Last Post: 07-14-12, 03:34 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Register forum what's new