2011 Seadoo Wake 155 - IBR Module Error - Limp mode, won't go over 5,000rpm - Seadoo Forums
Need OEM parts for your boat or PWC? Visit SeadooWarehouse.com
Results 1 to 5 of 5
  1. ☑ ORIGINAL POSTER #1
    Senior Member
    Join Date
    Nov 2011
    Location
    Northern CA
    Posts
    106
    Watercrafts
    2011 Seadoo Wake 155 - 1996 Seadoo GTX
    Thumbs Up
    Received: 1 Given: 164


    Default 2011 Seadoo Wake 155 - IBR Module Error - Limp mode, won't go over 5,000rpm

    My son took our 2011 Seadoo Wake out with a buddy and ran over a light patch of weeds by mistake. It bogged the engine and was limping along. He tried to gun it to work the weeds through (which he has done in the past when this happens), but this time he couldn't get it running right. It then went into limp mode showing the error "IBR Module Error" an it wouldn't go over 5,000rpm's (will quickly get up to 5,000rpm's, then hold there). I tried turning it off, letting it cool down, then trying again. This didn't do anything. I'm still getting the "IBR Module Error" message and it won't go over 5,000rpm's.

    Is there anything you would suggest someone that's not extremely handy (me) could try to get this working again without needing to take it anywhere?

    Thanks in advance!!!

    0 Not allowed!

  2. # ADS
     

  3. #2
    Coastiejoe's Avatar
    Join Date
    Apr 2011
    Location
    FLorida, Southern Area
    Posts
    14,566
    Watercrafts
    2009 RTX X (255 hp supercharged / inter-cooled). 2010 GTX 155
    Thumbs Up
    Received: 689 Given: 5


    Default

    Inspect the intake, drive shaft, impeller and the IBR system. Could be weeds wrapped up in there. If it is running hot, there are weeds for sure.
    Repairing iPhones and iPads. and Mini iPads Cracked screens, motherboards, speakers, home buttons ect ect,

    Screen replacements for iPhone and iPads. Discount to all forum members. Stocking refurbished iPhones and iPads..

    0 Not allowed!

  4. ☑ ORIGINAL POSTER #3
    Senior Member
    Join Date
    Nov 2011
    Location
    Northern CA
    Posts
    106
    Watercrafts
    2011 Seadoo Wake 155 - 1996 Seadoo GTX
    Thumbs Up
    Received: 1 Given: 164


    Default

    It's still in the water. I got in the water and made sure the intake grate is completely free from any obstructions. I'm assuming the weeds that jammed it up in the first place worked through while my son was giving it throttle. We can normally just give it a little throttle and the weeds will work through and the seadoo will run fine after that. This time, I still think the weeds ran through, but the seadoo went into a limp mode and is showing that "IBR Module Error" and will not let the seadoo switch into normal driving mode.

    If there is still something clogging it up, it is further inside the system than the intake grate as I can't feel anything even reaching through the grate for any obstructions.

    Is there a way to reset the system and get it out of the "IBR Module Error" state it's currently in? Would that allow the engine to enter a normal driving mode?

    0 Not allowed!

  5. #4
    Junior Member
    Join Date
    Jul 2017
    Location
    New Orleans
    Posts
    1
    Watercrafts
    2012 Sea-Doo GTI Limited 155
    Thumbs Up
    Received: 0 Given: 0


    Default

    Quote Originally Posted by Fish1 View Post
    It's still in the water. I got in the water and made sure the intake grate is completely free from any obstructions. I'm assuming the weeds that jammed it up in the first place worked through while my son was giving it throttle. We can normally just give it a little throttle and the weeds will work through and the seadoo will run fine after that. This time, I still think the weeds ran through, but the seadoo went into a limp mode and is showing that "IBR Module Error" and will not let the seadoo switch into normal driving mode.

    If there is still something clogging it up, it is further inside the system than the intake grate as I can't feel anything even reaching through the grate for any obstructions.

    Is there a way to reset the system and get it out of the "IBR Module Error" state it's currently in? Would that allow the engine to enter a normal driving mode?
    You would need a RIVA or CanDoo diagnostic kit to reset the error. You need to take it out of the water, check that everything is cleared out of both the jet and the iBR and it should go back to normal. use the IBR override to help your inspection.

    This happened to me recently, believe it our not, charging the battery with a battery tender jr. overnight also affected it for some reason.

    There is a forum on the iBR module errors in here somewhere as well.

    0 Not allowed!

  6. ☑ ORIGINAL POSTER #5
    Senior Member
    Join Date
    Nov 2011
    Location
    Northern CA
    Posts
    106
    Watercrafts
    2011 Seadoo Wake 155 - 1996 Seadoo GTX
    Thumbs Up
    Received: 1 Given: 164


    Default

    Thanks jasonstewart, but I'm hoping it'll be much cheaper to have this fixed than the cost of one of those items. The RIVA from the link is almost a $1,000, and the CanDoo is $400. If there's nothing I can do on my end without one of these tools, I would really hope the cost would be quite a bit less to bring it to someone that can fix/reset things.

    I'm assuming there's nothing I can do that could reset the system? Looks like I'll need to bite the bullet and spend the time/hassle bringing it to a place that can take care of this.


    Thanks guys!

    0 Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1995 gtx seadoo limp mode
    By kgraff18 in forum 2-Stroke Sea-Doo PWC forum
    Replies: 11
    Last Post: 05-26-16, 07:55 PM
  2. How to fix limp mode on P0524 error code
    By Andrew gti130 in forum 4-Tec Sea-Doo PWC Forum
    Replies: 2
    Last Post: 02-13-16, 01:37 PM
  3. Replies: 27
    Last Post: 01-29-14, 02:01 PM
  4. 91 seadoo xp possibly in limp mode, need help
    By rwarren_5 in forum 2-Stroke Sea-Doo PWC forum
    Replies: 24
    Last Post: 07-12-11, 11:09 PM
  5. 2005 RXP oil light error limp mode please help
    By noslappers in forum 4-Tec Sea-Doo Boats
    Replies: 4
    Last Post: 06-23-11, 02:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Register forum what's new