Shop Discount Sea-Doo Parts

Search results

  1. brock1

    Hey do you have a used piston and ring for a !993 seadoo xp with the 657??

    Hey do you have a used piston and ring for a !993 seadoo xp with the 657??
  2. brock1

    No spark - Plugs wet

    ohh I assumed you had it hooked back up..yes that needs to be connected to have spark
  3. brock1

    No spark - Plugs wet

    its not a closed system so try to switch them the other way
  4. brock1

    Good to be back!!!!

    No marriage, "long story" but to make it short ill be a single daddy! Have to accept what is and keep going...so what have you guys been up to? im in need of some parts right now for the newest project but no one has any...got a 1995 waverunner 3 650cc....I need the start and stop switch that's...
  5. brock1

    Jet pump help

    sure can.. Lou beat me :cool:
  6. brock1

    1998 gtx rfi questions

    I think your bailer is probably just letting the excess water drain back down from the lines..your probably just fine..post if you need help!
  7. brock1

    1998 gtx rfi questions

    It wont pull it out that fast..If you roll it and get a fair amount of water in it then you need to just pull the plug when its on the trailer. Are you sure that the bailer is actually letting the water in? or just leaking back down from the lines after you stop Woops..messed up on which one...
  8. brock1

    Good to be back!!!!

  9. brock1

    Good to be back!!!!

    Holy shit!!!! Ive been trying to log in for 5 hours now!!!!!
  10. brock1

    Good to be back!!!!

    Hey everyone, been a while since I have been on here! How is everyone doing and whats new on the water??
  11. brock1

    96 xp800 spark problem

    to save yourself some time pull the wires going to the secondary coil and see if you have constant strong spark..if you do then its not the pickup, its the secondary..if you don't have gpopd cpnstant spark then start to trace the problem backwards
  12. brock1

    How has everyone been?

    sure is..commander 1000..
  13. brock1

    How has everyone been?

    im actually only about 2 hrs from the upper peninsula
  14. brock1

    How has everyone been?

    yeah still here..got a better job offer a little further north so I stayed..just need to get a few more toys now for the dirt, we have a ton of trails up here as well as lakes.. here is the latest toy..
  15. brock1

    How has everyone been?

    Hey all..been away for a while..whats new with you guys??
  16. brock1

    Oil light came on...reservoir full

    there is a float inside the tank..it may have fallen off the rail (probubly not) but its worth a try..if not the wire probubkly shorted
  17. brock1

    Please help! Sl 780 1996

    ok...i was being a smartass....welcome to our forum.. for me to be able to help you i need to know exactly what kind of ski we are talking about..you say sl780 so im thinking polaris right? ..whats it doing and what have you tried? do u have spark?..i need a detailed description please...thanks bud
  18. brock1

    Please help! Sl 780 1996

    expensive!!! very expensive!!..probubly low snatch fluid...top it off and try it...:driving:
  19. brock1

    96 XP suddenly quit

    pull the cover...99% sure you will find your problem
  20. brock1

    Ski won't rev!!

    they are probubly blacker than my neighbor! ...and he is BLACK!!! lol..great guy though :)
Top