Shop Discount Sea-Doo Parts

Recent content by wastadkey

  1. W

    New Kawasaki STX 1100 di

    I just got a three seater 2000 model kawi stx 1000 direct injection model...im absolutely in love with it...runs like it uses whipped cream and butter as the fuel (in other words, very smooth)!!!! Just a few questions Does it need a full sythetic oil like seadoo RAVE's? I would prefer a...
  2. W

    No spark, 96 xp

    :blush: I completely forgot about the coil!!!! I promise to send it sometime soon! Good news (kinda bad) I GOT IT TO START!!!!!!!!!!!!!!!!!!!!!!!!!!!!! :lol:After going through grounds ect, it started, i let it run for about 10 sec, then shut it off, then when i put the dess back on it wouldn't...
  3. W

    No spark, 96 xp

    I found a local mechanic that does 50.00 an hour...I am going to get him to do diagnostics, then buy the part(s) and replace them myself... Will reply with results Thanks everyone for all the help, espcially Loudoo, PPE, Dr honda, SKI Doo, and many others from my other thread... I really...
  4. W

    No spark, 96 xp

    JUst had a brain wave, I was reading other threads... Could my kill switch somehow be killing spark, no that it wont even turn over sometimes, and i have to wiggle it, to beep sometimes???
  5. W

    No spark, 96 xp

    Ok...also when I put dess on, it now makes a buzzing noise(not beeper, different than that) coming from the front ebox...would the cdi do that or the mpem? ? Also now when I go to Start of it turns over once, then sounds like it sparks and starts then immedietly stop all within about a second...
  6. W

    No spark, 96 xp

    I don't have any to swap out...should I go to seadoo and just get diagnostics?? Also in this model are the cdi and mpem separate or one part Btw thanks very much Dr. Honda for replying I hear ur the best!
  7. W

    No spark, 96 xp

    Ok, so I had a 4 page post on my ski, which didn't have spark...im sure i have pissed many people off by having such a long thread, it going dead, me bumping ect http://www.seadooforum.com/showthread.php?48173-96xp-782-cranks-doesn-t-start So here I go again... I have a 96 xp 787...
  8. W

    Maryland SeaDoo Repairs

    :coolgleam: Good to know!!! I'm in Annapolis, where are you located in md??? Mostly ride on the bay, severn river, south river... Also, what is your labour cost P/H????
  9. W

    1997 xp

    The 96' 787, does about 56-58mph stock, so I'm assuming the 97 should be pretty close??!
  10. W

    Nice XP!!! You just get it?

    Nice XP!!! You just get it?
  11. W

    96xp 782 cranks doesn't start

    Doing that now...any tips??? edit: Got all six bolts including the bigger one that mounts to the eninge, still won't pop off, does the oil pump one hold it on??? The top part prys off but the bottom seems stuck on
  12. W

    95 xp or 96 xp

    I agree...96 xp is great. If you have a compression tester bring it and ask to do a comp. test.
  13. W

    96xp 782 cranks doesn't start

    Yes and no...I didnt replace it, because it wasn't secured properly on that rear bolt, but now its fine. Still didn't start though as mentioned... Where do i go from here?
  14. W

    96xp 782 cranks doesn't start

    Any ideas??? Should I go ahead and take the mag housing off??? Don't, want to get into that until I am 100% sure its that...
  15. W

    96xp 782 cranks doesn't start

    Just tried, but didn't see spark, and wouldnt start with premix...was hoping for a quick fix...oh well!!! Were do I go from here? Could it still be the stator or pickup? I'm thinking it may be that because the arc test with the white wire didn't work...
Top