Visit PWCMuscle.com
for 15% off all Hydro Turf - CODE: HYDRO15
Results 1 to 10 of 10
  1. #1
    SeadooForum Pro
    Join Date
    Jun 2008
    Location
    Canada
    Posts
    1,313
    Thumbs Up
    Received: 0 Given: 0


    Default Problem with NEW wear ring, Need advise befor going back to dealer

    OK just had a new wear ring put in and i was out this weekend and noticed a slight decreas in performance, so today i looked at it through the intake grate and noticed that the top part of the wear ring looked fine but at the bottom of it the impeller has chewed it up and i bet i could put 2 quarters in between the ring and impeller and the groved cause by the impeller start on both sides and get bigger towards the bottom... any ideas why this is happening?????

    0 Not allowed!

  2. # ADS
     

  3. #2
    Banned
    Join Date
    May 2008
    Location
    inland empire, CA
    Posts
    5,084
    Watercrafts
    99' Seadoo Speedster
    Thumbs Up
    Received: 3 Given: 0


    Default

    maybe slight bend in shaft at impellor???

    0 Not allowed!

  4. #3
    SeadooForum Pro
    Join Date
    Jun 2008
    Location
    Canada
    Posts
    1,313
    Thumbs Up
    Received: 0 Given: 0


    Default

    Quote Originally Posted by timmyboy76 View Post
    maybe slight bend in shaft at impellor???
    If it was bent wouldnt the whole wearing be chewed up??? its only the bottom half. also ive never sucked up or had anything get stuck in there. I think something must be causing the impeller to move down and chew at the ring????

    0 Not allowed!

  5. #4
    Banned
    Join Date
    May 2008
    Location
    inland empire, CA
    Posts
    5,084
    Watercrafts
    99' Seadoo Speedster
    Thumbs Up
    Received: 3 Given: 0


    Default

    yah, ur right...maybe bearing in pump??? what if turn'n pto by hand w/ plugs removed, possibly feel "play" when turn'n?

    0 Not allowed!

  6. #5
    SeadooForum Pro
    Join Date
    Jun 2008
    Location
    Canada
    Posts
    1,313
    Thumbs Up
    Received: 0 Given: 0


    Default

    the only things i can think of would be a bad bearing or impeller shaft
    (not the drive shaft)

    0 Not allowed!

  7. #6
    seadoosnipe's Avatar
    Join Date
    Sep 2007
    Location
    Deep South
    Posts
    9,835
    Watercrafts
    1997 Challenger, 1997 GTX , 1991 SP and a shop with 2 spare 787cc's and a bunch of parts laying arou
    Thumbs Up
    Received: 32 Given: 0


    Default Bearings......

    Yeah, if you didn't change anything in the alingment when you did the wearing ring, then your probably seeing the results of a bad set of bearings. With the shaft angle like it is, the nozzle position, when you give it gas, if the bearings are going out, then the pressure on the shaft will push the impeller downward into the ring.

    Kinda strange you didn't notice it though. With your description, you'd think it would have wiggled a good bit side to side when you put it back together. The 4-TEC isn't set up like the 2 strokers, so seems it'd been more noticeable.

    I kinda doubt it would be the impeller shaft. You'd have noticed it while sliding it through the pump.

    Did the wear ring go in easy? YOu didn't have any glitches in it did you?
    Last edited by seadoosnipe; 09-23-08 at 11:18 PM.
    Looking for tips and advice, researched articles on carbs, spark plugs and general maintenance can be found at Snipes Korner. You can also follow me on "Twitter".

    Quality parts at low prices, visit Seadoowarehouse right here in our own forum. Please PM me if you are having a problem finding what you need!

    Is your jet ski fast? Do you want your XP or RXP to stand out? I know a place that has what you need to make it faster. Make your jetsksi a muscle craft, not just the ordinary, standard stock ski.

    Seen my GTX?... Those awesome graphics can be purchased from JetSki Detailing. Tell them Seadooforum sent you.

    Ever wonder what the inside of your 787cc engine looks like. Want to identify the parts, check out my thread on the 787. I'm sure there is something for everyone who want to learn about the internal parts.

    0 Not allowed!

  8. #7
    SeadooForum Pro
    Join Date
    Jun 2008
    Location
    Canada
    Posts
    1,313
    Thumbs Up
    Received: 0 Given: 0


    Default

    Quote Originally Posted by seadoosnipe View Post
    Yeah, if you didn't change anything in the alingment when you did the wearing ring, then your probably seeing the results of a bad set of bearings. With the shaft angle like it is, the nozzle position, when you give it gas, if the bearings are going out, then the pressure on the shaft will push the impeller downward into the ring.

    Kinda strange you didn't notice it though. With your description, you'd think it would have wiggled a good bit side to side when you put it back together.
    I had my dealer put the wear ring in.... im taking it back to the dealer this weekend. is there anything i can do to check the bearings befor i take it to the dealer, Im hopping that this is there problem not mine.... i dont feel like paying to have a wear ring replaced when i just did it. 3hr's of boat time is all its had sice it was replaced.

    0 Not allowed!

  9. #8
    SeadooForum Pro
    Join Date
    Jun 2008
    Location
    Canada
    Posts
    1,313
    Thumbs Up
    Received: 0 Given: 0


    Default

    would the bearing your talking about be #8 in the diagram? http://partsfinder.onlinemicrofiche....e=13&A=96&B=13

    Also is there anything else i should have them check out when they have the pump off so i avoid this kinda bull ****

    0 Not allowed!

  10. #9
    Banned
    Join Date
    May 2008
    Location
    inland empire, CA
    Posts
    5,084
    Watercrafts
    99' Seadoo Speedster
    Thumbs Up
    Received: 3 Given: 0


    Default

    "Also is there anything else i should have them check out when they have the pump off so i avoid this kinda bull ****

    the condition of where the bearing/s is seated. Like other threads/post/s, if bearing isnt right, shaft binds up..etc, so maybe the seated area for bearing, possibly worn abit...

    0 Not allowed!

  11. #10
    SeadooForum Pro
    Join Date
    Jun 2008
    Location
    Canada
    Posts
    1,313
    Thumbs Up
    Received: 0 Given: 0


    Default

    ok just got home from taking the boat to the dealer... I suggested that maybe it had a bad bearing but they think other wise. The dealer said it could be a worped pump housing???? how that could be i dont know seem kinda odd to me that ive put 50hrs+ on it this year take it in for a new wear ring and now its eating them right up.....

    0 Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Wear ring?
    By tsrparts in forum 2-Stroke Sea-Doo PWC forum
    Replies: 1
    Last Post: 09-19-08, 06:12 PM
  2. Wear Ring?
    By Ktmguy23 in forum 2-Stroke Sea-Doo PWC forum
    Replies: 1
    Last Post: 08-25-08, 03:47 PM
  3. 95 GTX wear ring
    By David Washington in forum Non-Seadoo PWC Talk
    Replies: 1
    Last Post: 06-13-08, 12:20 PM
  4. RXP wear ring
    By jet 01 in forum 4-Tec Sea-Doo PWC Forum
    Replies: 4
    Last Post: 04-24-08, 10:40 AM
  5. Wear Ring
    By 92GTX93 in forum 2-Stroke Sea-Doo PWC forum
    Replies: 8
    Last Post: 11-13-07, 02:08 PM

Members who have read this thread : 1

You do not have permission to view the list of names.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Register forum what's new