Results 1 to 7 of 7

Thread: Gauge Problem

  1. #1
    Junior Member
    Join Date
    Jun 2010
    Location
    Maryland
    Posts
    6
    Watercrafts
    yamaha, seadoo, chawk, bayliner
    Thumbs Up
    Received: 0
    Given: 0


    Default Gauge Problem

    I have a 02 GTX 4TEC and the gauge cluster won't work at all. It has power going up to them from the harness but nothing will light up or come across the display. Is there anything else that could cause it not to come on? Fuses are good also. And also, will guages from a newer ski work in mine? Say 04 RXP? Thanks

    0 Not allowed!

  2. # ADS

    Join Date
    Location
    Posts
     

  3. #2
    SeadooForum Pro ski-d00's Avatar
    Join Date
    Apr 2009
    Location
    St. Marys, Ohio
    Posts
    1,333
    Watercrafts
    2008 GTX LTD 2008 RXPX 2006 3D DI 2005 Speedster 200 SC 370HP
    Thumbs Up
    Received: 19
    Given: 0


    Default

    do you get a beep when you install the lanyard? normally, when an LCD gauge display fails, it will beep and give a code on BUDS that says its not communicating with the display.

    RXP has trim so the display is a little different. I know that the 02-05 gtx 4tec lcds will work. the 06 and newer gtxs have a different gauge look but not sure if they will interchange, never tried.

    to remove, carefully pull it straight out, you can check terminal connections for corrosion first.

    0 Not allowed!

  4. #3
    Junior Member
    Join Date
    Jun 2010
    Location
    Maryland
    Posts
    6
    Watercrafts
    yamaha, seadoo, chawk, bayliner
    Thumbs Up
    Received: 0
    Given: 0


    Default

    That is excatly what its doing. It's along beep then 2 right after it real fast. If no connections are bad what about any other fuses? Or you think that maybe its just fried?

    0 Not allowed!

  5. #4
    SeadooForum Pro ski-d00's Avatar
    Join Date
    Apr 2009
    Location
    St. Marys, Ohio
    Posts
    1,333
    Watercrafts
    2008 GTX LTD 2008 RXPX 2006 3D DI 2005 Speedster 200 SC 370HP
    Thumbs Up
    Received: 19
    Given: 0


    Default

    Yep, sounds like a bad lcd gauge, press set 5 times when you hear the long beep and it should give you a p code. You should check the fuses on the MPEM but my guess is they are good. I've replaced quite a few 4tec gauges, especially 02s and 03s. The connection is almost always good and the gauge is just toast, especially if there is moisture in it. I normally swap a gauge from another machine to check, only takes a minute, even faster than checking fuses.

    0 Not allowed!

  6. #5
    Junior Member
    Join Date
    Jun 2010
    Location
    Maryland
    Posts
    6
    Watercrafts
    yamaha, seadoo, chawk, bayliner
    Thumbs Up
    Received: 0
    Given: 0


    Default

    If i press set 5 times how will i read the code if the display don't work? Moisture has got into it in the past i do know. I guess i will probably just have to invest in gauges. They are pricey.

    0 Not allowed!

  7. #6
    SeadooForum Pro ski-d00's Avatar
    Join Date
    Apr 2009
    Location
    St. Marys, Ohio
    Posts
    1,333
    Watercrafts
    2008 GTX LTD 2008 RXPX 2006 3D DI 2005 Speedster 200 SC 370HP
    Thumbs Up
    Received: 19
    Given: 0


    Default

    sorry, good point. I normally just swap gauges or if I have to I'll hook up BUDS. I'm sure you can find somebody with 4tec to swap with, it will take less than 5 minutes.

    When I say moisture, I mean you can see fogging on the inside of the gauge. If yours is that way, most likely it's toast.

    0 Not allowed!

  8. #7
    Junior Member
    Join Date
    Jun 2010
    Location
    Maryland
    Posts
    6
    Watercrafts
    yamaha, seadoo, chawk, bayliner
    Thumbs Up
    Received: 0
    Given: 0


    Default

    I will see if i can find one around here i could swap with. Yea it got real foggy. So more than likely it is gone.

    0 Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fuel gauge problem. Help!!
    By ssrodgers88 in forum 2-Stroke Sea-Doo PWC forum
    Replies: 0
    Last Post: 04-13-10, 08:43 PM
  2. Fuel gauge and speedo gauge problem
    By ronald in forum 2-Stroke Sea-Doo PWC forum
    Replies: 1
    Last Post: 09-10-08, 11:08 AM
  3. 2003 gtx 4tec lcd gauge problem?
    By acooper in forum 2-Stroke Sea-Doo PWC forum
    Replies: 0
    Last Post: 08-30-08, 12:57 PM
  4. 99 GSX Limited Gauge Problem
    By mike3333 in forum 2-Stroke Sea-Doo PWC forum
    Replies: 4
    Last Post: 04-12-08, 11:23 PM
  5. gauge problem
    By Jared in forum 2-Stroke SeaDoo Sport Boat Forum
    Replies: 4
    Last Post: 04-09-08, 08:37 PM

Members who have read this thread : 6

You do not have permission to view the list of names.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Register forum what's new