2003 Seadoo Challenger 240 Merc drive won't rev - Seadoo Forums

Visit PWCMuscle.com
for 15% off all Hydro Turf - CODE: HYDRO15
Need OEM parts for your boat or PWC? Visit SeadooWarehouse.com
Results 1 to 5 of 5
  1. ☑ ORIGINAL POSTER #1
    Junior Member
    Join Date
    Jun 2010
    Location
    Bahamas
    Posts
    3
    Watercrafts
    Seadoo Challenger c/w Mercury 240 jet drive.
    Thumbs Up
    Received: 0 Given: 0


    Default 2003 Seadoo Challenger 240 Merc drive won't rev

    I've just inherited an early 2003 Seadoo Challenger with the Mercury 240 EFI jet drive. It drove the previous owner nuts.

    The problem is that it starts and idles, but giving it any more than a bit of throttle kills the engine. The ECM has supposedly been repaired numerous times and the mechanic who does not want to work on it any longer says it still needs an ECM.

    I've just had a look at the engine compartment and have noticed two wires have been cut near from one of the terminal connectors. The connector is near the ECM but does I can't tell where the other end of wires would go.

    Are these machines known for ECM problems? Any ideas as to what is really wrong with this boat?

    Big thanks,
    bluewaterboy

    0 Not allowed!

  2. # ADS
     

  3. #2
    LouDoo's Avatar
    Join Date
    May 2010
    Location
    Lexington, KY
    Posts
    12,673
    Watercrafts
    SeaDoo's: 96 GTI 720, 95 XP 800 Limited, 96 GSX 787. 2000, 18' Bayliner 3.0L.
    Thumbs Up
    Received: 341 Given: 40


    Default Fuel, Fuel Lines

    Hi,

    Have you checked your fuel, filters, etc.?

    You might want to move this to the boat forum, you'll probably get more help.

    Lou

    0 Not allowed!

  4. ☑ ORIGINAL POSTER #3
    Junior Member
    Join Date
    Jun 2010
    Location
    Bahamas
    Posts
    3
    Watercrafts
    Seadoo Challenger c/w Mercury 240 jet drive.
    Thumbs Up
    Received: 0 Given: 0


    Default

    Yes, the fuel and filters have both been changed (more than once actually).

    I'll take your advice and repost to the boat forum.

    Thanks,

    0 Not allowed!

  5. #4
    Dr Honda's Avatar
    Join Date
    Apr 2009
    Location
    Pittsburgh
    Posts
    18,030
    Watercrafts
    '00 Polaris Genesis '96 XP800 '02 Islandia 240 EFI
    Thumbs Up
    Received: 320 Given: 0


    Default

    I don't have a lot of experience with the Merc drives... but no... they are not known to have ECM issues. If they did, we would see it more often here.

    I would figure out where those wires go.

    Most of the time, we see bad fuel pumps, or plugged filters.

    Just a thought from an experienced mechanic... if the ECM, or other electronic module was bad... the engine wouldn't run.

    I would start with putting a fuel pressure gauge on the fitting near the regulator, and verify that you have good pressure while running. (I've seen a couple regulators go bad)

    Last thing. If you join this forum (become a premium member) you can download the Merc engine manual.
    Tony

    PM or post for help. Don't leave questions in my profile box. (i never check it)

    I'm not going to be able to do vinyl or carbs for a while. Starting my new job is taking a lot of time

    0 Not allowed!

  6. #5
    Junior Member
    Join Date
    Jun 2010
    Location
    Ohio
    Posts
    5
    Watercrafts
    Sea-Doo X20
    Thumbs Up
    Received: 0 Given: 0


    Default Same exact problem with 02 X20...

    I'd start it in neutral and shift it into reverse to back away from the trailer. When I shifted it and gave it any throttle, it cuts out. Tried that 6 or seven times before pulling it back out of the water.

    There shouldn't be much old gas in the tank from winterization. I've topped off the tank twice this year with about 15 gallons each time. The last time out, when the battery crapped out, it did seem to sound "bogged down" when throttling up.

    Suggestions? Fuel filter? Fuel pump? Something else?

    0 Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. how to change F N D drive cable seadoo challenger
    By seadoogti in forum 2-Stroke SeaDoo Sport Boat Forum
    Replies: 8
    Last Post: 07-18-11, 01:21 PM
  2. 2003 speedster 240 hp merc shift cable ?
    By snoozeyalooze in forum Mercury Powered SeaDoo Sport Boats
    Replies: 1
    Last Post: 08-06-09, 02:38 PM
  3. 2003 sportster LE drive shaft will not turn
    By romun629 in forum 2-Stroke SeaDoo Sport Boat Forum
    Replies: 2
    Last Post: 06-07-09, 02:08 PM
  4. 2003 Islandia w/250 Merc opti Questions please
    By froggie76 in forum Mercury Powered SeaDoo Sport Boats
    Replies: 5
    Last Post: 09-08-08, 06:40 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Register forum what's new