no propulsion (have pictures) - Seadoo Forums
Need OEM parts for your boat or PWC? Visit SeadooWarehouse.com
Results 1 to 9 of 9
  1. ☑ ORIGINAL POSTER #1
    Junior Member
    Join Date
    May 2008
    Location
    fernandina beach fl.
    Posts
    4
    Watercrafts
    2 98 gts
    Thumbs Up
    Received: 0 Given: 0

    Default no propulsion (have pictures)

    Hi my names Aaron, I've been reading alot of these forums and i guess this is a normal problem however mine may have a little twist. I have had two 98 gts's for about a year one of them has always been hard to get on plane. I found that the only way I could get it to plane was to put it into a hard right turn from the start and do atleast a 90 degree turn steadly giving some gas and then i'm off other wiseit will go no where. Now after reading alot of the forums I thought for sure when I took off the impeller housing that I would find a bad wear ring, but it seems to be fairly new, however I have noticed some other things. As you can see in the picture with what I think is called the shoe. In the upper part of the ring the metal is worn down what i would think would be a considerable amount. The only thing that I could think that would wear that down was the impellor itself. The impellor moves forward and backward quite a bit. Also where the impellor housing meets the boot there was like half sealent on the bottom and none on the top. I've also noticed that i think what is called the stator vaines is missing chunks out of it. Thats about all I know at this point. Hopefully you guys will have some suggestions about this one.
    Attached Images Attached Images
    Last edited by firestorm41; 05-05-08 at 08:33 PM.

    0 Not allowed!

  2. # ADS
     

  3. ☑ ORIGINAL POSTER #2
    Junior Member
    Join Date
    May 2008
    Location
    fernandina beach fl.
    Posts
    4
    Watercrafts
    2 98 gts
    Thumbs Up
    Received: 0 Given: 0

    Default hmmm

    can't figure ot how to do more than one pic. guess they are all too big what would be a good size so you can see them clearly? heres a few anyways
    Attached Images Attached Images
    Last edited by firestorm41; 05-05-08 at 08:39 PM.

    0 Not allowed!

  4. #3
    Junior Member
    Join Date
    Mar 2008
    Location
    Gainesville Florida
    Posts
    10
    Watercrafts
    1997 Seadoo XP
    Thumbs Up
    Received: 0 Given: 0

    Default i feel your pain

    Hey man i just had a similar problem but mine turned out to be the wear ring......sucked up a rock and it did a nice bit of damage to the wear ring.....surprisingly left the impeller unscathed.......really fluke incident i guess......anyway i would try chaning the oil in the nose cone and making sure it is sealed properly......read in my manual that if the cone isn't holding pressure it can be an issue.......thats all i got for ya...btw if it makes you feel better......changing a wear ring is a big pain in the a** while chanign the oil in that cone is pretty simple .....so if thats your problem you will miss out on all the cuss words lol

    0 Not allowed!

  5. #4
    Senior Member sanpan25's Avatar
    Join Date
    Apr 2008
    Location
    Lees Summit Mo / Lake of the Ozarks 11.5MM
    Posts
    106
    Watercrafts
    25 ft sanpan 225 honda 1996 seadoo gti 2007 seadoo gti se 155 hp
    Thumbs Up
    Received: 2 Given: 4

    Default

    Are the splines inside the impeller deep enough and engauge the drive shaft well? Could you be slipping there? How much clearance between the impeller and the wearring? The movement is front to back not side to side? How much play is there?
    Lake of the Ozarks more than a place.....It is a state of Mind!

    0 Not allowed!

  6. ☑ ORIGINAL POSTER #5
    Junior Member
    Join Date
    May 2008
    Location
    fernandina beach fl.
    Posts
    4
    Watercrafts
    2 98 gts
    Thumbs Up
    Received: 0 Given: 0

    Default

    hey yesh theres alot og play forward and backward not side to side and I haven't officially messured the gap between the impeller and the wear ring but it's looks lke just enough to fit a piece of paper between them. Slight exageration but thats hoe tight it looks. not sure about the splines i will have to check that. thanks to both of you and i will get back to you on that

    0 Not allowed!

  7. #6
    kustomkarl's Avatar
    Join Date
    Sep 2007
    Location
    Sunny S.W. coast of Englewood, Florida
    Posts
    11,229
    Watercrafts
    1996 Chris Craft 26' Cruiser, Kawasaki 440 Superstock, 550 Mod., 2008 200Speedster 310 Hp
    Thumbs Up
    Received: 15 Given: 0

    Default

    The clearence between the impeller and wear ring is .040". The impeller shaft shouldn't have any play forward and back on the shaft.

    Karl
    Please, If you have a "troubleshooting" request, use the correct category in the Sea-Doo Forum first.

    "Premium / Subscribed Members", not getting an answer, pm me directly for Expert Advise.



    When your ready for more performance, click on the this link!

    Click to order your Sea-Doo Parts at a fair price.

    Click here to view/join our Group on "Face Book"

    0 Not allowed!

  8. ☑ ORIGINAL POSTER #7
    Junior Member
    Join Date
    May 2008
    Location
    fernandina beach fl.
    Posts
    4
    Watercrafts
    2 98 gts
    Thumbs Up
    Received: 0 Given: 0

    Default

    it just seems that if your holding the impeller housing in your hands ( not attatched to the drive shaft) I can slide the impeller forward and back about a half an inch. now i did take the nose cone off and there was alot of water in there as well as the worst burn smell i have ever smelt. Stunk up the whole shop. Possibly the problem? I was thinking that the play back and fourth is what is gouging the metal on the foot. What do you think? The grooves on the spline looks good.

    0 Not allowed!

  9. #8
    kustomkarl's Avatar
    Join Date
    Sep 2007
    Location
    Sunny S.W. coast of Englewood, Florida
    Posts
    11,229
    Watercrafts
    1996 Chris Craft 26' Cruiser, Kawasaki 440 Superstock, 550 Mod., 2008 200Speedster 310 Hp
    Thumbs Up
    Received: 15 Given: 0

    Default

    The smell is common. I'll check the statis as to what the exact play should be. Here are the full directions to change the pump oil.
    _______________________
    The pump oil change

    if you look into the nozzle in the rear of the ski you will see a cone with 3 screws and an oil filler allen screw.

    To change it.
    1) take off 4 13 MMM bolts holding nozzle and 10 MM bolt holding steering.

    2) get something to catch the old oil in, drain pan margarine cup etc.... (don’t forget the nose plugs, the oil stinks to high heaven)

    3) remove the 3 8 mm bolts holding the cone on.

    4) pull the cone and drain the oil out. prop the front of the trailer up as high as you can to get most of it out.

    5) Inspect the rubber o ring and if it is good apply silicon and reinstall the cone. Make sure the allen fill plug is on top.

    6) lower the front of the ski and add oil to the cone. when it is full, take a brake and have a drink. There is air in the cone and when you go back you will see that it is low. top it off and take another brake... do this until the fluid does not lower again. I often start the ski for a few seconds to make sure oil is all the way worked into the bearings and all the air is out.

    7) wipe silicon on the set screw and screw it in (be sure not to run it all the way into the cone. just deeper than flush is fine. let it sit 24 hours to cure the silicon and put the nozzle back on.

    8) Use Sea Doo 75w90 GL5 Synthetic Polyolester Oil

    0 Not allowed!

  10. #9
    kustomkarl's Avatar
    Join Date
    Sep 2007
    Location
    Sunny S.W. coast of Englewood, Florida
    Posts
    11,229
    Watercrafts
    1996 Chris Craft 26' Cruiser, Kawasaki 440 Superstock, 550 Mod., 2008 200Speedster 310 Hp
    Thumbs Up
    Received: 15 Given: 0

    Default

    Aaron, here is someething that might be causing your problem;

    End Play of impeller shaft ( 98 GTS)
    End play of the impeller shaft is checked with the shaft in housing, without impeller and cover installed. Retain housing in a soft jaw vise making sure not to damage the housing lug. Set a dial gauge and position its tip on the end of the shaft. Check the play by pushing and pulling. The maximum permissible end play is (new) 0.12-0.54 mm (.005-.021 in.) Excessive play comes from a worn anti-knock pusher inside cover and wear of the impeller shaft nose. The wear limit of the pusher is the measurement of the outside end of the pusher to the bottom of the shaft.( not to the opposite end) The wear limit is 8.0mm (.315in).

    I hope you understand this and you can check the end play.

    Karl

    0 Not allowed!

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. Found some primer installation pictures.
    By scooper77515 in forum 2-Stroke Sea-Doo PWC forum
    Replies: 6
    Last Post: 04-12-08, 06:15 PM
  2. '99 Speedster SK pictures
    By jhood in forum 2-Stroke SeaDoo Sport Boat Forum
    Replies: 6
    Last Post: 02-26-08, 10:15 AM
  3. Everyone please chime in on these exhaust pictures...
    By scarfie in forum 2-Stroke SeaDoo Sport Boat Forum
    Replies: 44
    Last Post: 11-06-07, 12:18 PM
  4. 96 Gsx Trouble With Propulsion
    By ochuck88 in forum 2-Stroke Sea-Doo PWC forum
    Replies: 2
    Last Post: 07-31-07, 03:32 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Register forum what's new