Mercury sport jet engine vs mercury outboard engine - Seadoo Forums

Visit PWCMuscle.com
for 15% off all Hydro Turf - CODE: HYDRO15
Need OEM parts for your boat or PWC? Visit SeadooWarehouse.com
Results 1 to 14 of 14
  1. ☑ ORIGINAL POSTER #1
    Member
    Join Date
    Sep 2009
    Location
    New Jersey
    Posts
    53
    Watercrafts
    2001 Sea Doo Utopia 185
    Thumbs Up
    Received: 0 Given: 0


    Default Mercury sport jet engine vs mercury outboard engine

    Hello I recently had my 2001 Utopia(210 Merc)out in the bay and it started beeping. *I bought the boat at the end of last season and I have had it out about three times previously.* *So I was towed back to the dock and took it to the local Seadoo dealer.* When I purchased the boat I was told it had a 'new' engine in it which by all appearances it did.* When I talked to the mechanic at the Seadoo dealer they found it was an 'oil sensor' causing the beeping but the strange thing is this particular sensor is not present on the Merc Sport Jet engine, it is only present on the Merc Outboard engine.* Upon further inspection all of the electronics are 'outboard' electronics as opposed to 'sport jet' electronics and the VIN on the block traces back to a 1992 outboard.* Should I be 'bitchin' to the guy who sold it to me who replaced the engine?* What possible issues can arise from having an 'outboard' engine/electronics vs the 'sport jet' engine/electronics?* Is there that much of a difference? *Can you advertise a boat as having a 'new motor' if the block is from a 1992 outboard? *I have a call scheduled tonight with the guy who sold it to me and I am not sure how to approach it.* There is no way I would ever have been able to tell this was not the same 'type' of engine that was originally in the boat.*** Is the 'Seadoo' mechanic possibly just trying to rake me over the coals and make a bigger deal of this than it is?* Are there sensors on the 'outboard' engine that are not on the 'sport jet' engine? *Sorry for all the questions, I donít know who to trust.* Thanks
    *

    0 Not allowed!

  2. # ADS
     

  3. ☑ ORIGINAL POSTER #2
    Member
    Join Date
    Sep 2009
    Location
    New Jersey
    Posts
    53
    Watercrafts
    2001 Sea Doo Utopia 185
    Thumbs Up
    Received: 0 Given: 0


    Default

    Bump...maybe I asked too many questions in my first post. Lol. My main question is.

    1. Is there a major difference between a mercury sport jet engine and a mercury outboard engine?

    2. I am being told by a seadoo dealer that my boat has a mercury outboard motor with a bad oil sensor but this sensor is not even on the sport jet engine. Does this make sense?

    3. Should I be worried about any issues since the sport jet engine was replaced with an outboard?

    Thanks.

    0 Not allowed!

  4. #3
    Experienced Rider
    Join Date
    Apr 2010
    Location
    Spokane
    Posts
    461
    Watercrafts
    97GSX/Rotax 787, 96XP/Rotax 787, sold: 2001 C2K/Mercury 240EFI, now: Tige 24Ve/PCM 5.7L V8
    Thumbs Up
    Received: 6 Given: 0


    Default

    Quote Originally Posted by PerkDoo View Post
    1. Is there a major difference between a mercury sport jet engine and a mercury outboard engine?
    No "major" differences. The bottom of the engine connects to a adaptor plate that interfaces it to the jetdrive instead of an outboard's lower end transmission. There may be some very slight differences in ECU programming. I've heard rumors that the SportJet uses different reeds than the outboard. But the engine as a whole is a Mercury 2.5L V6 powerhead. Parts are interchangable, tools are the same, etc.

    Suggestion: Call Mercury directly and ask them. They're obviously the experts. 920-929-5040. They've always been very helpful and responsive to me.

    2. I am being told by a seadoo dealer that my boat has a mercury outboard motor with a bad oil sensor but this sensor is not even on the sport jet engine. Does this make sense?
    So what sensor is it? The SportJet has a sensor in the on-engine oil tank. What other sensor is he talking about? Part number would be nice, for example.

    What is your engine serial number? Don't take the tech's word for it. Read it yourself right off the engine. It should be OE######.

    3. Should I be worried about any issues since the sport jet engine was replaced with an outboard?
    Not necessarily, since they are indeed the same engine.

    Get your engine serial number (not the jetdrive's, but the ENGINE) and post that here. Then call Mercury at the number above and ask them what that serial number applies to - an engine that was originally a SportJet (what year?), originally an outboard (what year?), etc. Tell them your technician is giving you conflicting data and you want to know exactly what you have.

    Report back!

    0 Not allowed!

  5. ☑ ORIGINAL POSTER #4
    Member
    Join Date
    Sep 2009
    Location
    New Jersey
    Posts
    53
    Watercrafts
    2001 Sea Doo Utopia 185
    Thumbs Up
    Received: 0 Given: 0


    Default

    Thanks for the great info WA. I called the seadoo shop back and got the sensor part number. 41470A26 I then called mercury and spoke with Travis who was very helpful. He did confirm that this particular sensor was not on the 210 sport jet engine but is on the 210 outboard. So I do feel better that the mechanic is actually correct and seems to know what they are talking about. They are a seadoo dealer but have a mercury mechanic in their shop.

    I also confirmed with Travis that there really are no major differences in the power head between the two motors so they are pretty much interchangeable.

    Once I get the boat back I will verify the engine number and it's origin but based on my convo with the mechanic today I feel alot more confident that they are being truthful and actually know what they are talking about.

    They are also installing a high performance solas impellor for me so I will let you all know how that works and how it performs on the 210hp merc powered utopia.

    Thanks again for your reply WA.

    0 Not allowed!

  6. #5
    Experienced Rider
    Join Date
    Apr 2010
    Location
    Spokane
    Posts
    461
    Watercrafts
    97GSX/Rotax 787, 96XP/Rotax 787, sold: 2001 C2K/Mercury 240EFI, now: Tige 24Ve/PCM 5.7L V8
    Thumbs Up
    Received: 6 Given: 0


    Default

    OK, I looked up that part number. It appears to be a potted module (like the RPM limiter, throttle guardian, etc.) that is used with a sensor in the external oil tank. SportJets don't have a sensor on that tank - they only use the sensor in the on-engine tank. No idea why.

    Again, this further confirms that there is little to no difference between the ENGINES. This "difference" is on a completely separate component. I bet you could buy this sensor+module and plug it right into a SportJet ECU if you wanted. Not sure why Mercury treats the two applications for the same engine(s) differently.

    Frankly, if you test the sensor in your on-engine tank and confirm it is working, I'm not sure I'd spend the money to replace this ~$250 (!!!) external module. No other SportJet application has one.
    Last edited by WAJetboating; 06-03-10 at 02:39 PM.

    0 Not allowed!

  7. ☑ ORIGINAL POSTER #6
    Member
    Join Date
    Sep 2009
    Location
    New Jersey
    Posts
    53
    Watercrafts
    2001 Sea Doo Utopia 185
    Thumbs Up
    Received: 0 Given: 0


    Default

    Hey WA. Yes both Travis and the seadoo mechanic confirmed it is a low oil sensor in the external tank. And what makes me mad is I had more oil but I was letting the oil in the tank run down before 'mixing in' the new oil. I think if I had just added the oil when I bought it I probably would not have tripped this sensor.

    I would like to just remove this sensor since no other jet boats use it. That was not really presented as an option by my seadoo mechanic.

    I did ask Travis the msrp and he quoted $260 but my seadoo guy is only charging me $225 so I guess that is a little bonus. Lol. Unless of course he is just going to hide the extra cost into the labor charges.

    At this point I just want my boat back in working order...

    0 Not allowed!

  8. #7
    Experienced Rider
    Join Date
    Apr 2010
    Location
    Spokane
    Posts
    461
    Watercrafts
    97GSX/Rotax 787, 96XP/Rotax 787, sold: 2001 C2K/Mercury 240EFI, now: Tige 24Ve/PCM 5.7L V8
    Thumbs Up
    Received: 6 Given: 0


    Default

    I think your boat IS in working order. You just have an unnecessary sensor.

    Most of those modules ground their outputs when going "active". I'd put a voltmeter on its output lead and see which way the signal goes when it's "active". If it's near ground, just connect the lead to ground and be done with it.

    You might get lucky and find that disconnecting the module resolves the problem. If it's a "ground when active" system that's likely to be the case. Talk about a cheap fix to a non-problem!

    0 Not allowed!

  9. #8
    Experienced Rider
    Join Date
    Apr 2010
    Location
    Spokane
    Posts
    461
    Watercrafts
    97GSX/Rotax 787, 96XP/Rotax 787, sold: 2001 C2K/Mercury 240EFI, now: Tige 24Ve/PCM 5.7L V8
    Thumbs Up
    Received: 6 Given: 0


    Default Wait a minute...

    Are you saying you intentionally let the external tank's oil go low?

    Is THAT why the sensor is triggering?

    Are you CERTAIN the sensor+module is bad? Or do you just need to fill the external tank?!?

    I realize that by removing the sensor connection you can probably resolve the whole thing, but at this point I'm wondering if anything was ever broken at all.

    0 Not allowed!

  10. ☑ ORIGINAL POSTER #9
    Member
    Join Date
    Sep 2009
    Location
    New Jersey
    Posts
    53
    Watercrafts
    2001 Sea Doo Utopia 185
    Thumbs Up
    Received: 0 Given: 0


    Default

    Well I will say I was probably misinformed to let the old oil run down before adding new. I realize now it was not the smartest thing to do. I did actually have the oil in the boat with me when the sensor went off and something told me that might be it so I did add two gallons to my external tank but this did not stop the beeping. I guess once the sensor tripped it couldn't reset itself??

    I took wood shop when everyone else was taking auto shop so my mechanical abilities are pretty weak!! Lol. But I can make an awesome shelf. Lol

    0 Not allowed!

  11. #10
    Experienced Rider
    Join Date
    Apr 2010
    Location
    Spokane
    Posts
    461
    Watercrafts
    97GSX/Rotax 787, 96XP/Rotax 787, sold: 2001 C2K/Mercury 240EFI, now: Tige 24Ve/PCM 5.7L V8
    Thumbs Up
    Received: 6 Given: 0


    Default

    Quote Originally Posted by PerkDoo View Post
    Well I will say I was probably misinformed to let the old oil run down before adding new. I realize now it was not the smartest thing to do.
    Actually, that is precisely the recommended way to change lubricants. The rule of thumb is never to mix different lubricants. Since completely draining an oil injection system is often impractical, the way to do it is to let the existing oil be consumed while watching carefully so it doesn't actually run out. Then you fill the reservoir completely with the new lubricant, the idea being to minimize mixing as much as possible.

    So No, you didn't do anything wrong.

    I did add two gallons to my external tank but this did not stop the beeping. I guess once the sensor tripped it couldn't reset itself??
    No, they aren't designed like that. I don't mean to question your mechanic, but my first guess would be that the SENSOR in the tank failed, not the electronics module. Hopefully he tested and confirmed which one is bad. Either way, I'd simply defeat the extra sensor and forget about it.

    0 Not allowed!

  12. ☑ ORIGINAL POSTER #11
    Member
    Join Date
    Sep 2009
    Location
    New Jersey
    Posts
    53
    Watercrafts
    2001 Sea Doo Utopia 185
    Thumbs Up
    Received: 0 Given: 0


    Default

    Hey WA. Thanks so much for all of your input. I really really appreciate it and I feel alot better about the situation. I have a buddy who is very mechanically inclined so I will engage his help in trying to disarm this sensor. The worst part is it ruined a beautiful day on the water. Thanks so much again for all your help!!! Hopefully one day I can return the favor.

    0 Not allowed!

  13. ☑ ORIGINAL POSTER #12
    Member
    Join Date
    Sep 2009
    Location
    New Jersey
    Posts
    53
    Watercrafts
    2001 Sea Doo Utopia 185
    Thumbs Up
    Received: 0 Given: 0


    Default

    BTW. my wife went to high school in Redmond and college at WSU and if she had her way we would be in the great north west with you!!! Lol

    0 Not allowed!

  14. #13
    Experienced Rider
    Join Date
    Apr 2010
    Location
    Spokane
    Posts
    461
    Watercrafts
    97GSX/Rotax 787, 96XP/Rotax 787, sold: 2001 C2K/Mercury 240EFI, now: Tige 24Ve/PCM 5.7L V8
    Thumbs Up
    Received: 6 Given: 0


    Default

    Checking the schematic, I see that the on-engine oil tank's sensor has a signal lead and a ground lead. I'll bet the external tank's module connects to the same wire, such that a ground from either tank's sensor/module causes the beep. If so, all you need to do is disconnect the external tank's module.

    There are likely five wires: Two going to the tank sensor, a power wire (probably purple) to power the module, a ground wire (probably black) for ground reference, and the output signal wire (which could be almost any color). Probably all wires connect via bullet connectors that come apart with a firm pull.

    If it's beeping now, disconnecting the module will tell you if you can passively take it out of the system. Disconnecting it won't do any harm because it's just a warning - the engine continues to get fuel and oil no matter what the sensor says.

    Separate the two groups of wires - the two going to the actual sensor, and the three going to the wiring harness. Within the harness group, if there's one that isn't solid black or solid purple, it's almost certainly the output signal. Disconnect that one and see if the beeping stops.

    In reality, I'd probably just disconnect all wires, tape or shrink wrap the exposed connectors, and leave it. If you're not paying attention to the module there's no reason to supply power to it.

    Report back!

    0 Not allowed!

  15. #14
    Senior Member hypersniper2010's Avatar
    Join Date
    Jul 2010
    Location
    mass
    Posts
    185
    Watercrafts
    (1)-1995 seadoo xp 720 (2)- 1996 seadoo xps (1)- 1997 seadoo gsx (1)-1994 suagr sands mirage jet
    Thumbs Up
    Received: 1 Given: 2


    Default

    i know this is a real old thread but it kinda answers my question but leaves me still asking another about it. i have a 94 mercury sportjet 90 hp. is the regular mercury 90 hp outboard the same thing with just an adaptor plate for the jet pump? my sportjet has a bad piston and i cant read the serial number on the tag at all. are the pistons the same for a 94 sportjet 90hp as a 94hp outboard? and lastly sorry for hijackin a thread.
    thanks

    0 Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Mercury 240 EFI engine shuts off at high speed - HELP
    By kapeed in forum Mercury Powered SeaDoo Sport Boats
    Replies: 24
    Last Post: 02-04-11, 06:34 PM
  2. 240 EFI Mercury engine keeps cutting out and hard to start
    By Leo in forum Mercury Powered SeaDoo Sport Boats
    Replies: 9
    Last Post: 07-21-10, 10:39 PM
  3. mercury 240 efi engine cleaner?
    By surferdavet in forum Mercury Powered SeaDoo Sport Boats
    Replies: 5
    Last Post: 03-26-10, 02:03 AM
  4. engine temp sensor for mercury 240 efi
    By Leo in forum Mercury Powered SeaDoo Sport Boats
    Replies: 1
    Last Post: 07-02-09, 12:59 AM
  5. Used Speedster--bad to buy with Mercury M-2 engine?? Help?
    By tomjonesrocks in forum Mercury Powered SeaDoo Sport Boats
    Replies: 9
    Last Post: 06-21-09, 02:28 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Register forum what's new