No acceleration-2000 Islandia with Mercury 240 - Seadoo Forums

Visit PWCMuscle.com
for 15% off all Hydro Turf - CODE: HYDRO15
Need OEM parts for your boat or PWC? Visit SeadooWarehouse.com
Results 1 to 3 of 3
  1. ☑ ORIGINAL POSTER #1
    Junior Member
    Join Date
    Mar 2010
    Location
    Baytown
    Posts
    16
    Watercrafts
    1999 Seadoo GSX Limited
    Thumbs Up
    Received: 1 Given: 0


    Thumbs down No acceleration-2000 Islandia with Mercury 240

    I have a 2000 Islandia with a Mercury 240 jet drive I purchased a few months ago. It has been running fine until the last time I took it out. It started fine at the ramp, but as I left the ramp and went to full throttle, it wouldn't turn more than 3500 rpm, wouldn't get on a plane, and wouldn't go more than around 10mph. The fuel filter, water seperator, and spark plugs appeared to be original, so I replaced them. It has made no difference at all. It still will not accelerate and get on a plane. Any ideas? Thanks!

    0 Not allowed!

  2. # ADS
     

  3. #2
    Dr Honda's Avatar
    Join Date
    Apr 2009
    Location
    Pittsburgh
    Posts
    18,085
    Watercrafts
    '00 Polaris Genesis '96 XP800 '02 Islandia 240 EFI
    Thumbs Up
    Received: 328 Given: 0


    Default

    I'm not real good with the Merc drives... but if it won't go past 3500 rpm...


    Does it sound like it's bouncing off the rev limiter? The neutral safety switch may be messed up. But as I recall... it has a single control/throttle lever, so I'm not sure where the switch is... but it should be in the control housing.

    Is your boat injected or does it have carbs?
    Tony

    PM or post for help. Don't leave questions in my profile box. (i never check it)

    I'm not going to be able to do vinyl or carbs for a while. Starting my new job is taking a lot of time

    0 Not allowed!

  4. ☑ ORIGINAL POSTER #3
    Junior Member
    Join Date
    Mar 2010
    Location
    Baytown
    Posts
    16
    Watercrafts
    1999 Seadoo GSX Limited
    Thumbs Up
    Received: 1 Given: 0


    Default

    It is fuel injected, and the shifter and throttle controls are seperate from each other. The way it is now, the more throttle I give it, the more it sounds like it's bogging down. It doesn't sound like it's hitting a rev limiter. Thanks for the reply.

    0 Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 SeaDoo 2000 Challenger 240hp Mercury
    By millerwarren in forum Mercury Powered SeaDoo Sport Boats
    Replies: 4
    Last Post: 08-12-09, 06:52 PM
  2. Challenger 2000 Mercury 240 won't start sometimes
    By voomvoom in forum Mercury Powered SeaDoo Sport Boats
    Replies: 6
    Last Post: 03-09-09, 02:33 PM
  3. 2000 GS acceleration issue
    By skatensx in forum 2-Stroke Sea-Doo PWC forum
    Replies: 1
    Last Post: 10-26-08, 07:33 PM
  4. 2000 Challenger Mercury hot start problem
    By hoppe in forum Mercury Powered SeaDoo Sport Boats
    Replies: 1
    Last Post: 07-10-08, 03:46 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Register forum what's new