Results 1 to 19 of 19
  1. #1
    Member
    Join Date
    Feb 2008
    Location
    Houston
    Posts
    44
    Thumbs Up
    Received: 0 Given: 0


    Default 2003 XP "DI"e-dead Mpem, NOW bad knock sensor; Are DI's even worth owning!?

    I'm going to keep this short & sweet because I can hardly stomach it anymore...

    I bought a 2003 XPdi with 20hrs on it. The problem is that the ski was coming in and out of limp mode. One day it I rode it around for 15min's and it wouldn't go over (45mph) est 5,000rpm... then it ran 100% for 1hr but acted up around the time I was ready to pull it out of the water. *** It's been to the lake 4 times. 3 times I've taken it to the lake... I’ve been stuck onshore.

    -The rear cylinder was shutting off intermittently. My SDoo tech said that the mpem was the cause so I purchased a used one. That seemed to fix that problem... no more limp mode.
    >>WRONG>> I got out to the lake and no sooner made it out of the NoWake zone and BEEEEEEEEEEEP, "Maint/limp mode".

    -Now the "knock" sensor (aka: noise sensor) that is located on the top of the cylinder head was throwing a code. A stinking $45 dollar sensor... so, I've ordered a new one. WHATS NEXT!?

    QUESTION: This DI has approx 13 sensors and in the very short time that I've owned it I've dumped about a GRAND on fixing it. I like to venture out miles away from the boat dock to 'get away' from the world... but I'm not sure if this ski is trustworthy enough> or ever will be?

    Are these DI's worth owning!? I have NEVER had so many problems with skis... and I sank my 96 xp two times only to have it running again in a few hrs!


    0 Not allowed!

  2. # ADS
     

  3. #2
    kustomkarl's Avatar
    Join Date
    Sep 2007
    Location
    Sunny S.W. coast of Englewood, Florida
    Posts
    11,229
    Watercrafts
    1996 Chris Craft 26' Cruiser, Kawasaki 440 Superstock, 550 Mod., 2008 200Speedster 310 Hp
    Thumbs Up
    Received: 7 Given: 0


    Default

    I'm sorry your thread went unanswered for so long. I haven't heard anybody have such problems as you have had. I would bring it to a different dealer next time it needs anything to have it looked by someone else. That XPDI is suppose to be a great machine.

    Karl
    Please, If you have a "troubleshooting" request, use the correct category in the Sea-Doo Forum first.

    "Premium / Subscribed Members", not getting an answer, pm me directly for Expert Advise.



    When your ready for more performance, click on the this link!

    Click to order your Sea-Doo Parts at a fair price.

    Click here to view/join our Group on "Face Book"

    0 Not allowed!

  4. #3
    Senior Member
    Join Date
    Feb 2008
    Location
    Cairns AUSTRALIA
    Posts
    142
    Watercrafts
    2000 gtx di injected
    Thumbs Up
    Received: 0 Given: 0


    Default Knock sensor? Or something more?

    Do you know why the knock sensor was throwing a code? Is it trying to tell you something? Or is it a faulty sensor? I guess you'll find out when you put in the new one.. I feel your pain... my ski stuffed me around thousands of $$$$ @ mechanics and 6 months of pain... with little pleasure in between.. in the end it was a dirty RAVE hose...just blowing the dirt out of the hose .. costing nothing.... and away it went. Don't give up on it.

    0 Not allowed!

  5. #4
    Member
    Join Date
    Feb 2008
    Location
    Houston
    Posts
    44
    Thumbs Up
    Received: 0 Given: 0


    Default "DI"- Air Injector problem / solution: Has your Di Di-ED yet?

    Well, another $200 bucks down the drain on diagnosing wtf is wrong.

    The intermittent issue with the rear cyclinder shutting down is due to the rear air injector failing after the ski has been running and warms up...and the sensor fails throwing the ski into MAINT/LIMP mode. Then once it cools off there is no code for the mechanics to diagnois.

    Di's are notorious for air injectors, fuel injectors, MPEM's, and fuel filters going out.

    I'm sure everyone reading this already knew that but for the people (like me) who stumble into buying one of these DI money pits... just know that before / after you buy it. I'm $1,485 in the hole in 8 weeks- and have yet to ride it.

    0 Not allowed!

  6. #5
    SeadooForum Pro
    Join Date
    Dec 2007
    Location
    florida
    Posts
    1,505
    Watercrafts
    restored 1995 seadoo sportster
    Thumbs Up
    Received: 0 Given: 0


    Default

    I am sory about your problem I have allso read alot of bad just as you described. I will use your info to try and help others. what I have read it seems to be a compressor problem most of the time.

    0 Not allowed!

  7. #6
    Senior Member sanpan25's Avatar
    Join Date
    Apr 2008
    Location
    Blue Springs Mo / Lake of the Ozarks 11.5MM
    Posts
    105
    Watercrafts
    25 ft sanpan 225 honda 1996 seadoo gti 1996 challenger seadoo boat 2007 seadoo gti se 155 hp
    Thumbs Up
    Received: 2 Given: 0


    Default

    Texas T:

    Where I am at we have marinas that sell and service seadoos. They lake test and stand behind what they do. I had an issue with a GTX I owned and it took a couple trips on the trailer back to them but they made it right, N/C. I was pleased with the final results. Hang in there and let them have it till it is right and explain you dont want to pay for their learning curve.

    Good Luck
    Lake of the Ozarks more than a place.....It is a state of Mind!

    0 Not allowed!

  8. #7
    Senior Member
    Join Date
    Feb 2008
    Location
    Cairns AUSTRALIA
    Posts
    142
    Watercrafts
    2000 gtx di injected
    Thumbs Up
    Received: 0 Given: 0


    Default Found your problem?

    Hi TOBY .. in your last post you said your air injector rail is failing so does this mean you've found your problem now? I mean... will changing the rear air injector fix it?

    0 Not allowed!

  9. #8
    Member
    Join Date
    Feb 2008
    Location
    Houston
    Posts
    44
    Thumbs Up
    Received: 0 Given: 0


    Default

    The mechanic told me that it was the rear air injector located "under the fuel rail". My understanding is that you have (2) fuel injectors on the top of the rail and (2) air injectors below the rail >> that also go into the cylinder heads.

    Since the ski wasn't showing a code when I brought the ski back to the mechanic he called in the big gun (a guy with extensive electric troubleshooting experience). He scoped the ski and ran it until the rear cylinder shut down... and found that it was def. the rear air injector sticking open.

    Is it ONLY the air injector?! That's the 64,000 dollar question... a better question is, "with 7 plus sensors- what is the next to fail"?

    I am seriously considering selling this ski. It is in mint condition with 20hrs on it.... but has had more issues that Time Magazine!! The last thing I want to do is get stranded out in the BFE and have to call the Coast Guard!

    0 Not allowed!

  10. #9
    Member
    Join Date
    Feb 2008
    Location
    Houston
    Posts
    44
    Thumbs Up
    Received: 0 Given: 0


    Default PROBLEM SOLVED: 2003' XPdi Bad Oxygen sensor (pic/attached)

    I have posted countless threads about all of the problems I've had with my 2003 XPdi.

    PROBLEM SOLVED: It was the Oxygen sensor. If you are have intermittent failures and / or are going into limp mode... then taking it to the dealership and there is no code to read......... check this lil *$($#*$kr out.

    A stinking $125 dollar part... but it took (TWO) dealerships NINE (9) weeks to finally diagnois and fix. They also replaced the MPEM and knock sensor which now looking back... probably WERE NOT faulty

    OH WELL!>> I AM BACK ON THE LAKE JUST IN TIME FOR THE FULL HEAT OF TEXAS HEAT WAVE!
    Attached Images Attached Images

    0 Not allowed!

  11. #10
    Senior Member
    Join Date
    Feb 2008
    Location
    Cairns AUSTRALIA
    Posts
    142
    Watercrafts
    2000 gtx di injected
    Thumbs Up
    Received: 0 Given: 0


    Thumbs up good o

    Let us know how the ski goes on your next ride .....

    0 Not allowed!

  12. #11
    kustomkarl's Avatar
    Join Date
    Sep 2007
    Location
    Sunny S.W. coast of Englewood, Florida
    Posts
    11,229
    Watercrafts
    1996 Chris Craft 26' Cruiser, Kawasaki 440 Superstock, 550 Mod., 2008 200Speedster 310 Hp
    Thumbs Up
    Received: 7 Given: 0


    Default

    Yes, do keep us up to date so we can use your information to help other owners with the same problem if it occurs.

    Karl

    0 Not allowed!

  13. #12
    Junior Member
    Join Date
    Jan 2008
    Location
    Conroe, TX
    Posts
    10
    Watercrafts
    1998 Seadoo GS 720cc
    Thumbs Up
    Received: 0 Given: 0


    Default TX heat

    Where in part of TX are you from TX T? Im from the Houston area, but live in SC because of being in the NAVY. I grew up on Lake Conroe, if that rings any bells.

    0 Not allowed!

  14. #13
    Junior Member
    Join Date
    Jun 2008
    Location
    Atlanta
    Posts
    3
    Watercrafts
    03 xp di
    Thumbs Up
    Received: 0 Given: 0


    Default 2003 xp di problems

    I have read your posts and my ski is doing what yours did. It runs fine for about 15 min and then a long beep and the screen flashes MAINT and the ski will only run about 4800 rpm. Take key off and restart and will run fine for a min then goes back into limp mode. I noticed you narrowed it down to oxygen sensor. Did that fix it totally? I'm afraid that dealer is going to do me wrong and take forever to troubleshoot it. Thanks

    0 Not allowed!

  15. #14
    Member
    Join Date
    Feb 2008
    Location
    Houston
    Posts
    44
    Thumbs Up
    Received: 0 Given: 0


    Default

    Matt.... Take my advice.... Take a HARD look at the OX_Sensor! I spent WEEKS waiting on the dealer to find out what was wrong.

    What happened in my case was that the sensor heats up and stops working.. so that cylinder shuts down and it goes into LIMP MODE. Then you get the ski back to the dealer and it has cooled off so it starts up it runs fine. The codes it threw were of no help. They even replaced the KNOCK sensor on the top of the cylinder head.

    In the end the part & fix wasn't that bad. The frustration and MIS-Diagnosis by the dealer WAS MISERABLE

    My ski has run at 100% ever sense.

    0 Not allowed!

  16. #15
    Junior Member
    Join Date
    Jun 2008
    Location
    Atlanta
    Posts
    3
    Watercrafts
    03 xp di
    Thumbs Up
    Received: 0 Given: 0


    Default

    well its at dealer now and they havn't called me. How much is the oxy sensore and how hard is it to replace? This thing ran fine last summer. The battery died so I put a new one in it the other day and the first ride of the season it started doing this. It couldn't be a battery problem could it??

    0 Not allowed!

  17. #16
    Junior Member
    Join Date
    Jun 2008
    Location
    Atlanta
    Posts
    3
    Watercrafts
    03 xp di
    Thumbs Up
    Received: 0 Given: 0


    Default

    oh yea how did you determine thats what it was? did it throw a code for the oxy sensor? and why does it throw other codes if thats not the problem??

    When I was riding it beeped really loud and flased MAINT on screen. Well i thought it was just the thing telling its time for 30 hour service or something cause it kept running fine for another 5 min or so before it started limiting the rpm. is that what yours did?

    0 Not allowed!

  18. #17
    Member
    Join Date
    Feb 2008
    Location
    Houston
    Posts
    44
    Thumbs Up
    Received: 0 Given: 0


    Default

    I found out the hard way.... my mechanic figured it out by "trial and error">> which meant mucho denaro$$ and tons of time.

    The MAIN issue is that the ski wasn't throwing a code because the oxy sensor didn't "go bad".. it would just quit working (or work intermittenly). one time when it shut the cylinder down the MPEM registered a "knock sensor" error so the mechanic had me purchase & replace it... only to find out it wasn't bad.

    the oxy sensor sits between the fuel injector rail and goes into cylinder head. It's not an expensive part and it doesn't take long to replace.

    It's the #1 failure part in that system. My ski has run solid ever since.

    0 Not allowed!

  19. #18
    Junior Member
    Join Date
    Jul 2008
    Location
    Calgary
    Posts
    1
    Watercrafts
    2003 Seadoo XPDI
    Thumbs Up
    Received: 0 Given: 0


    Default

    hey just wondering if you still have that MPEM for your 03 xpdi? it still works right? would you be interested in selling it? i need one for my 03 and cannot find them anywhere..... i would purchase it from you if you want....let me know thanks.

    QuadRacer99

    0 Not allowed!

  20. #19
    Member
    Join Date
    Feb 2008
    Location
    Houston
    Posts
    44
    Thumbs Up
    Received: 0 Given: 0


    Default Picture Of The Oxygen Sensor

    Since this thread will no doubt be used by future XPdi victims I figure it would be worth the time to post a pic of the part that was defective in my boat.

    I also included pictures of the MPEM and Knock sensor for visual reference since they were mentioned several times.
    Attached Images Attached Images

    0 Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. *WANTED* Access Cover for 98 Speedster, and "Carpet"
    By sandshark in forum Buy/Sell/Trade Sea-Doo Related
    Replies: 3
    Last Post: 05-02-08, 03:09 AM
  2. 2003 XPdi- "rear cylinder air pump" malfunction?
    By TxToby in forum 2-Stroke Sea-Doo PWC forum
    Replies: 3
    Last Post: 03-30-08, 11:47 AM
  3. Edy "King of Kings" Speed Run Kissimmee River
    By seadoofeed in forum Sea-Doo Videos
    Replies: 1
    Last Post: 03-11-08, 04:58 PM
  4. Stockholm Boat Show "Allt för sjön" 2008
    By seadoofeed in forum Sea-Doo Videos
    Replies: 0
    Last Post: 03-09-08, 10:40 PM
  5. EXTREME "Am I Ever Gonna Change" Live Video Compilation
    By seadoofeed in forum Sea-Doo Videos
    Replies: 0
    Last Post: 11-25-07, 07:23 AM

Members who have read this thread : 6

You do not have permission to view the list of names.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Register forum what's new