New owner - Impeller nicked up, need advice - Seadoo Forums

Visit PWCMuscle.com
for 15% off all Hydro Turf - CODE: HYDRO15
Need OEM parts for your boat or PWC? Visit SeadooWarehouse.com
Results 1 to 4 of 4
  1. ☑ ORIGINAL POSTER #1
    Junior Member
    Join Date
    Aug 2009
    Location
    CT
    Posts
    22
    Thumbs Up
    Received: 0 Given: 0


    Default New owner - Impeller nicked up, need advice

    Hi Guys,

    I have a 2001 Challenger 2000, with the Merc V-6. I bought it and had it up in NH on a lake all last week and it ran great (I think) after sitting a couple of years. I got about 46-47 MPH with 2 guys (400lbs) and a half tank of gas. Pulled me out on 1 ski, tubed with the kids no problem, pulled the kids on skis no problem, planned out pretty quick.

    So I'm going through it today, and found 3 golf ball sized rocks jambed in the stator. 2 rocks in 1 section, the third next to it. I can't understand how it ran so well like that? Anyway, the inner impeller is a bit chewed up on the leading edge looking at it from the grate side as it the stator cone. The housing is a little scraped up too, but very slight. The stator is the worst of it. I was able to knock the rocks loose, took out a plug and spun the impeller to catch the rocks back into the grate 1 at a time, and they're out, but.....so I need to replace the impeller? I figure if it ran 46-47 with 2 of the posts 90% blocked and the impeller with the edge nicked up it should be ok with them out, yes??

    BTW - it still has the HydroGrate, I ordered the 6 fin today.

    Thanks in advance for the input!!
    Last edited by mwz1500; 08-17-09 at 11:00 PM.

    0 Not allowed!

  2. # ADS
     

  3. ☑ ORIGINAL POSTER #2
    Junior Member
    Join Date
    Aug 2009
    Location
    CT
    Posts
    22
    Thumbs Up
    Received: 0 Given: 0


    Default No replies!!!

    Ahh.. help me out!!

    I dropped her into a local lake tonight, and minus the rocks, it ran great. I think they were jambed in the stator all last week, I never looked (rookie). It did pull a little left last week, and the rocks were jambed in the left side of the stator, so, I think that was why? It ran straight tonight.

    Although the leading edge of the stator is less than perfect, and the back side (grate side) of the impeller is also less that perfect, it ran 51mph tonight in fairly rough conditions with the same 2 guys and a 1/4 tank of gas.

    Not bad!!!???

    My new fixed grate is on order, no more HydroSurge.....


    0 Not allowed!

  4. #3
    Dr Honda's Avatar
    Join Date
    Apr 2009
    Location
    Pittsburgh
    Posts
    18,081
    Watercrafts
    '00 Polaris Genesis '96 XP800 '02 Islandia 240 EFI
    Thumbs Up
    Received: 327 Given: 0


    Default

    Well…

    I think the reason you didn’t get a response is because you really didn’t ask a question. I see one question, but it is buried in a statement. If you want a response… ask a clear question.

    OK… if the pump and impeller is messed up… then fix it. If it’s running well, and there is minimal cavitation… don’t worry about the nicks, and scratches, and have fun with the boat.
    Tony

    PM or post for help. Don't leave questions in my profile box. (i never check it)

    I'm not going to be able to do vinyl or carbs for a while. Starting my new job is taking a lot of time

    0 Not allowed!

  5. ☑ ORIGINAL POSTER #4
    Junior Member
    Join Date
    Aug 2009
    Location
    CT
    Posts
    22
    Thumbs Up
    Received: 0 Given: 0


    Default

    Thx Tony - I did ramble on a bit. It seems to run great, I'll eventually do the impeller, but it dosen't seem to be hurting it any! Thanks for the help

    0 Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Advice for speedster owner
    By matlac in forum 2-Stroke SeaDoo Sport Boat Forum
    Replies: 3
    Last Post: 06-07-09, 09:36 PM
  2. spun impeller (I need advice or HELP!)
    By blttitan in forum 2-Stroke SeaDoo Sport Boat Forum
    Replies: 10
    Last Post: 05-11-09, 11:40 PM
  3. Hey guys upcoming new owner!!!! Need some advice
    By txruffhouse18 in forum 2-Stroke SeaDoo Sport Boat Forum
    Replies: 3
    Last Post: 04-17-09, 05:48 PM
  4. New owner needs help
    By ThomasD1981 in forum Non-Seadoo PWC Talk
    Replies: 13
    Last Post: 11-05-08, 05:18 PM
  5. New PWC owner......help..advice..
    By Cloud 9 in forum Non-Seadoo PWC Talk
    Replies: 2
    Last Post: 04-21-08, 07:05 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Register forum what's new