Bad problem 240 M2 EFI -00 Challenger 2000 - Seadoo Forums

Visit PWCMuscle.com
for 15% off all Hydro Turf - CODE: HYDRO15
Need OEM parts for your boat or PWC? Visit SeadooWarehouse.com
Results 1 to 7 of 7
  1. ☑ ORIGINAL POSTER #1
    Member Chrille's Avatar
    Join Date
    Jun 2009
    Location
    Sweden
    Posts
    52
    Watercrafts
    Sea Doo Challenger 2000 Optimax 250 -04
    Thumbs Up
    Received: 0 Given: 0


    Default Bad problem 240 M2 EFI -00 Challenger 2000

    Hi.
    Still have trouble starting it up. But works then i hold the throttle at w.o.t. after a while, but will not go higher than 5300 rpm. The plugs get really black the engine smokes quite black aswell.


    I made a really fast turn back to shore and the engine almost died out. After that the engine sounds really bad wont go over 3000 rpm and after a while dies out. I Was able to restart it but the same thing again.. Runs really bad sounds like nothing i heard before missfires and dies out again. Sounds like something is jumping around in the engine. And now it will not restart. So got towed back.

    Please help me.. Changed the trigger, airtempsensor and engineheadtemp sensor today after a month on land and now itīs up on land again..

    Can the engine just be finished?? Ready for the scrapyard??

    //Chrille
    Last edited by Chrille; 07-16-09 at 02:04 AM.

    0 Not allowed!

  2. # ADS
     

  3. #2
    rookie101's Avatar
    Join Date
    Jun 2008
    Location
    Okotoks Alberta, Canada
    Posts
    1,012
    Watercrafts
    2006 Yamaha AR230 HO 320hp
    Thumbs Up
    Received: 4 Given: 0


    Default

    What did the shop say when they replaced the trigger, did they not mention anything?? It's possible when they did the trigger assembly they left something loose. That would explain the noise and poor performance. Hopefully that is all it is.

    I would take it straight back to them and have them look at it again.

    Aaron
    Looking for parts for your Doo?? Click HERE





    Find your Mercury M-2 motor and pump parts here!

    0 Not allowed!

  4. #3
    Junior Member
    Join Date
    Aug 2008
    Location
    Minnesota
    Posts
    10
    Watercrafts
    2001 Sea Doo Speedster
    Thumbs Up
    Received: 0 Given: 0


    Default Trigger?

    I am having starting problems also (240 efi). I have checked everything up to the elec fuel pump including voltage and jumped negative to ground(pump works). I don't have a pressure gauge, but I have fuel all the way into the VS. What is this "trigger" and what might I check next. (float and needle valve were free moving)

    thanks,

    djwdoo

    0 Not allowed!

  5. #4
    rookie101's Avatar
    Join Date
    Jun 2008
    Location
    Okotoks Alberta, Canada
    Posts
    1,012
    Watercrafts
    2006 Yamaha AR230 HO 320hp
    Thumbs Up
    Received: 4 Given: 0


    Default

    Quote Originally Posted by djwdoo View Post
    I am having starting problems also (240 efi). I have checked everything up to the elec fuel pump including voltage and jumped negative to ground(pump works). I don't have a pressure gauge, but I have fuel all the way into the VS. What is this "trigger" and what might I check next. (float and needle valve were free moving)

    thanks,

    djwdoo
    djwdoo, start a new thread with an explanation of the problem. Make sure you mention if you are getting spark and any other information you can think of.

    Aaron

    0 Not allowed!

  6. ☑ ORIGINAL POSTER #5
    Member Chrille's Avatar
    Join Date
    Jun 2009
    Location
    Sweden
    Posts
    52
    Watercrafts
    Sea Doo Challenger 2000 Optimax 250 -04
    Thumbs Up
    Received: 0 Given: 0


    Default

    Quote Originally Posted by rookie101 View Post
    What did the shop say when they replaced the trigger, did they not mention anything?? It's possible when they did the trigger assembly they left something loose. That would explain the noise and poor performance. Hopefully that is all it is.

    I would take it straight back to them and have them look at it again.

    Aaron
    The only thing the shop did was help me release the flywheel. I did everything myself. They didnīt do anything for 3 weeks and it seems that they are complete idiots.
    The only thing that happened standing there was that i now also hav wet carpets and a stereo with waterdamage. They left it standing in the rain with the aft up.

    Iīm pretty shore I tighten all things up really god. but i will check that again.
    If i have water in the fuel can the engine sound bad or should it just die..

    0 Not allowed!

  7. #6
    rookie101's Avatar
    Join Date
    Jun 2008
    Location
    Okotoks Alberta, Canada
    Posts
    1,012
    Watercrafts
    2006 Yamaha AR230 HO 320hp
    Thumbs Up
    Received: 4 Given: 0


    Default

    Start by going over everything and making sure it is tight. If you want to eliminate the fuel as a problem, drain the vapor separator and the fuel/water separator, then disconnect the pick-up hose going to the fuel tank and run it into a small tank with fresh fuel.

    What kind of oil are you running in the boat?

    Aaron

    0 Not allowed!

  8. ☑ ORIGINAL POSTER #7
    Member Chrille's Avatar
    Join Date
    Jun 2009
    Location
    Sweden
    Posts
    52
    Watercrafts
    Sea Doo Challenger 2000 Optimax 250 -04
    Thumbs Up
    Received: 0 Given: 0


    Default Shot engine

    Hi.
    The engine is ready for the scrapyard.
    One piston is stuck in the cylinder but i can still move the flywheel around even crank it.

    I canīt belive it after all work i put in to it.

    One sparkplug was totallt smacked in with lots of new metal melted to it.

    Just wonder what caused this?

    But now i will not put any more work on this scrap engine..

    So anyone please help me get a new engine to the boat.

    I wanīt a complete engine who fittes on the jetpump.

    Can i for example buy a 2009 240 efi engine or 250 optimax engine does that fit the pump unit?

    Any tips on a good used engine??

    0 Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 SeaDoo 2000 Challenger 240hp Mercury
    By millerwarren in forum Mercury Powered SeaDoo Sport Boats
    Replies: 4
    Last Post: 08-12-09, 06:52 PM
  2. 2000 Challenger 2000 intermittent engine cutoff
    By seadoodude1 in forum Mercury Powered SeaDoo Sport Boats
    Replies: 20
    Last Post: 08-03-09, 10:53 AM
  3. Digital Instrument cluster for 2000 Challenger 2000
    By csellars in forum 2-Stroke SeaDoo Sport Boat Forum
    Replies: 0
    Last Post: 06-08-09, 05:57 PM
  4. 2000 Challenger Mercury hot start problem
    By hoppe in forum Mercury Powered SeaDoo Sport Boats
    Replies: 1
    Last Post: 07-10-08, 03:46 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Register forum what's new