Low Power on 2003 Utopia 185 Mercury EFI - Seadoo Forums

Visit PWCMuscle.com
for 15% off all Hydro Turf - CODE: HYDRO15
Need OEM parts for your boat or PWC? Visit SeadooWarehouse.com
Results 1 to 11 of 11
  1. ☑ ORIGINAL POSTER #1
    Junior Member
    Join Date
    Jun 2009
    Location
    Abu Dhabi
    Posts
    4
    Watercrafts
    2003 Seadoo Utopia 185
    Thumbs Up
    Received: 0 Given: 0


    Default Low Power on 2003 Utopia 185 Mercury EFI

    Hello Everyone,

    I am a new, first time boat owner who shipped a seado from Florida to Abu Dhabi, UAE. It ran fine until I got the red oil light beeping. The beeping would stop but the light stayed on. I assumed this meant the oil was low. I took the boat out of the water and the marina mecahnics added 3 liters of two kinds of 2 stroke oil that they said is fine. We took the boat out and the light and beeping stayed. I drove it around a little hoping that things needed to settle ot something but it was not the case. Then I got the constant overheat beep so i shut the boat off and got a buddy to tow me in. I took it to a specialty Mercury Engine shop here. Although they didnt really speak english, they explained that something was bad and replaced it in about half an hour. I took the boat out, no light and it ran great. A weak later I took it out and it felt really weak. It had no power when I tried to accelerate. When I took it out I noticed there was some rope and trash caught in the intake. I removed it but the engine still sounds off. I have also been having trouble starting for a few weeks. Does anyone have any ideas? I am completely new to this so I am not sure what info is actually relevant. I plan on going out tomorrow morn to see if removing the trash hada significant impact. Cheers and hanks for all your help!

    0 Not allowed!

  2. # ADS
     

  3. #2
    rookie101's Avatar
    Join Date
    Jun 2008
    Location
    Okotoks Alberta, Canada
    Posts
    1,012
    Watercrafts
    2006 Yamaha AR230 HO 320hp
    Thumbs Up
    Received: 4 Given: 0


    Default

    Any trash in the jet will cause major problems in the way the boat performs so that may have fixed your power problem.

    From reading your post I would guess that when the oil tank went low the level sensor in the small engine mounted tank went bad or stuck, and this is what they changed. As far as mix and matching oils, do not ever do this unless it is an emergency, and even then make 100% sure that they all meet the TC-W3 spec that Mercury calls for.

    Pick one type of oil and order it in bulk so you don't have this problem again. I only run the Quicksilver Premium oil that Mercury recommends in the manual, and have seen it available by the case on Ebay (four gallons a case).

    One last thing, your large reserve oil tank should hold three gallons, so three litres is not near enough to add after the low oil light comes on.

    Aaron
    Looking for parts for your Doo?? Click HERE





    Find your Mercury M-2 motor and pump parts here!

    0 Not allowed!

  4. #3
    Experienced Rider Craigmri's Avatar
    Join Date
    Jan 2009
    Location
    Spring Hill, FL
    Posts
    873
    Watercrafts
    2008 Starcraft 1800 Limited Sport 4.3 MPI Mercruiser
    Thumbs Up
    Received: 0 Given: 0


    Default

    Aaron,

    I wish you were my neighbor!

    Craig

    0 Not allowed!

  5. #4
    rookie101's Avatar
    Join Date
    Jun 2008
    Location
    Okotoks Alberta, Canada
    Posts
    1,012
    Watercrafts
    2006 Yamaha AR230 HO 320hp
    Thumbs Up
    Received: 4 Given: 0


    Default

    I wish I lived in Florida.............


    Growing up, dad was in charge of setting up new pulp and paper mills, and for a while we lived in Monroeville Alabama. When the contract was up they offered him a job in Miami, or Prince Albert, Sask. He picked PA (land of -47c and 10 months of winter). To this day I tell my parents I will never forgive them.


    True story.

    Aaron

    0 Not allowed!

  6. ☑ ORIGINAL POSTER #5
    Junior Member
    Join Date
    Jun 2009
    Location
    Abu Dhabi
    Posts
    4
    Watercrafts
    2003 Seadoo Utopia 185
    Thumbs Up
    Received: 0 Given: 0


    Default

    Thanks Aaron,

    This site is really great! Especially for folks in the middle of the desert (They dont call it the empty quarter for nothing).

    I was able to find the quicksilver oil. I didnt want to mix the oils but I had no siphon so I added 6 liters of the quicksilver to dilute it as much as possible while keeping about two inches of air space in the oil tank. I am going to go see if the trash removal made the difference now. Thanks again.

    I also tried to sign up for premium to get the manual but have to wait three days for Penpal to verify my account:-)

    Cheers!

    0 Not allowed!

  7. ☑ ORIGINAL POSTER #6
    Junior Member
    Join Date
    Jun 2009
    Location
    Abu Dhabi
    Posts
    4
    Watercrafts
    2003 Seadoo Utopia 185
    Thumbs Up
    Received: 0 Given: 0


    Default

    Hello again,

    I just got back from a test run. The power is back and it seems to behave fine. The engine sounds a bit off still. It is not as regular a sound as it used to make. It sputters a bit. I am hoping these problems are residual from the original overheating and that once everything gets lubed better it will smooth out. We are going for a longer ride today so I guess I will see.

    Thanks again!

    0 Not allowed!

  8. #7
    rookie101's Avatar
    Join Date
    Jun 2008
    Location
    Okotoks Alberta, Canada
    Posts
    1,012
    Watercrafts
    2006 Yamaha AR230 HO 320hp
    Thumbs Up
    Received: 4 Given: 0


    Default

    I know from a few of the times out camping with my dirt bikes and quads when I would run out of my regular oil and make a run to the nearest gas station for whatever they had for two-stroke oil, they would always run much worse until I could drain the tank the next week and go back to my preferred oil.

    Hopefully that is all the problem is. You may want to look at changing the plugs once you think most of the older oil is out of the tank.

    Aaron

    0 Not allowed!

  9. #8
    Experienced Rider Sikiguya's Avatar
    Join Date
    Oct 2008
    Location
    Salem, WI
    Posts
    381
    Watercrafts
    2007 Seadoo Utopia 205 SE
    Thumbs Up
    Received: 0 Given: 0


    Default I owe Craig and Aaron a bunch of drinks!

    Seriously guys! Come by and I will treat you to a bunch of good Wisconsin beer!!!

    0 Not allowed!

  10. ☑ ORIGINAL POSTER #9
    Junior Member
    Join Date
    Jun 2009
    Location
    Abu Dhabi
    Posts
    4
    Watercrafts
    2003 Seadoo Utopia 185
    Thumbs Up
    Received: 0 Given: 0


    Default

    Thank Aaron,

    We did a few trips to a small island shutling people back and forth and the more a drove the boat the better it sounded. I really do think that was the problem. It just surprised me that oil made such a difference. I read somewhere it may be because this oil has a different "flashpoint."

    I also like the idea about changing the plugs after a bit. Then I should be completely back to normal.

    Thanks a bunch guys!

    0 Not allowed!

  11. #10
    Experienced Rider Sikiguya's Avatar
    Join Date
    Oct 2008
    Location
    Salem, WI
    Posts
    381
    Watercrafts
    2007 Seadoo Utopia 205 SE
    Thumbs Up
    Received: 0 Given: 0


    Default Where do you boat?

    Ferdinand, Where do you boat in Abu Dhabi? Fascinating country. Believe it or not, I only heard of Abu Dhabi when I was yound and reading Garfield. There was some reference to it so I looked it up. Was it very costly to have that boat shipped like that?

    Aaron, feel bad that you could have been in Miami. I believe life would have been different for you had your father made the choice to move to FL. Whether it would have been good or bad...that is up to the man upstair. Did you meet your wife up north? or elsewhere. What do you do now? Ever thought about moving?!!

    0 Not allowed!

  12. #11
    Senior Member SeadooBOB Square Pants's Avatar
    Join Date
    Jun 2008
    Location
    Pacific Northwest
    Posts
    213
    Watercrafts
    1996 Seadoo Speedster 1994 Seadoo XP
    Thumbs Up
    Received: 1 Given: 0


    Default

    Quote Originally Posted by ferdinand View Post
    Hello again,

    I just got back from a test run. The power is back and it seems to behave fine. The engine sounds a bit off still. It is not as regular a sound as it used to make. It sputters a bit. I am hoping these problems are residual from the original overheating and that once everything gets lubed better it will smooth out. We are going for a longer ride today so I guess I will see.

    Thanks again!
    Did you or they check if the wear ring or impeller was damaged? If your impeller gets dinged it can cause cavitation which kind of sounds like the engine.

    0 Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Used 2003 Utopia 205
    By rdradu in forum 2-Stroke SeaDoo Sport Boat Forum
    Replies: 27
    Last Post: 07-03-10, 12:25 AM
  2. 2003 Mercury SEA DOO UTOPIA
    By seadoofeed in forum Sea-Doo Videos
    Replies: 0
    Last Post: 09-03-08, 07:30 AM
  3. Help for a new guy? (2003 Utopia)
    By hoped_snb in forum 2-Stroke SeaDoo Sport Boat Forum
    Replies: 0
    Last Post: 07-30-08, 02:53 PM
  4. Choke/stall @ 6000 rpm - 2003 Mercury 250 Optimax
    By lsegneri in forum Mercury Powered SeaDoo Sport Boats
    Replies: 1
    Last Post: 04-19-08, 11:49 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Register forum what's new