2000 SeaDoo 2000 Challenger 240hp Mercury - Seadoo Forums

Visit PWCMuscle.com
for 15% off all Hydro Turf - CODE: HYDRO15
Need OEM parts for your boat or PWC? Visit SeadooWarehouse.com
Results 1 to 5 of 5
  1. ☑ ORIGINAL POSTER #1
    Junior Member
    Join Date
    May 2009
    Location
    Kansas
    Posts
    1
    Watercrafts
    SeaDoo 2000 Challenger
    Thumbs Up
    Received: 0 Given: 0


    Default 2000 SeaDoo 2000 Challenger 240hp Mercury

    Boat has run fine this season so far until today. Although, it has been smoking quite a bit when first starting out in the water ~ very white smoke. Ran well today until late in the afternoon. Now when we want to speed up (from about 5mph) you can hear the engine rev up but do not go any faster. Like it doesn't kick in. My husband also said that the RPM's drop down too. Once this started, we were able to slowly get the boat back to the dock and out of the water.

    We had just had the boat looked at by a boat shop and they said that everything looked great. The compressions were fine.....

    Has anyone else experienced anything like this? Do you know what could be causing this? We just purchased the boat from out of town and are not familiar with things that could be potentially wrong.

    Cathy

    0 Not allowed!

  2. # ADS
     

  3. #2
    rookie101's Avatar
    Join Date
    Jun 2008
    Location
    Okotoks Alberta, Canada
    Posts
    1,012
    Watercrafts
    2006 Yamaha AR230 HO 320hp
    Thumbs Up
    Received: 4 Given: 0


    Default

    Sounds like you may have sucked something into the pump. Have a good look in both ends for any foreign objects or damage to the impeller or wear housing.


    Aaron

    0 Not allowed!

  4. #3
    Senior Member seadoodude1's Avatar
    Join Date
    Oct 2008
    Location
    Cypress, TX
    Posts
    163
    Watercrafts
    1998 Seadoo GSXL & 2000 Seadoo Challenger 2000
    Thumbs Up
    Received: 1 Given: 0


    Default

    Happened to me when it sucked up seaweed. Had to reach under and clear intake grate.

    0 Not allowed!

  5. #4
    Junior Member
    Join Date
    Oct 2008
    Location
    Minnesota
    Posts
    12
    Watercrafts
    2001 sea doo challenger
    Thumbs Up
    Received: 0 Given: 0


    Default

    on another jet boat..I blew a seal between the jet pump and intake.. it did the same thing.. 1 week and lots of sillicone at the shop..

    0 Not allowed!

  6. #5
    Senior Member johnhibbs's Avatar
    Join Date
    Jul 2009
    Location
    San Diego
    Posts
    239
    Watercrafts
    SeaDoo Challenger 2000, year 2001, 240 EFI
    Thumbs Up
    Received: 1 Given: 0


    Default exhaust hoses

    Bad exhaust hoses can cause low rpm's. The hoses can delaminate on the inside. Are the hoses soft in any area? They should be firm. My boat wouldn't get above 3000 rpm with bad hoses. See photo at left.

    0 Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 Seadoo Challenger 2000 w/Mercury 240EFI
    By mikem0310 in forum Buy/Sell/Trade Sea-Doo Related
    Replies: 1
    Last Post: 05-31-09, 12:00 AM
  2. Challenger 2000 Mercury 240 won't start sometimes
    By voomvoom in forum Mercury Powered SeaDoo Sport Boats
    Replies: 6
    Last Post: 03-09-09, 02:33 PM
  3. 2001 Seadoo Challenger 2000 with 240hp EFI M2 Motor
    By mikem0310 in forum Mercury Powered SeaDoo Sport Boats
    Replies: 12
    Last Post: 01-29-09, 12:47 PM
  4. 2000 Challenger Mercury hot start problem
    By hoppe in forum Mercury Powered SeaDoo Sport Boats
    Replies: 1
    Last Post: 07-10-08, 03:46 PM
  5. Sea Doo Speedster 2000 v6 240hp playing around
    By seadoofeed in forum Sea-Doo Videos
    Replies: 1
    Last Post: 04-03-08, 03:28 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Register forum what's new