2000 GSX Help - Seadoo Forums
Need OEM parts for your boat or PWC? Visit SeadooWarehouse.com
Results 1 to 8 of 8

Thread: 2000 GSX Help

  1. ☑ ORIGINAL POSTER #1
    Junior Member
    Join Date
    Dec 2007
    Location
    Winchester Virginia
    Posts
    4
    Watercrafts
    2000 Seadoo GSX 2006 Honda Aquatrax R-12
    Thumbs Up
    Received: 0 Given: 0

    Default 2000 GSX Help

    I have a 2000 GSX that I bought this past summer and the speedometer doesn't work. Has anyone else out there experienced this and know how to fix it?

    Also while I was on the lake 2 differen't times when I would first start it the orange light would blink and it would say service soon. But that would only stay on for about 5 seconds and the would go right off. The jet ski runs great. And these 2 times were seperate days. So I was just wondering if that was something to worry about or does the motor get a little loaded up and trigger a sensor everynow and then.

    Thanks for any help I can get on these 2 issues.

    Brent Hottle

    0 Not allowed!

  2. # ADS
     

  3. #2
    kustomkarl's Avatar
    Join Date
    Sep 2007
    Location
    Sunny S.W. coast of Englewood, Florida
    Posts
    11,229
    Watercrafts
    1996 Chris Craft 26' Cruiser, Kawasaki 440 Superstock, 550 Mod., 2008 200Speedster 310 Hp
    Thumbs Up
    Received: 15 Given: 0

    Default

    Brent, Welcome to the seadoo forum. I'm not real familar with you model, so I looked in the manual, and as far as the spedo goes I would check the fuse that is in the mpem box. The manual isn't completely clear as the the fuses for your exact model, but there appears to be an accessory fuse that is 5amp. check that. I would check all the wireing connections and be sure all the plugs are connected tightly and not correded inside. I also looked at the possible code for the orange light but the manual says you might need a dealer to plug your doo into a diagnostic tool and look for codes. Your doo has a lot of sensors and it could be possible one is faulty, or in need of service, throwing the orange light. I would keep an eye on it. Im sure another owner might chime in on you problems and offer a helping suggestion.
    Karl
    Please, If you have a "troubleshooting" request, use the correct category in the Sea-Doo Forum first.

    "Premium / Subscribed Members", not getting an answer, pm me directly for Expert Advise.



    When your ready for more performance, click on the this link!

    Click to order your Sea-Doo Parts at a fair price.

    Click here to view/join our Group on "Face Book"

    0 Not allowed!

  4. ☑ ORIGINAL POSTER #3
    Junior Member
    Join Date
    Dec 2007
    Location
    Winchester Virginia
    Posts
    4
    Watercrafts
    2000 Seadoo GSX 2006 Honda Aquatrax R-12
    Thumbs Up
    Received: 0 Given: 0

    Default

    Thanks for the help I don't know why I didn't think about checking the fuses. Pretty stupid of me. Thanks again

    0 Not allowed!

  5. #4

    Join Date
    Nov 2007
    Location
    cape coral fl
    Posts
    1,762
    Watercrafts
    (2) 2003 GTX 4TEC
    Thumbs Up
    Received: 12 Given: 1

    Default Speedo Inop

    Hi Brent,
    If the fuses all check good I would make sure the paddle wheel in the rear of the ski spins real easy and that the sensor that it's mounted to isn't cracked and the wires coming out of it aren't torn, etc.

    Thanks, Dennis

    0 Not allowed!

  6. ☑ ORIGINAL POSTER #5
    Junior Member
    Join Date
    Dec 2007
    Location
    Winchester Virginia
    Posts
    4
    Watercrafts
    2000 Seadoo GSX 2006 Honda Aquatrax R-12
    Thumbs Up
    Received: 0 Given: 0

    Default

    All of the fuses checked out. And the paddle wheel on the back spins very freely. I chased the wires and they looked fine. I'm lost on what else it could be. Thanks

    0 Not allowed!

  7. #6
    kustomkarl's Avatar
    Join Date
    Sep 2007
    Location
    Sunny S.W. coast of Englewood, Florida
    Posts
    11,229
    Watercrafts
    1996 Chris Craft 26' Cruiser, Kawasaki 440 Superstock, 550 Mod., 2008 200Speedster 310 Hp
    Thumbs Up
    Received: 15 Given: 0

    Smile Premium Membership a must for problem solving

    Here is a test for the speed sensor at the rear of the doo.
    To check if the speed sensor is operational, disconnect the speed sensor housing from the inside bilge. There are 3 wires attached to the speed sensor.You will need 2 of the 3 wires to test the speed sensor. The black/orange is ground. The purple /yellow is the pulse. Using a multimeter connect the positive probe to the speed sensor PURPLE/YELLOW wire and the negative probe to the BLACK/ORANGE wire.
    With the safety lanyard removed, depress the start/stop button to activate the timer. Slowly rotate the paddle wheel. Every 1/8 turn, the voltage should fluctuate between 5.5 and 8.5 Vdc. If you get this reading then the speed sensor is ok. Now check the wires going to the spedo and see if you get the same readings. If you do then the spedo unit itself could probably be bad.
    On the back of the spedo Gage are 5 wires. The purple is the power+ the black is the ground- and the purple/yellow wire is the pulse going into the Gage.(the same test as the sensor)You will also have a purple wire, power+ from the spedo Gage going to the info center and a black ground-,from the spedo Gage going into the info center. These should check out. If you want more detailed info you could join as a premium member and have a copy of the manual and more details for the wiring. The seadooforum has a large library of authentic sea doo shop repair manuals. The manuals include detailed wire diagrams, and troubleshooting guides to help you solve your problem. Click on the "seadoo manual" link on the home page for more details. Let us know how you make out and if you need any more help.
    Karl

    0 Not allowed!

  8. ☑ ORIGINAL POSTER #7
    Junior Member
    Join Date
    Dec 2007
    Location
    Winchester Virginia
    Posts
    4
    Watercrafts
    2000 Seadoo GSX 2006 Honda Aquatrax R-12
    Thumbs Up
    Received: 0 Given: 0

    Default

    thanks I have to leave today for a family function but when I get back on tuesday I will have time to check that out. Thanks again I will let you know how I make out.

    0 Not allowed!

  9. #8
    kustomkarl's Avatar
    Join Date
    Sep 2007
    Location
    Sunny S.W. coast of Englewood, Florida
    Posts
    11,229
    Watercrafts
    1996 Chris Craft 26' Cruiser, Kawasaki 440 Superstock, 550 Mod., 2008 200Speedster 310 Hp
    Thumbs Up
    Received: 15 Given: 0

    Default

    Cool Brent, we'll be here...maybe hung over on tues, but here..lol
    Karl

    0 Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Rx 2000
    By nick.rx in forum 2-Stroke Sea-Doo PWC forum
    Replies: 5
    Last Post: 12-29-07, 01:55 PM
  2. 2000 GTX RFI Shuts Off
    By oilie in forum 2-Stroke Sea-Doo PWC forum
    Replies: 3
    Last Post: 11-07-07, 02:58 PM
  3. 2000 Challenger 2000 Wiring Harness
    By scarfie in forum 2-Stroke SeaDoo Sport Boat Forum
    Replies: 0
    Last Post: 10-12-07, 06:41 PM
  4. 2000 gtx stalls
    By chefguy in forum 2-Stroke Sea-Doo PWC forum
    Replies: 3
    Last Post: 09-10-07, 06:23 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Register forum what's new