PDA

View Full Version : Mercury 240 EFI engine shuts off at high speed - HELP



kapeed
09-03-08, 09:38 AM
I have a 2002 speedster with the Mercury 240 EFI 6 cylinder engine. When I go on full throttle, the engine just shuts off. No sputtring or anything, just quietly shuts off. I am able to start the engine back immediately, but this problem is getting to be too frequent. If I go at less than full throttle, it does not happen. I have cleaned the plugs, and it did not help, the engine still shuts off at higher speeds. Someone please help. Thanks in advance..

Nate Surveyor
09-03-08, 12:50 PM
1st off, I simply do not know.

But, I will levy my guesses.

I think the RPM limiter is malfunctioning. I think that as soon as it hits too high of an rpm, that would allow the rev limiter to kick in, it kills the motor, and then when you hit the starter, to restart, it has been through a reset, and then all is well. Until you get the revs up again.

I am not for sure on this, but you might remove the "key" DESS system, then run it through diagnostics, and a reset, and solve it.

I don't know what I am talking about, but my guess work is often better than some dealers working on it, at 100 buks an hr!

:)

Nate

PS, can this feature be added to a mother in law?

He heheh

Ttocsybles
09-05-08, 08:03 AM
have you read the M2 service manual? there are multiple things that can cause that. there is a whole section troubleshooting fuel and sensors. it could be your TPS, MAP sensor, wide open adjustment on the throttle itself and so on... does it stall at a certian RPM or a certian % throttle while accelerating to full throttle?

seadoosnipe
09-05-08, 10:40 AM
The EFI M-2 Mercury is a totally computerized engine. It takes signals from one or more sensors and makes adjustments to your timing, fuel system and other engine management components.

YOur problem seems electrical though..........:agree:

andrewsilver
02-04-09, 10:24 PM
Hi Kapeed, did you ever figure out the issue here?

My 2002 Seadoo Utopia 205 with Merc 240EFI is having similar problems. I'm wondering if there's water in the fuel, or a computer/sensor issue, but not sure.

When just above idle, the engine suddenly cuts out, then comes back, then cuts out. Sometimes it cuts out completely and I have to restart it. When it comes back, it lunges forward obviously, then cuts back again.

As I accelerate further I seem to be able to eventually get it past the lunging and then it will run perfect on plane mostly.

But if I open the throttle to max, it eventually cuts out violently, then lunges forward, cuts out, lunges, etc. - until I reduce the throttle again to midspeed. Sometimes it cuts out completely at speed too, and I have to restart it.

Is this an electrical or computer/sensor issue? Or water in the fuel?

Thinking/hoping it might be water in the fuel, I drained the fuel tank through the fuel sender hole, hopefully I got out all the fuel. For the last bit I used a shop vac and sucked it up, but not sure if there's a hidden reservoir somewhere that I missed.

Next step is to figure out if the Merc240EFI has a fuel filter and a water separator. If so, can someone tell me where they are located, as I don't see them. I only see the fuel lines connected directly to the engine.

Help please... Is it water in the fuel, or something else?

Thanks in advance,
Andrew


-------------------
2002 Seadoo Utopia 205 Merc 240EFI with Bennett Hydraulic Trim Tabs
1997 Seadoo GTX with Touring Windshield
1995 Seadoo GTS with Touring Windshield

rookie101
02-04-09, 11:45 PM
You have two filters on your engine, there is a small inline fuel filter, and a fuel water separator. The fuel water separator looks like a spin on oil filter with the addition of a water sensor that threads into the bottom of it.

To change the filters' I cut the bottom off a washer fluid, or antifreeze jug and have a bucket handy. (I know..... What's the bucket for??) Start by sliding the bottom of the cut off jug under the fuel/water separator, and remove the water sensor to let the fuel drain. Once it has stopped dripping dump the jug bottom in the bucket. (oh that's what its for!!) you can now get on the separator with a filter wrench and remove it. Reinstall in the reverse order. Now place the jug bottom under the small inline filter and remove and replace it. Throw the jug bottom in the bucket and your done.

Since you are in there, I would also change the spark plugs at the same time. Give this a try and get back to us with an update.

fuel/water separating filter Mercury part number 35-18458Q4

inline fuel filter Mercury part number 35-889615

Ngk plug number BPZ8HS10 (do not substitute)



Aaron

andrewsilver
02-05-09, 10:41 AM
Aaron, thanks, I will try to do it this weekend.

But can you tell me exactly where is the water separator and the inline fuel filter are located? I've looked all over the engine and can't see it.

On the Merc sterndrive on my previous boat, it was obvious - was connected right to the engine with the fuel line coming into it. But on the 240 EFI, I just don't see the spin-on water separator filter. Nor do I see the inline fuel filter.

thanks!
Andrew

Chrisca74
02-05-09, 06:10 PM
I know this problem all to well. My enginge did the same exact thing. It turned out to be the CPS that is mounted in front if the teeth on the fly wheel real simple fix, less than 5 miniutes, just two screws unplug it put the new one in $50 and your off. I'm so confident I would put money on it.

andrewsilver
02-05-09, 08:55 PM
Many thanks Chrisca74 - I'm really hoping you're right - that would be an easy fix, going to look into it this weekend.

Any chance you can tell me what it looks like and how I access it. Is it on top of the engine near the front?

Thanks again.

Chrisca74
02-06-09, 09:32 AM
That is correct, it is on the top of the engine held in place with 2 bolts and it has I belive a 2 wire plug. Its right below the fly wheel it monitors the teeth on the fly wheel. Let me know how it turns out.

andrewsilver
02-08-09, 12:36 PM
Thanks all for the advice. It appears to have been solved. I changed the inline fuel filter, the fuel filter/water separator and cleaned the spark plugs.

I just took it out on the lake and the hesitations and cutouts seems to have gone away. Hopefully it will stay that way.

One note is that when I emptied the fuel filter/water separator into a plastic container, there were quite a lot of sediment in there.

Chrisca74 - thx also for the suggestion on the CPS. I went to the dealer, didn't have my serial number with me, so they gave me the CPS they had in stock. But when I looked on my 240 EFI engine, I couldn't find that part. Looked it up on Mercruiserparts.com with my serial number and there doesn't appear to be a CPS on this model with my serial number (I did notice it on other models though.

Thanks again for the suggestions/advice, appreciated.

Leo
02-27-09, 08:56 AM
Hi im gaving problems with my 2000 seadoo challenger. It cut out on me a few times in mid run but after it cut out it would not start for ages. when out on the river and i turn off the boat it can also take ages for it to start you i could be there for about 10 mins trying to start it. I change the sprk plugs in the boat and there still was no change and this stage i cant trust the boat been towed in 2 many times now. Any suggestions would be great

seadoodude1
08-04-09, 11:25 PM
This seems to be a common problem and I'm still searching for answer. In my case engine will cut off but can be immediately restarted. Cots out more frequently in rough choppy water. I ordered new plugs and exhaust hose and trigger. Now I see it may be CPS. something else to try before she sees the mechanic.

andrewsilver
08-04-09, 11:45 PM
Seadoodude1, your problem might be the post where the DESS key connects to. I had that problem on my 97 GTX seadoo, it would just cut out while driving, then start right up after I took the DESS key off and put it on again. If that's the problem, just buy a new post at the dealer and then you can cut the wires and replace it.

Back to my Utopia 205, which appeared to be fixed in Feb09 - the acceleration problem is back:

"When just above idle, the engine suddenly cuts out, then comes back, then cuts out. Sometimes it cuts out completely and I have to restart it. When it comes back, it lunges forward obviously, then cuts back again.

As I accelerate further I seem to be able to eventually get it past the lunging and then it will run perfect on plane mostly.

But if I open the throttle to max, it eventually cuts out violently, then lunges forward, cuts out, lunges, etc. - until I reduce the throttle again to midspeed. Sometimes it cuts out completely at speed too, and I have to restart it."

The problem just started again, so I emptied the fuel filter/water separator, and put in new spark plugs, but haven't tried it yet.

Could the problem be the throttle shifter? There is a magnet in the shifter that activates a switch, and when I put it into forward or reverse, it often doesn't activate - so when I throttle-up, the rev limiter goes on. I then whack right next to the shifter a few times, and then try again, and after 2-3 times it usually engages.

I'm wondering if the magnet is suddenly disengaging and then re-engaging when I'm going at high speed, which causes the lunging.

Any thoughts/advice? Thanks.

rookie101
08-05-09, 12:05 AM
Andrew your problem definitely sounds like it is related to the neutral safety switch. Replace it and see if it cures the problem.

Seadoodude your problem being more pronounced in rough water sounds like a bad connection. Check your lanyard kill switch with a multimeter while banging on it, and check all the wires coming from your ignition switch. They can be problematic as well. Also be sure to check every connection you can find.

Aaron:cheers:

johnhibbs
08-05-09, 02:04 AM
I recently had a problem with my Challenger 2000 240EFI M2. I tried everything on the engine then discovered that the wet exhaust hose was delamintated on the inside and was causing an exhaust blockage. I could always start the boat and it would run fine up to about 3000 rpm but no more. Does the exhaust hoses feel soft at the bend near the muffler? The exhaust hose should be very stiff. Unfortunately you have to remove the hose and look inside to be sure it's not delaminated. Seadoo had a recall because of these hoses and has a new design now. You may have to cut a slit in the hose at the engine end to get it off because it is probably melted on. I'm on a mission to tell everyone about this problem. The delaminated hose looks like the one on the left when you open it up.

andrewsilver
08-05-09, 12:49 PM
Wow John that's pretty interesting - I haven't checked the exhaust hoses to see if they've delaminated - I will check them when I return from vacation mid August.

However if it's a recall, can I bring my boat into a Seadoo dealer and they should check/fix that for free?

I'm seriously wondering if that could be the issue. I'm not absolutely convinced it's the neutral switch, because when it last happened the other day, I had the engine at full throttle, and it lost some power at the top end just before I had to come in. The boat slowed down to 46mph from 48, and I could hear the engine wasn't going as fast as it had a minute earlier, even though it was not lunging at this time.

So I'm wondering if the tubes became delaminated and were restricting the exhaust. I'll have to check this when I get back home.

Aaron - thanks for the input as well. I see you're in Calgary - my brother and some family live in Edmonton, and I'm originally from Montreal, now in Texas. Where do you ride your boat in Calgary?

Thanks guys.
Andrew

johnhibbs
08-05-09, 01:23 PM
The way I understand it is that the hoses would get a small leak and spray the engine compartment with a mist of salt spray. This salt would then cause a problem with corrosion on the throttle and put it in WOT. I don't think they recalled the hoses but they did redesign the hoses. The recall was to replace the throttle parts. This is the recall: http://www.uscgboating.org/recalls/recalls_detail.aspx?id=040019T

I hear the new hose also has a problem but it should last a while. The new hose has a metal liner.

Both of my wet exhaust hoses were delaminated on the inside.

johnhibbs
08-05-09, 01:35 PM
http://www.tc.gc.ca/marinesafety/debs/obs/equipment/recalls/mercury240.htm

andrewsilver
08-25-09, 02:36 PM
Well, I emptied the fuel filter/water separator, but did not see any water in it.

So I decided to replace the spark plugs with new NGK BPZ8HS-10 ($5.49 each at O'Reilly Auto is the lowest I could find them).

Seems to have fixed the problem - for now... Hesitations went away at low and high speed. Seems to idle fine as well.

carlosparham
09-10-10, 12:25 PM
hi, i own a sea doo challenger 2000, model 2002 with a mercury efi 240 hp, the engine run great untill this summer when i try to accelerate about middle range, the engine stop, it only runs in low or very high speed, if i put the trotle in the middle the engine dies and it take a while to start again, also, i don't know if is related but all the gauges stoped working at the same time, i cheked all the fuses and they are ok, coul be the cps?. please help

johnhibbs
09-10-10, 08:39 PM
I had a problem with my exhaust hoses shutting down the engine. These hoses delaminate on the inside and block the exhaust at high rpm. Do the hoses feel soft? Can you squeeze the hose together? They should be very stiff. See my previous posts above.

carlosparham
09-10-10, 11:09 PM
i don't think the hose is the problem because the engine works fine at high speed, it just at mid speed that shut off.

rickyray2000
01-30-11, 09:15 PM
i don't think the hose is the problem because the engine works fine at high speed, it just at mid speed that shut off.

Carlos, did you fix the problem? Im having the same issue right now and cant seem to figure it out. I just replaced the plugs and both filters. Took it out today and its doing the same thing. Any suggestions would be greatly appreciated.
Thanks, Ricky

carlosparham
02-04-11, 05:34 PM
No, i haven't fix it, the problem that i have is that in Honduras, where the boat is, there is not a Sea Doo dealer or mechanic that i can take my boat to, so basicaly i need to fix it myself, if only i knew what the problem is, now something odd is happening, all the gauges are not working, not one of them, i tough it was an electrical problem but i cheked all the fuses and are fine, i just don't know what is happening, first the engine now the gauges, if you ever find the solution please let me know, i will really appreciated. thank you