PDA

View Full Version : Electrical



DEE JAY
05-08-08, 07:03 PM
Greetings to one and all. I'm new to the site and it sure looks like a great place to get help.

I have two skis 1990 and 1992 580 cc SP's.

I replaced the engines with SBT short blocks and have about 12 hours on both skis.

My 92 is not getting any spark. It started and ran for about 2 seconds and died. Couldn't get it started.

Engine turns over strong, I changed the fuses in the electrical box and still no go. The 7 amp fuse was broken and the 15 Amp was good. I changed them both anyway. No spark.

My main question is how to test the Stator and CDI without the Seadoo Engine Ignition Tester. I have the shop manual and read up but it says to hook up the tester and follow their directions.

Is it possible a bad kill switch or lanyard switch could be the culprit?

Any and all help appreciated.

Thanks.

DEE JAY

kustomkarl
05-08-08, 11:18 PM
welcome to the seadoo forum Dee Jay. I would check both switches first. Follow the wires to the connector and use a multi meter and check for continunity on the switch. I bet it is the switch that isn't working properly. Check the ground too on the safety lanyard switch. Keep us posted. If these checkout we'll go deeper to find the problem.

Karl

DEE JAY
05-23-08, 10:00 PM
Karl, A big thanks for the suggestion. I changed out both switches and the bugger started right up.

Thanks again and I have this site saved to favorites.

DEE JAY

kustomkarl
05-23-08, 10:47 PM
Glad it worked for you ...Now go have a fun filled weekend.

Karl