PDA

View Full Version : 2000 Islandia cooling problem



blinniss
08-20-09, 07:24 PM
We just bought a 2000 Seadoo Islandia with the Mercury M2 jet drive (6 cylinder, 2 stroke, 240 HP). It doesn't seem to pull water through the engine to cool it down. The craft will automatically stop after riding in it for a steady time. Does anyone know what we can do? Thank you for any help!

Thunderkat13
08-20-09, 08:23 PM
First and foremost do not drive it anymore until you figure out . The Mercs are expensive to replace, so be careful.
Are you getting the constant beep.?
Have you flushed the cooling system throughly...
Did you notice if when in the water and idling/moving that the boat was squirting water out the back left side.. AKA the pisser? If your not seeing water coming out then you have a blockage..

Hope some of this helps...

rookie101
08-20-09, 09:30 PM
Give it a good flush like Thunderkat13 suggests, as well as have a good look in the pump area to make sure there are no weeds or trash stuck in it (this is where you get the cooling water from). See what you find and let us know.

Aaron:cheers:

blinniss
08-21-09, 06:00 AM
Correct, no water comes out of the pisser. we've had this boat for just over a month and love it. Didnt come with the instruction manuals.Learning the hard way. I will do a complete check for any blockage and let you know from there.At flush down of the engine we get a good flow through the jet drive and the exhuast but none to the cylinder heads.Will look for blockage there.Thanks Thundercat13.