PDA

View Full Version : Merc 240hp efi won't start if temp sensor connected



ussaguilar@hotmail.com
03-11-08, 01:11 PM
Hi,

I was wondering if anyone can offer some advise. I've taken my Seadoo to my local dealer, but I was told they don't work on that engine any more. So I bought the service manual for it, and did some work on it.

My problem was I couldn't start the boat so I started trouble shooting the system at this point the engine only coughed. So I kept going foward and checked the head tempeture sensor and notice a 15% change on the sensor instead of the +/-10% the manual mentioned. So I disconnected the sensor and it started fine it idled with the rich mixture like it should. I then went ahead and replaced the head temp sensor with a new one and it does the same thing with the exception that it starts and dies a couple of times. The it just cranks and no start. So far I've cleaned the final pump, changed head temp sensor, changed fuel and oil, and fuel filters. Any ideas on what else can be wrong?

Thanks,
Oscar

ScubaDoo
03-11-08, 03:15 PM
Hey Oscar, welcome to the seadoo forum. We could use a little more information on the seadoo to help with your problem. I see it is a speedster, what year and which model. Single or twin engine? This forum is full of members that don't just own new seadoo's. This is a friendly place with many active members members more than willing to help with advise. Get back to us with more info, and I'm sure you'll get a quick response.

seadoosnipe
03-11-08, 06:16 PM
Welcome to the forum......
The M-2 engine was Mercury's second attempt at a jet engine. It is a nice engine, loaded with horsepower. But now, since Rotax came out with the new 4-TEC series engines, they can produce the horsepower that the Merc could and then some. Plus, they weight a lot less.
Your problem is probably going to be related to the TKS ECM (turn key start electronic control module). This engine uses several sensors to direct the air/fuel and ignition timing, for it to run. When you disconnect a sensor wire, then your electornic system will send out false signals that could keep your engine from starting. In the TKS system, it will enrichen or lean out your fuel system by the temperature of the block, which is through the sensor you state that you just disconnected.
You say you got the manual. With the M-2, you'll need to start reading about this TKS system and how it functions.
I worked with one other memeber for a long time trying to solve a heavy smoking issue. It finally got solved when he replaced his temperature control sensor. It seems the TKS got a bad signal and kept the fuel rich, whent the motor was hot, sending way more fuel/oil than was needed.
Read the manual and see what you can determine. There are several test you can perform and with the process of elimination, you may be able to find out where your problem is coming from.
I'm pretty sure it's going to be one of your sensors that either isn't working, or is, for some reason, giving a bad or "grounded" signal.
I do have this manual, so you can refer me to a page number if you get stuckl. In the meantime, I'll be going through it again, it's been a while since I read through it. If I find something of interest that may be applicable to your situation, I'll drop it in a post.....

ussaguilar@hotmail.com
03-12-08, 03:19 PM
Hello,
Thanks for the help guys. The model is a 2001 240hp EFI M2 Merc Speedster single engine Seadoo. Snip I see what your saying and I did go thru this section on the service manual, but turned away when I noticed that the manual stated that the TKS is for the 210hp engine. But I'm with you that it has to be electronical I'm using service manual 90-877837 if its of any help for you guys. I'm going to perform the tests on section 2C of the manual today so I can make sure all of that is correct.

ussaguilar@hotmail.com
03-12-08, 06:20 PM
Hello guys,

Well I did section 2C of the service manual like I said I would and everything tested out ok. The only thing that cought my eye was the TPS I removed it to test manually and it tested ok. But what I'm not sure is if when TPS is released it reads 11ohms and when fully engaged its 0ohms my understanding is it should be the other way around or am I mistaken. I read on leads 1 and 2 on my test. I was just going to replace it but thought I'd ask first.

Thank for the help!

seadoosnipe
03-12-08, 07:38 PM
O.K....the TKS is only for the 210 hp.........like I said, it's been a while since I dove into this manual. Not many of them left.
I re-read your 1st post on your problem and that you changed your temp sensor out thinking that might be your gremlin, since it started after that and ran fine.
Now, your back in the same boat. Your TPS test. What I read in the manual on the TPS sensor, their test is with some DD something or another type tester, but it does give a reading of .200-.300 as being normal. Reading about the TPS and the Throttle valve/oil pump syncronizaton, this could be a probable cause. But with the small amount of information you gave on your first post, it could still be one of any thing.
You said you replaced the oils and filters etc....Have you pulled the plugs and grounded them, rolled the engine over to watch the spark? If your engine is spitting and sputtering and not really running good, I'd look to see the plugs are firing well, each one of them. Then, I'd look at the fuel rail. I know the 210hp is carbed, but I didn't read alot into the fuel system of the 240. So to make it quicker, is yours injected? If so, do you think, since it ran well on that start after disconnecting the temp switch, that you got a vapor look in the fuel rail. Here too, if I had spark on all the plugs, then vented the fuel system and find that all the injectors are spitzing (atomizing) fuel, then I'd go into the electricals in detail.
From what I've read on the first post, I wouldn't eliminate a fuel or ignition problem just yet.
Let me know what you find on the spark and fuel. I will try and throw some things in the air for you and try the best I can.
Oh, by the way, your local Sea-Doo repair shop doesn't work on those engines and honestly, I don't think they ever did because it's a Mercury engine. After we check all that we can possibly do, then you may want to look up your local Mercury shop. I'm certain they work on it..............:cheers:
P.S....I noticed your name is listed as USS. Are you in the Navy? On a ship? If so, I'm an old tin can sailer, shellback.

ussaguilar@hotmail.com
03-12-08, 08:52 PM
Thanks snipe,

Yes, my engine is fuel injected. I mention on my first post that the engine runs well without the head temp sensor connected it idels smooth at 2500 - 3000 rpms. Now when fulling around with the TPS I adjusted to .248 which is in range of .200 - .300 like the manul states. After doing this the engine ideled correctly at 1000 - 1100 rpms with the two tan/black wires to the head temp sensor disconected just had the rich fuel mixture like before. Now when I connected the wires it reved up to 3000 rpms for about 10 sec. and back down to 1000 rpms for about 3 sec. and died. Tryed to restart with every thing connected 3 times it started and died almost as soon as it started then it just cranked and eventually burped. I read on in the manual and in one of your post to another member with a 240 EFI, but on a challenger that had a hot start problem. His was the head temp senor I think on mine I think the vapor like you mentioned is kicking in. Because when its cranking and occationally burps its almost like if there is no fuel going in. I believe the disconnected sensor bypasses the vapor system thats why it starts I think.

I read on the manual and on that post I mentioned above that this engine has to temp sensors, but I've only been able to find one which is the one I replaced. I tested the old one and the readings on it are correct except its 15% off instead of 10% like the manual states. I've been looking for the second one but no luck. Would you know where its located and would the second one do the same as the head temp sensor by shuting the fuel to the engine?

P.S. wasn't a sailor but was in the service for 8 yrs Army I had an accident and was medically discharged. Shatered my knee but my replacment works just fine and can still do everything with no problem. Just not combat fit so they say. The screen name is also my e-mail I came up with it cuz one of our home town heros was Freddy Gonzalez and he has a distroyer named after him (USSFREDDYGONZALEZ) and I always wanted one too but didn't get to be a distinguished hero like him so my e-mail was the next best thing.

seadoosnipe
03-12-08, 10:27 PM
There is only one and on the 240 hp, it is on the port head, I believe. In the manual where it is written sensor(s), I believe is because there are two motors. The 240 and the 210. I see in the manual on the test results, that the ohms should be according to that chart, +/- 10% and you say you have 14. So it's out of range, but the question would be, is that really going to affect the operation to the degree your having?........but it's worth considering.
I did find some things interesting. On page 4B-1, there is a continuity test on the wires. Testing each individually with a ground to the block should be no continuity. Then, testing the wires together, there should be no continuity. Then again on page 4B-3, there is a note that states "if the sensor doesn't make clean contact with the head, a rich condition may exist".
You may have already read this, I'm pretty sure you have.
I remember the guy with the "hot start" problem. We thought it was the sensor, but because he had to wait on the part to arrive, we went through a lot of other stuff. He was happy it was the sensor but said that he enjoyed the learning process of his motor. As a matter of fact, he just sent me email a week or so ago. Motor still running good, but he has an issue with a gage now.......
If your safisified with your results so far on the temp sensor, maybe you should move on to the idea that you may have a vapor lock in your fuel system.
Hate to hear of the accident and the knee. Glad to see it's no hinderance to your life. I did 8 years in Uncle Sam's canoe club. I too don't have a boat named after me. But if I did, I'd want it to be the USS NeverSail............LOL

ussaguilar@hotmail.com
03-13-08, 02:45 PM
Well, I did another set of tests on the engine no luck today either. The sensor well I did change it for a new one. I have good spark and gaped plugs injectors are working correctly the only thing I notice is that all plugs with the exception of the top port side pulg was not wet. I did the checks on 4B-1 and 4B-3 had already go thru that but went ahead and did it again. I also noticed while removing the cover to the manifull that the final pump has a leak on the oring but the presure is at 36 psi. Another thing that came to thought was the switch box (DBA) that maybe its somthing on the injector fireing.

ussaguilar@hotmail.com
03-13-08, 07:54 PM
Well I just finished doing every test possible on the service manual and it passes every test. The only thing left to do is pull the injectors and fuel rail to clean it to see if that does anything. We took it out to the river to do some tests there that required the engine been in the water, but there it wouldn't stay on with the temp sensor disconnected like it does with the water hose. Except when it did stay on for a matter of seconds it smoked like a son of a gun. I have come to think maybe the ECU went bad or the map sensor which require some special tools that I don't have avaliable. Any imput there that maybe helpful?

Thanks
Oscar

seadoosnipe
03-13-08, 09:01 PM
Oscar, it seems that your very knowledgable in what your doing. Your reading the manual and conducting the test that we'd all recommend. But it seems that this is trying to be a pain in the butt to figure out.
Go with the fuel rail. See if there is a vapor lock. From there, I myself will be stuck. Reading the manual behind you, doesn't leave very much more for any of us to do. And like you said, the special tools it requires on some, just can't be purchased.
I haven't gone to far into the fuel system yet, but I'm at work all night, so I'm going to be doing some reading. I may post again tonight with some questions..........
Sometimes, the solution is right in front of you and it goes un-noticed. I hope you can fix this.
ADDITIONAL INFO:
Oscar, I’ve been looking more into the fuel injection system and I’ve come across a page on symptoms that occur from a restricted anti-siphon valve (3A-4).
I’ve also been reading about the electric fuel pump primer. This is only used in starting the engine. Once it’s on it’s own power the pulse fuel pump takes over. Here, you can look at a couple things. The electric pump isn’t working, causing a hard start, or the electric is working and once the engine starts, it shuts off so the pulse pump can take over but it goes dead or runs rough because of failure of some sort. If so, this fuel pump looks pretty easy to get into and check diaphragms and so forth. The electric fuel pump has a fuel filter attached to it, that needs to be checked. Also, there are two wires leading out of that pump, I don’t see a specific test on it, but it does say it’s 12 volt, maybe there’s a way you can up-plug it and with your multi meter, have someone turn the key on while you test it with the probe. There is also a 20 amp fuse on that pump. Have you checked all your fuses? I’m pretty sure you’ve already done that but I had to ask.
The fuel pressure regulator regulates the fuel pressure between 34 and 36 psi, so that’s worth investigating.
Starting on page 3D-20 is a complete list of the specifics of the components associated with your fuel system. The more I read about it, the more I’m beginning to believe that this really could be where your problem lies. After going through some of the tests, let me know how your coming out or if you need help interpreting some of the data or procedures.

ussaguilar@hotmail.com
03-24-08, 03:52 PM
Well I tryed everything already but nothing work. I've taken it up to Austin to a mechanic up there to see what he thinks I may have missed.

Thanks for all the help I'll post the news as soon as I here what the problem was.

seadoosnipe
03-24-08, 06:01 PM
Thanks for the update. I hadn't heard from you in a while, so I was wondering how it was going. I know how frustrating it can be, trying to trouble shoot the engine, with limited tools........
Good luck and I hope to hear from you on the repairs.......
I hope you took it to a Mercury repair shop, because the Sea-Doo repair shops don't really know how to repair these engines..........

pineiro
04-12-08, 04:51 PM
My boat is behaving exactly like yours.

:ack:

I love to find out if you were able to fix it.

I spent a lot of money on shop which was not Mercury certified.

Then went to a Mercury certified.

Ran boat twice and lo and behold back to the same.

:confused: